about summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorRenaud <c0bw3b@users.noreply.github.com>2018-11-17 16:25:45 +0100
committerGitHub <noreply@github.com>2018-11-17 16:25:45 +0100
commitc102306c1f4b75984bc9a78c8de77b4988991e42 (patch)
tree053dcdc30a71279100491a087117ad7dfce61588 /pkgs/os-specific
parenta1b8fe8c8fa59024ed87024b54ddba38811010cf (diff)
parentb6c830d2fe820f8c632314c409e1d1fdb68c3b38 (diff)
downloadnixlib-c102306c1f4b75984bc9a78c8de77b4988991e42.tar
nixlib-c102306c1f4b75984bc9a78c8de77b4988991e42.tar.gz
nixlib-c102306c1f4b75984bc9a78c8de77b4988991e42.tar.bz2
nixlib-c102306c1f4b75984bc9a78c8de77b4988991e42.tar.lz
nixlib-c102306c1f4b75984bc9a78c8de77b4988991e42.tar.xz
nixlib-c102306c1f4b75984bc9a78c8de77b4988991e42.tar.zst
nixlib-c102306c1f4b75984bc9a78c8de77b4988991e42.zip
Merge pull request #50435 from c0bw3b/pkg/procdump
procdump: init at 1.0.1
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/procdump/default.nix48
1 files changed, 48 insertions, 0 deletions
diff --git a/pkgs/os-specific/linux/procdump/default.nix b/pkgs/os-specific/linux/procdump/default.nix
new file mode 100644
index 000000000000..aa7d0ec46043
--- /dev/null
+++ b/pkgs/os-specific/linux/procdump/default.nix
@@ -0,0 +1,48 @@
+{ stdenv, fetchFromGitHub, fetchpatch, bash, coreutils, gdb, zlib }:
+
+stdenv.mkDerivation rec {
+  name = "procdump-${version}";
+  version = "1.0.1";
+
+  src = fetchFromGitHub {
+    owner = "Microsoft";
+    repo = "ProcDump-for-Linux";
+    rev = version;
+    sha256 = "1lkm05hq4hl1vadj9ifm18hi7cbf5045xlfxdfbrpsl6kxgfwcc4";
+  };
+
+  nativeBuildInputs = [ zlib ];
+  buildInputs = [ bash coreutils gdb ];
+
+  patches = [
+    # Fix name conflict when built with musl
+    # TODO: check if fixed upstream https://github.com/Microsoft/ProcDump-for-Linux/pull/50
+    (fetchpatch {
+      url = "https://github.com/Microsoft/ProcDump-for-Linux/commit/1b7b50b910f20b463fb628c8213663c8a8d11d0d.patch";
+      sha256 = "0h0dj3gi6hw1wdpc0ih9s4kkagv0d9jzrg602cr85r2z19lmb7yk";
+    })
+  ];
+
+  postPatch = ''
+    substituteInPlace src/CoreDumpWriter.c \
+      --replace '"gcore ' '"${gdb}/bin/gcore ' \
+      --replace '"rm ' '"${coreutils}/bin/rm ' \
+      --replace '/bin/bash' '${bash}/bin/bash'
+  '';
+
+  makeFlags = [
+    "DESTDIR=$(out)"
+    "INSTALLDIR=/bin"
+    "MANDIR=/share/man/man1"
+  ];
+
+  doCheck = false; # needs root
+
+  meta = with stdenv.lib; {
+    description = "A Linux version of the ProcDump Sysinternals tool";
+    homepage = https://github.com/Microsoft/ProcDump-for-Linux;
+    license = licenses.mit;
+    maintainers = with maintainers; [ c0bw3b ];
+    platforms = platforms.linux;
+  };
+}