about summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorgithub-actions[bot] <41898282+github-actions[bot]@users.noreply.github.com>2022-11-30 12:01:13 +0000
committerGitHub <noreply@github.com>2022-11-30 12:01:13 +0000
commitb910b259768a5f5ae6d84347d5ef128bc119067b (patch)
tree22852525297b6c28018f5a18d406466d6af83926 /pkgs/os-specific
parent21716f16b7440b8a646a183d24ade4f059ec40e4 (diff)
parent5b6e95b131ac7617419e5d2cb695f686ba457c30 (diff)
downloadnixlib-b910b259768a5f5ae6d84347d5ef128bc119067b.tar
nixlib-b910b259768a5f5ae6d84347d5ef128bc119067b.tar.gz
nixlib-b910b259768a5f5ae6d84347d5ef128bc119067b.tar.bz2
nixlib-b910b259768a5f5ae6d84347d5ef128bc119067b.tar.lz
nixlib-b910b259768a5f5ae6d84347d5ef128bc119067b.tar.xz
nixlib-b910b259768a5f5ae6d84347d5ef128bc119067b.tar.zst
nixlib-b910b259768a5f5ae6d84347d5ef128bc119067b.zip
Merge master into staging-next
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/bridge-utils/default.nix12
1 files changed, 10 insertions, 2 deletions
diff --git a/pkgs/os-specific/linux/bridge-utils/default.nix b/pkgs/os-specific/linux/bridge-utils/default.nix
index cbbf77c67c8a..a03cb12727ce 100644
--- a/pkgs/os-specific/linux/bridge-utils/default.nix
+++ b/pkgs/os-specific/linux/bridge-utils/default.nix
@@ -1,4 +1,4 @@
-{ lib, stdenv, fetchurl, autoreconfHook }:
+{ lib, stdenv, fetchurl, autoreconfHook, fetchpatch }:
 
 stdenv.mkDerivation rec {
   pname = "bridge-utils";
@@ -9,7 +9,15 @@ stdenv.mkDerivation rec {
     sha256 = "sha256-ph2L5PGhQFxgyO841UTwwYwFszubB+W0sxAzU2Fl5g4=";
   };
 
-  patches = [ ./autoconf-ar.patch ];
+  patches = [
+    ./autoconf-ar.patch
+
+    (fetchpatch {
+      name = "musl-includes.patch";
+      url = "https://git.alpinelinux.org/aports/plain/main/bridge-utils/fix-PATH_MAX-on-ppc64le.patch?id=12c9046eee3a0a35665dc4e280c1f5ae2af5845d";
+      sha256 = "sha256-uY1tgJhcm1DFctg9scmC8e+mgowgz4f/oF0+k+x+jqw=";
+    })
+  ];
 
   nativeBuildInputs = [ autoreconfHook ];