about summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorAdam C. Stephens <2071575+adamcstephens@users.noreply.github.com>2023-12-06 13:55:45 -0500
committerGitHub <noreply@github.com>2023-12-06 13:55:45 -0500
commitb1f7f1ce6d8169fa95041262a808c3e56e4310e1 (patch)
treeaacc4b413ed2962430eaff893e5ab0b81399cc09 /pkgs/os-specific
parent3770e21093dd3080647716d3991fe9458570b0eb (diff)
parentf8160d8856f3f385a060b6324ed62a125b9833d2 (diff)
downloadnixlib-b1f7f1ce6d8169fa95041262a808c3e56e4310e1.tar
nixlib-b1f7f1ce6d8169fa95041262a808c3e56e4310e1.tar.gz
nixlib-b1f7f1ce6d8169fa95041262a808c3e56e4310e1.tar.bz2
nixlib-b1f7f1ce6d8169fa95041262a808c3e56e4310e1.tar.lz
nixlib-b1f7f1ce6d8169fa95041262a808c3e56e4310e1.tar.xz
nixlib-b1f7f1ce6d8169fa95041262a808c3e56e4310e1.tar.zst
nixlib-b1f7f1ce6d8169fa95041262a808c3e56e4310e1.zip
Merge pull request #271689 from adamcstephens/lxc/team
treewide: init lxc team and take ownership of components
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/lxc/default.nix15
-rw-r--r--pkgs/os-specific/linux/lxcfs/default.nix7
2 files changed, 10 insertions, 12 deletions
diff --git a/pkgs/os-specific/linux/lxc/default.nix b/pkgs/os-specific/linux/lxc/default.nix
index 49f16db002f3..4192de0cfeab 100644
--- a/pkgs/os-specific/linux/lxc/default.nix
+++ b/pkgs/os-specific/linux/lxc/default.nix
@@ -6,7 +6,6 @@
 , libcap ? null, systemd ? null
 }:
 
-with lib;
 stdenv.mkDerivation rec {
   pname = "lxc";
   version = "4.0.12";
@@ -48,10 +47,10 @@ stdenv.mkDerivation rec {
     "--disable-api-docs"
     "--with-init-script=none"
     "--with-distro=nixos" # just to be sure it is "unknown"
-  ] ++ optional (libapparmor != null) "--enable-apparmor"
-    ++ optional (libselinux != null) "--enable-selinux"
-    ++ optional (libseccomp != null) "--enable-seccomp"
-    ++ optional (libcap != null) "--enable-capabilities"
+  ] ++ lib.optional (libapparmor != null) "--enable-apparmor"
+    ++ lib.optional (libselinux != null) "--enable-selinux"
+    ++ lib.optional (libseccomp != null) "--enable-seccomp"
+    ++ lib.optional (libcap != null) "--enable-capabilities"
     ++ [
     "--disable-examples"
     "--enable-python"
@@ -90,7 +89,7 @@ stdenv.mkDerivation rec {
   meta = {
     homepage = "https://linuxcontainers.org/";
     description = "Userspace tools for Linux Containers, a lightweight virtualization system";
-    license = licenses.lgpl21Plus;
+    license = lib.licenses.lgpl21Plus;
 
     longDescription = ''
       LXC is the userspace control package for Linux Containers, a
@@ -100,7 +99,7 @@ stdenv.mkDerivation rec {
       mechanisms to Linux’s existing process management infrastructure.
     '';
 
-    platforms = platforms.linux;
-    maintainers = with maintainers; [ ];
+    platforms = lib.platforms.linux;
+    maintainers = lib.teams.lxc.members;
   };
 }
diff --git a/pkgs/os-specific/linux/lxcfs/default.nix b/pkgs/os-specific/linux/lxcfs/default.nix
index 96477c5f4426..28777d36e6be 100644
--- a/pkgs/os-specific/linux/lxcfs/default.nix
+++ b/pkgs/os-specific/linux/lxcfs/default.nix
@@ -2,7 +2,6 @@
 , util-linux, makeWrapper
 , enableDebugBuild ? config.lxcfs.enableDebugBuild or false }:
 
-with lib;
 stdenv.mkDerivation rec {
   pname = "lxcfs";
   version = "4.0.12";
@@ -48,8 +47,8 @@ stdenv.mkDerivation rec {
     description = "FUSE filesystem for LXC";
     homepage = "https://linuxcontainers.org/lxcfs";
     changelog = "https://linuxcontainers.org/lxcfs/news/";
-    license = licenses.asl20;
-    platforms = platforms.linux;
-    maintainers = with maintainers; [ ];
+    license = lib.licenses.asl20;
+    platforms = lib.platforms.linux;
+    maintainers = lib.teams.lxc.members;
   };
 }