about summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorMatthew Bauer <mjbauer95@gmail.com>2019-02-18 20:36:48 -0500
committerMatthew Bauer <mjbauer95@gmail.com>2019-02-18 20:36:48 -0500
commitb1bbd94bb680dbcb1c7b55128d129d5cdd3f81c3 (patch)
treed6eaa4102b8caf97fd924395114f4d9df5d3b4ef /pkgs/os-specific
parenta808baa5e50e83c64b00f772d0070e5989f6afb9 (diff)
parent266315c91d5e4a6d7b8465eb44d4f6af30d90b30 (diff)
downloadnixlib-b1bbd94bb680dbcb1c7b55128d129d5cdd3f81c3.tar
nixlib-b1bbd94bb680dbcb1c7b55128d129d5cdd3f81c3.tar.gz
nixlib-b1bbd94bb680dbcb1c7b55128d129d5cdd3f81c3.tar.bz2
nixlib-b1bbd94bb680dbcb1c7b55128d129d5cdd3f81c3.tar.lz
nixlib-b1bbd94bb680dbcb1c7b55128d129d5cdd3f81c3.tar.xz
nixlib-b1bbd94bb680dbcb1c7b55128d129d5cdd3f81c3.tar.zst
nixlib-b1bbd94bb680dbcb1c7b55128d129d5cdd3f81c3.zip
Merge remote-tracking branch 'NixOS/master' into staging
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/usbutils/default.nix9
1 files changed, 7 insertions, 2 deletions
diff --git a/pkgs/os-specific/linux/usbutils/default.nix b/pkgs/os-specific/linux/usbutils/default.nix
index d58c5a7e67c2..85ef8a1a6ccb 100644
--- a/pkgs/os-specific/linux/usbutils/default.nix
+++ b/pkgs/os-specific/linux/usbutils/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, substituteAll, autoreconfHook, pkgconfig, libusb1, hwdata }:
+{ stdenv, fetchurl, substituteAll, autoreconfHook, pkgconfig, libusb1, hwdata , python3 }:
 
 stdenv.mkDerivation rec {
   name = "usbutils-010";
@@ -16,7 +16,12 @@ stdenv.mkDerivation rec {
   ];
 
   nativeBuildInputs = [ autoreconfHook pkgconfig ];
-  buildInputs = [ libusb1 ];
+  buildInputs = [ libusb1 python3 ];
+
+  outputs = [ "out" "man" "python" ];
+  postInstall = ''
+    moveToOutput "bin/lsusb.py" "$python"
+  '';
 
   meta = with stdenv.lib; {
     homepage = http://www.linux-usb.org/;