about summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2020-03-07 22:31:45 +0100
committerFlorian Klink <flokli@flokli.de>2020-04-17 00:27:30 +0200
commita6710adab21b5fe55d28ba587c3076bcf5a19e2d (patch)
tree0b0de4058bd154db8bc810efc2c36d6cf3b18d18 /pkgs/os-specific
parent4f346cd84929d583d278bfa289b57da594ca09ed (diff)
downloadnixlib-a6710adab21b5fe55d28ba587c3076bcf5a19e2d.tar
nixlib-a6710adab21b5fe55d28ba587c3076bcf5a19e2d.tar.gz
nixlib-a6710adab21b5fe55d28ba587c3076bcf5a19e2d.tar.bz2
nixlib-a6710adab21b5fe55d28ba587c3076bcf5a19e2d.tar.lz
nixlib-a6710adab21b5fe55d28ba587c3076bcf5a19e2d.tar.xz
nixlib-a6710adab21b5fe55d28ba587c3076bcf5a19e2d.tar.zst
nixlib-a6710adab21b5fe55d28ba587c3076bcf5a19e2d.zip
systemd: join 000{3,8}-Don-t-try-to-unmount-nix-or-nix-store.patch
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/systemd/0003-Don-t-try-to-unmount-nix-or-nix-store.patch24
-rw-r--r--pkgs/os-specific/linux/systemd/0008-Don-t-try-to-unmount-nix-or-nix-store.patch28
-rw-r--r--pkgs/os-specific/linux/systemd/default.nix1
3 files changed, 20 insertions, 33 deletions
diff --git a/pkgs/os-specific/linux/systemd/0003-Don-t-try-to-unmount-nix-or-nix-store.patch b/pkgs/os-specific/linux/systemd/0003-Don-t-try-to-unmount-nix-or-nix-store.patch
index a1380a33f458..80b6721cb71e 100644
--- a/pkgs/os-specific/linux/systemd/0003-Don-t-try-to-unmount-nix-or-nix-store.patch
+++ b/pkgs/os-specific/linux/systemd/0003-Don-t-try-to-unmount-nix-or-nix-store.patch
@@ -1,4 +1,4 @@
-From 620047803b70b941606398e77f253645058007dd Mon Sep 17 00:00:00 2001
+From fd9c882581877eef8ba1b34a9502a1ff546b3833 Mon Sep 17 00:00:00 2001
 From: Eelco Dolstra <eelco.dolstra@logicblox.com>
 Date: Fri, 12 Apr 2013 13:16:57 +0200
 Subject: [PATCH 03/27] Don't try to unmount /nix or /nix/store
@@ -7,11 +7,27 @@ They'll still be remounted read-only.
 
 https://github.com/NixOS/nixos/issues/126
 ---
+ src/core/mount.c      | 4 +++-
  src/shutdown/umount.c | 2 ++
- 1 file changed, 2 insertions(+)
+ 2 files changed, 5 insertions(+), 1 deletion(-)
 
+diff --git a/src/core/mount.c b/src/core/mount.c
+index eef362f0c8..600393ffc1 100644
+--- a/src/core/mount.c
++++ b/src/core/mount.c
+@@ -409,7 +409,9 @@ static bool mount_is_extrinsic(Mount *m) {
+ 
+         if (PATH_IN_SET(m->where,  /* Don't bother with the OS data itself */
+                         "/",
+-                        "/usr"))
++                        "/usr",
++                        "/nix/",
++                        "/nix/store"))
+                 return true;
+ 
+         if (PATH_STARTSWITH_SET(m->where,
 diff --git a/src/shutdown/umount.c b/src/shutdown/umount.c
-index 00e268855d..08f3590f2a 100644
+index 2d07d3d6c1..8b112f464e 100644
 --- a/src/shutdown/umount.c
 +++ b/src/shutdown/umount.c
 @@ -373,6 +373,8 @@ static int delete_dm(dev_t devnum) {
@@ -24,5 +40,5 @@ index 00e268855d..08f3590f2a 100644
                  || path_equal(path, "/usr")
  #endif
 -- 
-2.24.1
+2.25.1
 
diff --git a/pkgs/os-specific/linux/systemd/0008-Don-t-try-to-unmount-nix-or-nix-store.patch b/pkgs/os-specific/linux/systemd/0008-Don-t-try-to-unmount-nix-or-nix-store.patch
deleted file mode 100644
index fedaeb796718..000000000000
--- a/pkgs/os-specific/linux/systemd/0008-Don-t-try-to-unmount-nix-or-nix-store.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 5b2eafc51fa2d98f03fd341176d9a7accc0259ae Mon Sep 17 00:00:00 2001
-From: Eelco Dolstra <eelco.dolstra@logicblox.com>
-Date: Mon, 11 May 2015 15:30:46 +0200
-Subject: [PATCH 08/27] Don't try to unmount /nix or /nix/store
-
-33f458625f2a9d201263bd1b81b1c56f4a077e80 wasn't enough.
----
- src/core/mount.c | 22 +++++++++++++++++-----
- 1 file changed, 17 insertions(+), 5 deletions(-)
-
-diff --git a/src/core/mount.c b/src/core/mount.c
-index 959b8fbed2..5e4c4a9767 100644
---- a/src/core/mount.c
-+++ b/src/core/mount.c
-@@ -409,7 +409,9 @@ static bool mount_is_extrinsic(Mount *m) {
- 
-         if (PATH_IN_SET(m->where,  /* Don't bother with the OS data itself */
-                         "/",
--                        "/usr"))
-+                        "/usr",
-+                        "/nix/",
-+                        "/nix/store"))
-                 return true;
- 
-         if (PATH_STARTSWITH_SET(m->where,
--- 
-2.24.1
-
diff --git a/pkgs/os-specific/linux/systemd/default.nix b/pkgs/os-specific/linux/systemd/default.nix
index 7079e21f3097..427c48a32e3b 100644
--- a/pkgs/os-specific/linux/systemd/default.nix
+++ b/pkgs/os-specific/linux/systemd/default.nix
@@ -49,7 +49,6 @@ in stdenv.mkDerivation {
     ./0005-kmod-static-nodes.service-Don-t-require-lib-modules.patch
     ./0006-Look-for-fsck-in-the-right-place.patch
     ./0007-Add-some-NixOS-specific-unit-directories.patch
-    ./0008-Don-t-try-to-unmount-nix-or-nix-store.patch
     ./0009-Get-rid-of-a-useless-message-in-user-sessions.patch
     ./0010-hostnamed-localed-timedated-disable-methods-that-cha.patch
     ./0011-Fix-hwdb-paths.patch