about summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2022-12-04 16:38:30 +0100
committerGitHub <noreply@github.com>2022-12-04 16:38:30 +0100
commita5878154938d3bb6d06ecc9311af253d01945370 (patch)
treec0d712a81bbf4d95e074f242e13f6a638d22323f /pkgs/os-specific
parent5f6f7b474d330f4a7a5b0e75eb86e0004f56b89e (diff)
parent3e5b243639786781dbdfcf5a9faba41b1364406a (diff)
downloadnixlib-a5878154938d3bb6d06ecc9311af253d01945370.tar
nixlib-a5878154938d3bb6d06ecc9311af253d01945370.tar.gz
nixlib-a5878154938d3bb6d06ecc9311af253d01945370.tar.bz2
nixlib-a5878154938d3bb6d06ecc9311af253d01945370.tar.lz
nixlib-a5878154938d3bb6d06ecc9311af253d01945370.tar.xz
nixlib-a5878154938d3bb6d06ecc9311af253d01945370.tar.zst
nixlib-a5878154938d3bb6d06ecc9311af253d01945370.zip
Merge pull request #189078 from martinetd/bpftrace
bcc: 0.24.0 -> 0.25.0; bpftrace: 0.15.0 -> 0.16.0
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/bcc/default.nix4
-rw-r--r--pkgs/os-specific/linux/bpftrace/default.nix46
-rw-r--r--pkgs/os-specific/linux/oci-seccomp-bpf-hook/default.nix4
3 files changed, 8 insertions, 46 deletions
diff --git a/pkgs/os-specific/linux/bcc/default.nix b/pkgs/os-specific/linux/bcc/default.nix
index bb042e31c0e8..d8026fa0d696 100644
--- a/pkgs/os-specific/linux/bcc/default.nix
+++ b/pkgs/os-specific/linux/bcc/default.nix
@@ -7,7 +7,7 @@
 
 python.pkgs.buildPythonApplication rec {
   pname = "bcc";
-  version = "0.24.0";
+  version = "0.25.0";
 
   disabled = !stdenv.isLinux;
 
@@ -15,7 +15,7 @@ python.pkgs.buildPythonApplication rec {
     owner = "iovisor";
     repo = "bcc";
     rev = "v${version}";
-    sha256 = "sha256-5Nq6LmphiyiiIyru/P2rCCmA25cwJIWn08oK1+eM3cQ=";
+    sha256 = "sha256-05FQWBxFI8bxjm6vDCoEqqpAd4Agn84M28P3G6F3tag=";
   };
   format = "other";
 
diff --git a/pkgs/os-specific/linux/bpftrace/default.nix b/pkgs/os-specific/linux/bpftrace/default.nix
index 2772c587ca89..0c6a6f648672 100644
--- a/pkgs/os-specific/linux/bpftrace/default.nix
+++ b/pkgs/os-specific/linux/bpftrace/default.nix
@@ -1,4 +1,4 @@
-{ lib, stdenv, fetchFromGitHub, fetchpatch
+{ lib, stdenv, fetchFromGitHub
 , cmake, pkg-config, flex, bison
 , llvmPackages, elfutils
 , libbfd, libbpf, libopcodes, bcc
@@ -9,44 +9,15 @@
 
 stdenv.mkDerivation rec {
   pname = "bpftrace";
-  version = "0.15.0";
-
-  # Cherry-picked from merged PR, remove this hook on next update
-  # https://github.com/iovisor/bpftrace/pull/2242
-  # Cannot `fetchpatch` such pure renaming diff since
-  # https://github.com/iovisor/bpftrace/commit/2df807dbae4037aa8bf0afc03f52fb3f6321c62a.patch
-  # does not contain any diff in unified format but just this instead:
-  #   ...
-  #   man/man8/{bashreadline.8 => bashreadline.bt.8}     | 0
-  #   ...
-  #   35 files changed, 0 insertions(+), 0 deletions(-)
-  #   rename man/man8/{bashreadline.8 => bashreadline.bt.8} (100%)
-  #   ...
-  # on witch `fetchpatch` fails with
-  #   error: Normalized patch '/build/patch' is empty (while the fetched file was not)!
-  #   Did you maybe fetch a HTML representation of a patch instead of a raw patch?
-  postUnpack = ''
-    rename .8 .bt.8 "$sourceRoot"/man/man8/*.8
-  '';
+  version = "0.16.0";
 
   src = fetchFromGitHub {
     owner  = "iovisor";
     repo   = "bpftrace";
     rev    = "v${version}";
-    sha256 = "sha256-9adZAKSn00W2yNwVDbVB1/O5Y+10c4EkVJGCHyd4Tgg=";
+    sha256 = "sha256-S43KS/qpzxU+Sgkcud4Cyx4yRjaT6SZzLv6R6bg5I2w=";
   };
 
-  patches = [
-    # Pull upstream fix for binutils-2.39:
-    #   https://github.com/iovisor/bpftrace/pull/2328
-    (fetchpatch {
-      name = "binutils-2.39.patch";
-      url = "https://github.com/iovisor/bpftrace/commit/3be6e708d514d3378a4fe985ab907643ecbc77ee.patch";
-      sha256 = "sha256-WWEh8ViGw8053nEG/29KeKEHV5ossWPtL/AAV/l+pnY=";
-      excludes = [ "CHANGELOG.md" ];
-    })
-  ];
-
   buildInputs = with llvmPackages;
     [ llvm libclang
       elfutils bcc
@@ -64,22 +35,13 @@ stdenv.mkDerivation rec {
   cmakeFlags =
     [ "-DBUILD_TESTING=FALSE"
       "-DLIBBCC_INCLUDE_DIRS=${bcc}/include"
+      "-DINSTALL_TOOL_DOCS=off"
     ];
 
-  # nuke the example/reference output .txt files, for the included tools,
-  # stuffed inside $out. we don't need them at all.
-  # (see "Allow skipping examples" for a potential option
-  #  https://github.com/iovisor/bpftrace/pull/2256)
-  #
   # Pull BPF scripts into $PATH (next to their bcc program equivalents), but do
   # not move them to keep `${pkgs.bpftrace}/share/bpftrace/tools/...` working.
-  # (remove `chmod` once a new release "Add executable permission to tools"
-  #  https://github.com/iovisor/bpftrace/commit/77e524e6d276216ed6a6e1984cf204418db07c78)
   postInstall = ''
-    rm -rf $out/share/bpftrace/tools/doc
-
     ln -s $out/share/bpftrace/tools/*.bt $out/bin/
-    chmod +x $out/bin/*.bt
   '';
 
   outputs = [ "out" "man" ];
diff --git a/pkgs/os-specific/linux/oci-seccomp-bpf-hook/default.nix b/pkgs/os-specific/linux/oci-seccomp-bpf-hook/default.nix
index 75f210f4c228..d6f8b4c9533f 100644
--- a/pkgs/os-specific/linux/oci-seccomp-bpf-hook/default.nix
+++ b/pkgs/os-specific/linux/oci-seccomp-bpf-hook/default.nix
@@ -10,12 +10,12 @@
 
 buildGoModule rec {
   pname = "oci-seccomp-bpf-hook";
-  version = "1.2.6";
+  version = "1.2.8";
   src = fetchFromGitHub {
     owner = "containers";
     repo = "oci-seccomp-bpf-hook";
     rev = "v${version}";
-    sha256 = "sha256-+HGVxPBCPIdFwzZf3lFE0MWA2xMKsHQkfDo4zyNgzpg=";
+    sha256 = "sha256-0SSiVnCWs3NLefnmZn1oCc7nwTrSzDsyjPszVBRQVH0=";
   };
   vendorSha256 = null;