about summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorAlyssa Ross <hi@alyssa.is>2024-01-13 11:12:02 +0100
committerAlyssa Ross <hi@alyssa.is>2024-01-19 13:11:51 +0100
commita455c5fb3ee513e2f443838a0e84d52b035adb67 (patch)
tree2a5aa0efb53f65c11799d9fa5dc363e68b3999c4 /pkgs/os-specific
parentfa66a7a3b482560a8321cf251a29725c5e703f81 (diff)
downloadnixlib-a455c5fb3ee513e2f443838a0e84d52b035adb67.tar
nixlib-a455c5fb3ee513e2f443838a0e84d52b035adb67.tar.gz
nixlib-a455c5fb3ee513e2f443838a0e84d52b035adb67.tar.bz2
nixlib-a455c5fb3ee513e2f443838a0e84d52b035adb67.tar.lz
nixlib-a455c5fb3ee513e2f443838a0e84d52b035adb67.tar.xz
nixlib-a455c5fb3ee513e2f443838a0e84d52b035adb67.tar.zst
nixlib-a455c5fb3ee513e2f443838a0e84d52b035adb67.zip
Revert "linux: drop XEN on 32-bit"
This reverts commit 096639c548e2b0256309c92c53542e052eaa3761.

The kernel bug that broke this has now been fixed, and we now set
CONFIG_X86_GENERIC, which would have stopped us being affected by it anyway.
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/kernel/common-config.nix34
1 files changed, 17 insertions, 17 deletions
diff --git a/pkgs/os-specific/linux/kernel/common-config.nix b/pkgs/os-specific/linux/kernel/common-config.nix
index 2aacb88dc87e..e9aba32aa225 100644
--- a/pkgs/os-specific/linux/kernel/common-config.nix
+++ b/pkgs/os-specific/linux/kernel/common-config.nix
@@ -685,23 +685,23 @@ let
       VBOXGUEST = option no;
       DRM_VBOXVIDEO = option no;
 
-      XEN                         = mkIf stdenv.is64bit (option yes);
-      XEN_DOM0                    = mkIf stdenv.is64bit (option yes);
-      PCI_XEN                     = mkIf stdenv.is64bit (option yes);
-      HVC_XEN                     = mkIf stdenv.is64bit (option yes);
-      HVC_XEN_FRONTEND            = mkIf stdenv.is64bit (option yes);
-      XEN_SYS_HYPERVISOR          = mkIf stdenv.is64bit (option yes);
-      SWIOTLB_XEN                 = mkIf stdenv.is64bit (option yes);
-      XEN_BACKEND                 = mkIf stdenv.is64bit (option yes);
-      XEN_BALLOON                 = mkIf stdenv.is64bit (option yes);
-      XEN_BALLOON_MEMORY_HOTPLUG  = mkIf stdenv.is64bit (option yes);
-      XEN_EFI                     = mkIf stdenv.is64bit (option yes);
-      XEN_HAVE_PVMMU              = mkIf stdenv.is64bit (option yes);
-      XEN_MCE_LOG                 = mkIf stdenv.is64bit (option yes);
-      XEN_PVH                     = mkIf stdenv.is64bit (option yes);
-      XEN_PVHVM                   = mkIf stdenv.is64bit (option yes);
-      XEN_SAVE_RESTORE            = mkIf stdenv.is64bit (option yes);
-      XEN_SELFBALLOONING          = mkIf stdenv.is64bit (whenOlder "5.3" yes);
+      XEN                         = option yes;
+      XEN_DOM0                    = option yes;
+      PCI_XEN                     = option yes;
+      HVC_XEN                     = option yes;
+      HVC_XEN_FRONTEND            = option yes;
+      XEN_SYS_HYPERVISOR          = option yes;
+      SWIOTLB_XEN                 = option yes;
+      XEN_BACKEND                 = option yes;
+      XEN_BALLOON                 = option yes;
+      XEN_BALLOON_MEMORY_HOTPLUG  = option yes;
+      XEN_EFI                     = option yes;
+      XEN_HAVE_PVMMU              = option yes;
+      XEN_MCE_LOG                 = option yes;
+      XEN_PVH                     = option yes;
+      XEN_PVHVM                   = option yes;
+      XEN_SAVE_RESTORE            = option yes;
+      XEN_SELFBALLOONING          = whenOlder "5.3" yes;
 
       # Enable device detection on virtio-mmio hypervisors
       VIRTIO_MMIO_CMDLINE_DEVICES = yes;