about summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorJoachim Fasting <joachifm@fastmail.fm>2017-04-30 01:52:17 +0200
committerJoachim Fasting <joachifm@fastmail.fm>2017-05-06 19:47:27 +0200
commita04d8532c2385ab3e217d06bd3592d0386b6caa3 (patch)
tree16613b19d22351de9e45ee55125c0a8a4ceb6bc5 /pkgs/os-specific
parent22cffa0716de2f3cda9d262a4b7861d534ea9805 (diff)
downloadnixlib-a04d8532c2385ab3e217d06bd3592d0386b6caa3.tar
nixlib-a04d8532c2385ab3e217d06bd3592d0386b6caa3.tar.gz
nixlib-a04d8532c2385ab3e217d06bd3592d0386b6caa3.tar.bz2
nixlib-a04d8532c2385ab3e217d06bd3592d0386b6caa3.tar.lz
nixlib-a04d8532c2385ab3e217d06bd3592d0386b6caa3.tar.xz
nixlib-a04d8532c2385ab3e217d06bd3592d0386b6caa3.tar.zst
nixlib-a04d8532c2385ab3e217d06bd3592d0386b6caa3.zip
linux: support using gcc plugins
linux 4.8 onwards support gcc plugins.  This patch adds build inputs
required to make use of gcc plugins to the generic kernel build
environment.
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/kernel/manual-config.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/pkgs/os-specific/linux/kernel/manual-config.nix b/pkgs/os-specific/linux/kernel/manual-config.nix
index 55162e54f4dc..3466cafa2660 100644
--- a/pkgs/os-specific/linux/kernel/manual-config.nix
+++ b/pkgs/os-specific/linux/kernel/manual-config.nix
@@ -1,4 +1,6 @@
-{ stdenv, runCommand, nettools, bc, perl, kmod, openssl, writeTextFile, ubootChooser }:
+{ stdenv, runCommand, nettools, bc, perl, gmp, libmpc, mpfr, kmod, openssl
+, writeTextFile, ubootChooser
+}:
 
 let
   readConfig = configfile: import (runCommand "config.nix" {} ''
@@ -219,7 +221,7 @@ stdenv.mkDerivation ((drvAttrs config stdenv.platform (kernelPatches ++ nativeKe
 
   enableParallelBuilding = true;
 
-  nativeBuildInputs = [ perl bc nettools openssl ] ++ optional (stdenv.platform.uboot != null)
+  nativeBuildInputs = [ perl bc nettools openssl gmp libmpc mpfr ] ++ optional (stdenv.platform.uboot != null)
     (ubootChooser stdenv.platform.uboot);
 
   hardeningDisable = [ "bindnow" "format" "fortify" "stackprotector" "pic" ];