about summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorOrivej Desh (NixOS) <40807862+orivej-nixos@users.noreply.github.com>2024-02-19 22:39:47 +0000
committerGitHub <noreply@github.com>2024-02-19 22:39:47 +0000
commit9ff5d9075a17e5e96f26cd2f3bbe76e01cce62c4 (patch)
tree926211d4b1472a51f47fdd38790a03abdd10593b /pkgs/os-specific
parent51cf4c4d0c221b9ed42ff8a4a3c9a6b579068307 (diff)
parent204c33e6e1ce5869e033b22a93e0912e4a7c9766 (diff)
downloadnixlib-9ff5d9075a17e5e96f26cd2f3bbe76e01cce62c4.tar
nixlib-9ff5d9075a17e5e96f26cd2f3bbe76e01cce62c4.tar.gz
nixlib-9ff5d9075a17e5e96f26cd2f3bbe76e01cce62c4.tar.bz2
nixlib-9ff5d9075a17e5e96f26cd2f3bbe76e01cce62c4.tar.lz
nixlib-9ff5d9075a17e5e96f26cd2f3bbe76e01cce62c4.tar.xz
nixlib-9ff5d9075a17e5e96f26cd2f3bbe76e01cce62c4.tar.zst
nixlib-9ff5d9075a17e5e96f26cd2f3bbe76e01cce62c4.zip
Merge pull request #287435 from orivej/linux-rt_6_6
linux-rt_6_6: init at 6.6.15-rt22
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/kernel/linux-rt-6.6.nix45
1 files changed, 45 insertions, 0 deletions
diff --git a/pkgs/os-specific/linux/kernel/linux-rt-6.6.nix b/pkgs/os-specific/linux/kernel/linux-rt-6.6.nix
new file mode 100644
index 000000000000..b586dc392a6c
--- /dev/null
+++ b/pkgs/os-specific/linux/kernel/linux-rt-6.6.nix
@@ -0,0 +1,45 @@
+{ lib, buildLinux, fetchurl
+, kernelPatches ? [ ]
+, structuredExtraConfig ? {}
+, extraMeta ? {}
+, argsOverride ? {}
+, ... } @ args:
+
+let
+  version = "6.6.15-rt22"; # updated by ./update-rt.sh
+  branch = lib.versions.majorMinor version;
+  kversion = builtins.elemAt (lib.splitString "-" version) 0;
+in buildLinux (args // {
+  inherit version;
+
+  # modDirVersion needs a patch number, change X.Y-rtZ to X.Y.0-rtZ.
+  modDirVersion = if (builtins.match "[^.]*[.][^.]*-.*" version) == null then version
+    else lib.replaceStrings ["-"] [".0-"] version;
+
+  src = fetchurl {
+    url = "mirror://kernel/linux/kernel/v6.x/linux-${kversion}.tar.xz";
+    sha256 = "1ajzby6isqji1xlp660m4qj2i2xs003vsjp1jspziwl7hrzhqadb";
+  };
+
+  kernelPatches = let rt-patch = {
+    name = "rt";
+    patch = fetchurl {
+      url = "mirror://kernel/linux/kernel/projects/rt/${branch}/older/patch-${version}.patch.xz";
+      sha256 = "0dr4lb6f95vj8vzhlvy353dk6k694f1s6qfxr10m48hzyyqyaxdy";
+    };
+  }; in [ rt-patch ] ++ kernelPatches;
+
+  structuredExtraConfig = with lib.kernel; {
+    PREEMPT_RT = yes;
+    # Fix error: unused option: PREEMPT_RT.
+    EXPERT = yes; # PREEMPT_RT depends on it (in kernel/Kconfig.preempt)
+    # Fix error: option not set correctly: PREEMPT_VOLUNTARY (wanted 'y', got 'n').
+    PREEMPT_VOLUNTARY = lib.mkForce no; # PREEMPT_RT deselects it.
+    # Fix error: unused option: RT_GROUP_SCHED.
+    RT_GROUP_SCHED = lib.mkForce (option no); # Removed by sched-disable-rt-group-sched-on-rt.patch.
+  } // structuredExtraConfig;
+
+  extraMeta = extraMeta // {
+    inherit branch;
+  };
+} // argsOverride)