about summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorRyan Lahfa <masterancpp@gmail.com>2023-10-23 11:05:40 +0100
committerGitHub <noreply@github.com>2023-10-23 11:05:40 +0100
commit98afbaa34b7c5ed45a9a477010fcc0e314ac81f3 (patch)
tree5f66fea3e445c5b7e1ed9816ce6c949f2124cee5 /pkgs/os-specific
parentd1ee91c22de97fca39ce0d93041dcec8430beec1 (diff)
parent007d92d830b2ca82f518a3c1f69fbfea2db8f771 (diff)
downloadnixlib-98afbaa34b7c5ed45a9a477010fcc0e314ac81f3.tar
nixlib-98afbaa34b7c5ed45a9a477010fcc0e314ac81f3.tar.gz
nixlib-98afbaa34b7c5ed45a9a477010fcc0e314ac81f3.tar.bz2
nixlib-98afbaa34b7c5ed45a9a477010fcc0e314ac81f3.tar.lz
nixlib-98afbaa34b7c5ed45a9a477010fcc0e314ac81f3.tar.xz
nixlib-98afbaa34b7c5ed45a9a477010fcc0e314ac81f3.tar.zst
nixlib-98afbaa34b7c5ed45a9a477010fcc0e314ac81f3.zip
Merge pull request #250662 from Majiir/zfs-armv7
zfs: add armv7 to supported platforms
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/zfs/generic.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/pkgs/os-specific/linux/zfs/generic.nix b/pkgs/os-specific/linux/zfs/generic.nix
index 7bb4a1b7496e..8adbb8cab8f9 100644
--- a/pkgs/os-specific/linux/zfs/generic.nix
+++ b/pkgs/os-specific/linux/zfs/generic.nix
@@ -202,15 +202,15 @@ stdenv'.mkDerivation {
     changelog = "https://github.com/openzfs/zfs/releases/tag/zfs-${version}";
     license = lib.licenses.cddl;
 
-    # The case-block for TARGET_CPU has branches for only five CPU families,
+    # The case-block for TARGET_CPU has branches for only some CPU families,
     # which prevents ZFS from building on any other platform.  Since the NixOS
     # `boot.zfs.enabled` property is `readOnly`, excluding platforms where ZFS
     # does not build is the only way to produce a NixOS installer on such
     # platforms.
-    # https://github.com/openzfs/zfs/blob/6a6bd493988c75331deab06e5352a9bed035a87d/config/always-arch.m4#L16
+    # https://github.com/openzfs/zfs/blob/6723d1110f6daf93be93db74d5ea9f6b64c9bce5/config/always-arch.m4#L12
     platforms =
       with lib.systems.inspect.patterns;
-      map (p: p // isLinux) [ isx86_32 isx86_64 isPower isAarch64 isSparc ];
+      map (p: p // isLinux) ([ isx86_32 isx86_64 isPower isAarch64 isSparc ] ++ isArmv7);
 
     maintainers = with lib.maintainers; [ jcumming jonringer globin raitobezarius ];
     mainProgram = "zfs";