about summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authora-n-n-a-l-e-e <150648636+a-n-n-a-l-e-e@users.noreply.github.com>2024-01-15 20:21:14 -0800
committerGitHub <noreply@github.com>2024-01-15 20:21:14 -0800
commit8c6fb2212db222de46ff0d7e2eb786301e58fff9 (patch)
treeedf46145c513c598504ab50678cdfba6ac436989 /pkgs/os-specific
parentac91019d4412be0f68698b2956d0a836535fefa0 (diff)
parentcd5fd58b7213553692e9552a4d0185e034e22b4f (diff)
downloadnixlib-8c6fb2212db222de46ff0d7e2eb786301e58fff9.tar
nixlib-8c6fb2212db222de46ff0d7e2eb786301e58fff9.tar.gz
nixlib-8c6fb2212db222de46ff0d7e2eb786301e58fff9.tar.bz2
nixlib-8c6fb2212db222de46ff0d7e2eb786301e58fff9.tar.lz
nixlib-8c6fb2212db222de46ff0d7e2eb786301e58fff9.tar.xz
nixlib-8c6fb2212db222de46ff0d7e2eb786301e58fff9.tar.zst
nixlib-8c6fb2212db222de46ff0d7e2eb786301e58fff9.zip
Merge pull request #281143 from ethorsoe/trace-cmd-path
trace-cmd: search path properly when running commands
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/trace-cmd/default.nix10
1 files changed, 9 insertions, 1 deletions
diff --git a/pkgs/os-specific/linux/trace-cmd/default.nix b/pkgs/os-specific/linux/trace-cmd/default.nix
index 7bdadc2cea15..d19754cdb5e0 100644
--- a/pkgs/os-specific/linux/trace-cmd/default.nix
+++ b/pkgs/os-specific/linux/trace-cmd/default.nix
@@ -1,4 +1,4 @@
-{ lib, stdenv, fetchzip, pkg-config, asciidoc, xmlto, docbook_xsl, docbook_xml_dtd_45, libxslt, libtraceevent, libtracefs, zstd, sourceHighlight }:
+{ lib, stdenv, fetchpatch, fetchzip, pkg-config, asciidoc, xmlto, docbook_xsl, docbook_xml_dtd_45, libxslt, libtraceevent, libtracefs, zstd, sourceHighlight }:
 stdenv.mkDerivation rec {
   pname = "trace-cmd";
   version = "3.2";
@@ -8,6 +8,14 @@ stdenv.mkDerivation rec {
     hash   = "sha256-rTcaaEQ3Y4cneNnZSGiMZNp+Z7dyAa3oNTNMAEXr28g=";
   };
 
+  patches = [
+    # Upstream patches to be released in the next version
+    (fetchpatch {
+      sha256 = "sha256-eGuHODm29M7rbGYsyXUPoNe1xsIG3eJYhwXQDakRJHA=";
+      url = "https://git.kernel.org/pub/scm/utils/trace-cmd/trace-cmd.git/patch/?id=6b07a7df871342068604b204711ab741d421d051";
+    })
+  ];
+
   # Don't build and install html documentation
   postPatch = ''
     sed -i -e '/^all:/ s/html//' -e '/^install:/ s/install-html//' \