about summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorFrederik Rietdijk <freddyrietdijk@fridh.nl>2020-02-05 19:09:27 +0100
committerGitHub <noreply@github.com>2020-02-05 19:09:27 +0100
commit87a19e9048773d5a363679617406ad148d36c3b8 (patch)
tree3c4071bb4a5d2593fbf1bd6209ed8c60b727f938 /pkgs/os-specific
parentf720f1413755ea9fcc7915fd5a87bf1f0c2a2dfa (diff)
parent76a439239eb310d9ad76d998b34d5d3bc0e37acb (diff)
downloadnixlib-87a19e9048773d5a363679617406ad148d36c3b8.tar
nixlib-87a19e9048773d5a363679617406ad148d36c3b8.tar.gz
nixlib-87a19e9048773d5a363679617406ad148d36c3b8.tar.bz2
nixlib-87a19e9048773d5a363679617406ad148d36c3b8.tar.lz
nixlib-87a19e9048773d5a363679617406ad148d36c3b8.tar.xz
nixlib-87a19e9048773d5a363679617406ad148d36c3b8.tar.zst
nixlib-87a19e9048773d5a363679617406ad148d36c3b8.zip
Merge pull request #79119 from NixOS/staging-next
Staging next
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/darwin/apple-sdk/default.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/pkgs/os-specific/darwin/apple-sdk/default.nix b/pkgs/os-specific/darwin/apple-sdk/default.nix
index 9890d385259c..89c13d0b92d7 100644
--- a/pkgs/os-specific/darwin/apple-sdk/default.nix
+++ b/pkgs/os-specific/darwin/apple-sdk/default.nix
@@ -1,10 +1,15 @@
 { stdenv, fetchurl, xar, cpio, pkgs, python3, pbzx, lib }:
 
+let version = "10.12"; in
+
+# Ensure appleSdkVersion is up to date.
+assert stdenv.isDarwin -> stdenv.appleSdkVersion == version;
+
 let
   # sadly needs to be exported because security_tool needs it
   sdk = stdenv.mkDerivation rec {
-    version = "10.12";
     pname = "MacOS_SDK";
+    inherit version;
 
     # This URL comes from https://swscan.apple.com/content/catalogs/others/index-10.12.merged-1.sucatalog, which we found by:
     #  1. Google: site:swscan.apple.com and look for a name that seems appropriate for your version