about summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorWilliam A. Kennington III <william@wkennington.com>2015-08-31 10:28:18 -0700
committerWilliam A. Kennington III <william@wkennington.com>2015-08-31 10:28:18 -0700
commit7735c6cb0ed8bc28fc63a2009b5674b52f1e607b (patch)
treeba5cf48c9424aa31c816e60912acd19c0c110b3f /pkgs/os-specific
parent461a9ee562cb93b15b7dd495b6d1029ea42d6e30 (diff)
parent6f19418b654b440f9b7e40fa898f3681f51bca0d (diff)
downloadnixlib-7735c6cb0ed8bc28fc63a2009b5674b52f1e607b.tar
nixlib-7735c6cb0ed8bc28fc63a2009b5674b52f1e607b.tar.gz
nixlib-7735c6cb0ed8bc28fc63a2009b5674b52f1e607b.tar.bz2
nixlib-7735c6cb0ed8bc28fc63a2009b5674b52f1e607b.tar.lz
nixlib-7735c6cb0ed8bc28fc63a2009b5674b52f1e607b.tar.xz
nixlib-7735c6cb0ed8bc28fc63a2009b5674b52f1e607b.tar.zst
nixlib-7735c6cb0ed8bc28fc63a2009b5674b52f1e607b.zip
Merge branch 'master.upstream' into staging.upstream
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/conky/default.nix82
-rw-r--r--pkgs/os-specific/linux/freefall/default.nix32
-rw-r--r--pkgs/os-specific/linux/kernel/linux-4.2.nix18
-rw-r--r--pkgs/os-specific/linux/musl/default.nix4
-rw-r--r--pkgs/os-specific/linux/nvidia-x11/default.nix8
-rw-r--r--pkgs/os-specific/linux/nvidia-x11/nvidia-4.2.patch26
-rw-r--r--pkgs/os-specific/linux/pax-utils/default.nix4
-rw-r--r--pkgs/os-specific/linux/policycoreutils/default.nix2
-rw-r--r--pkgs/os-specific/linux/policycoreutils/fix-printf-type.patch12
-rw-r--r--pkgs/os-specific/linux/spl/git.nix6
-rw-r--r--pkgs/os-specific/linux/trace-cmd/default.nix4
-rw-r--r--pkgs/os-specific/linux/xf86-input-wacom/default.nix4
-rw-r--r--pkgs/os-specific/linux/zfs/git.nix6
13 files changed, 122 insertions, 86 deletions
diff --git a/pkgs/os-specific/linux/conky/default.nix b/pkgs/os-specific/linux/conky/default.nix
index c54d4aa6319b..60bfe0930171 100644
--- a/pkgs/os-specific/linux/conky/default.nix
+++ b/pkgs/os-specific/linux/conky/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, pkgconfig
+{ stdenv, fetchFromGitHub, pkgconfig, cmake
 
 # dependencies
 , glib
@@ -7,23 +7,17 @@
 , mpdSupport          ? true
 , ibmSupport          ? true # IBM/Lenovo notebooks
 
-# This should be optional, but it is not due to a bug in conky
-# Please, try to make it optional again on update
-, ncurses
-#, ncursesSupport      ? true      , ncurses       ? null
-
 # optional features with extra dependencies
+, ncursesSupport      ? true      , ncurses       ? null
 , x11Support          ? true      , x11           ? null
 , xdamageSupport      ? x11Support, libXdamage    ? null
 , imlib2Support       ? x11Support, imlib2        ? null
-, luaSupport          ? true      , lua           ? null
 
+, luaSupport          ? true      , lua           ? null
 , luaImlib2Support    ? luaSupport && imlib2Support
 , luaCairoSupport     ? luaSupport && x11Support, cairo ? null
 , toluapp ? null
 
-, alsaSupport         ? true      , alsaLib       ? null
-
 , wirelessSupport     ? true      , wirelesstools ? null
 
 , curlSupport         ? true      , curl ? null
@@ -33,7 +27,7 @@
 , libxml2 ? null
 }:
 
-#assert ncursesSupport      -> ncurses != null;
+assert ncursesSupport      -> ncurses != null;
 
 assert x11Support          -> x11 != null;
 assert xdamageSupport      -> x11Support && libXdamage != null;
@@ -46,8 +40,6 @@ assert luaCairoSupport     -> luaSupport && toluapp != null
 assert luaCairoSupport || luaImlib2Support
                            -> lua.luaversion == "5.1";
 
-assert alsaSupport         -> alsaLib != null;
-
 assert wirelessSupport     -> wirelesstools != null;
 
 assert curlSupport         -> curl != null;
@@ -58,62 +50,52 @@ assert weatherXoapSupport  -> curlSupport && libxml2 != null;
 with stdenv.lib;
 
 stdenv.mkDerivation rec {
-  name = "conky-1.9.0";
-
-  src = fetchurl {
-    url = "mirror://sourceforge/conky/${name}.tar.bz2";
-    sha256 = "0vxvjmi3cdvnp994sv5zcdyncfn0mlxa71p2wm9zpyrmy58bbwds";
+  name = "conky-${version}";
+  version = "1.10.0";
+
+  src = fetchFromGitHub {
+    owner = "brndnmtthws";
+    repo = "conky";
+    rev = "v${version}";
+    sha256 = "00vyrf72l54j3majqmn6vykqvvb15vygsaby644nsb5vpma6b1cn";
   };
 
   NIX_LDFLAGS = "-lgcc_s";
 
-  buildInputs = [ pkgconfig glib ]
-    ++ [ ncurses ]
-    #++ optional  ncursesSupport     ncurses
+  buildInputs = [ pkgconfig glib cmake ]
+    ++ optional  ncursesSupport     ncurses
     ++ optional  x11Support         x11
     ++ optional  xdamageSupport     libXdamage
     ++ optional  imlib2Support      imlib2
     ++ optional  luaSupport         lua
     ++ optionals luaImlib2Support   [ toluapp imlib2 ]
     ++ optionals luaCairoSupport    [ toluapp cairo ]
-
-    ++ optional  alsaSupport        alsaLib
-
     ++ optional  wirelessSupport    wirelesstools
-
     ++ optional  curlSupport        curl
     ++ optional  rssSupport         libxml2
     ++ optional  weatherXoapSupport libxml2
     ;
 
-  configureFlags =
-    let flag = state: flags: if state then map (x: "--enable-${x}")  flags
-                                      else map (x: "--disable-${x}") flags;
-     in flag mpdSupport          [ "mpd" ]
-     ++ flag ibmSupport          [ "ibm" ]
-
-     #++ flag ncursesSupport      [ "ncurses" ]
-     ++ flag x11Support          [ "x11" "xft" "argb" "double-buffer" "own-window" ] # conky won't compile without --enable-own-window
-     ++ flag xdamageSupport      [ "xdamage" ]
-     ++ flag imlib2Support       [ "imlib2" ]
-     ++ flag luaSupport          [ "lua" ]
-     ++ flag luaImlib2Support    [ "lua-imlib2" ]
-     ++ flag luaCairoSupport     [ "lua-cairo" ]
-
-     ++ flag alsaSupport         [ "alsa" ]
-
-     ++ flag wirelessSupport     [ "wlan" ]
-
-     ++ flag curlSupport         [ "curl" ]
-     ++ flag rssSupport          [ "rss" ]
-     ++ flag weatherMetarSupport [ "weather-metar" ]
-     ++ flag weatherXoapSupport  [ "weather-xoap" ]
-     ;
+  cmakeFlags = [ "-DCMAKE_BUILD_TYPE=Release" ]
+    ++ optional curlSupport         "-DBUILD_CURL=ON"
+    ++ optional (!ibmSupport)       "-DBUILD_IBM=OFF"
+    ++ optional imlib2Support       "-DBUILD_IMLIB2=ON"
+    ++ optional luaCairoSupport     "-DBUILD_LUA_CAIRO=ON"
+    ++ optional luaImlib2Support    "-DBUILD_LUA_IMLIB2=ON"
+    ++ optional (!mpdSupport)       "-DBUILD_MPD=OFF"
+    ++ optional (!ncursesSupport)   "-DBUILD_NCURSES=OFF"
+    ++ optional rssSupport          "-DBUILD_RSS=ON"
+    ++ optional (!x11Support)       "-DBUILD_X11=OFF"
+    ++ optional xdamageSupport      "-DBUILD_XDAMAGE=ON"
+    ++ optional weatherMetarSupport "-DBUILD_WEATHER_METAR=ON"
+    ++ optional weatherXoapSupport  "-DBUILD_WEATHER_XOAP=ON"
+    ++ optional wirelessSupport     "-DBUILD_WLAN=ON"
+    ;
 
-  meta = {
+  meta = with stdenv.lib; {
     homepage = http://conky.sourceforge.net/;
     description = "Advanced, highly configurable system monitor based on torsmo";
-    maintainers = [ stdenv.lib.maintainers.guibert ];
-    license = stdenv.lib.licenses.gpl3Plus;
+    maintainers = [ maintainers.guibert ];
+    license = licenses.gpl3Plus;
   };
 }
diff --git a/pkgs/os-specific/linux/freefall/default.nix b/pkgs/os-specific/linux/freefall/default.nix
index 34d0f3881e42..683ec9f6155d 100644
--- a/pkgs/os-specific/linux/freefall/default.nix
+++ b/pkgs/os-specific/linux/freefall/default.nix
@@ -1,39 +1,33 @@
 { stdenv, fetchurl }:
 
-let version = "3.19"; in
+let version = "4.2"; in
 stdenv.mkDerivation {
   name = "freefall-${version}";
 
   src = fetchurl {
-    sha256 = "0v40b5l6dcviqgl47bxlcbimz7kawmy1c2909axi441jwlgm2hmy";
-    url = "mirror://kernel/linux/kernel/v3.x/linux-${version}.tar.xz";
+    sha256 = "1syv8n5hwzdbx69rsj4vayyzskfq1w5laalg5jjd523my52f086g";
+    url = "mirror://kernel/linux/kernel/v4.x/linux-${version}.tar.xz";
   };
 
-  buildPhase = ''
-    cd Documentation/laptops
+  postPatch = ''
+    cd tools/laptop/freefall
 
     # Default time-out is a little low, probably because the AC/lid status
     # functions were never implemented. Because no-one still uses HDDs, right?
-    substituteInPlace freefall.c --replace "alarm(2)" "alarm(5)"
-
-    cc -o freefall freefall.c
+    substituteInPlace freefall.c --replace "alarm(2)" "alarm(7)"
   '';
 
-  installPhase = ''
-    mkdir -p $out/bin
-    install freefall $out/bin
-  '';
+  makeFlags = "PREFIX=$(out)";
 
   meta = with stdenv.lib; {
     description = "Free-fall protection for spinning HP/Dell laptop hard drives";
     longDescription = ''
-      ATA/ATAPI-7 specifies the IDLE IMMEDIATE command with unload feature.
-      Issuing this command should cause the drive to switch to idle mode and
-      unload disk heads. This feature is being used in modern laptops in
-      conjunction with accelerometers and appropriate software to implement
-      a shock protection facility. The idea is to stop all I/O operations on
-      the internal hard drive and park its heads on the ramp when critical
-      situations are anticipated. This has no effect on SSD devices!
+      Provides a shock protection facility in modern laptops with spinning hard
+      drives, by stopping all input/output operations on the internal hard drive
+      and parking its heads on the ramp when critical situations are anticipated.
+      Requires support for the ATA/ATAPI-7 IDLE IMMEDIATE command with unload
+      feature, which should cause the drive to switch to idle mode and unload the
+      disk heads, and an accelerometer device. It has no effect on SSD devices!
     '';
     license = licenses.gpl2;
     platforms = with platforms; linux;
diff --git a/pkgs/os-specific/linux/kernel/linux-4.2.nix b/pkgs/os-specific/linux/kernel/linux-4.2.nix
new file mode 100644
index 000000000000..fc44c6f1dbb8
--- /dev/null
+++ b/pkgs/os-specific/linux/kernel/linux-4.2.nix
@@ -0,0 +1,18 @@
+{ stdenv, fetchurl, ... } @ args:
+
+import ./generic.nix (args // rec {
+  version = "4.2";
+  modDirVersion = "4.2.0";
+  extraMeta.branch = "4.2";
+
+  src = fetchurl {
+    url = "mirror://kernel/linux/kernel/v4.x/linux-${version}.tar.xz";
+    sha256 = "1syv8n5hwzdbx69rsj4vayyzskfq1w5laalg5jjd523my52f086g";
+  };
+
+  features.iwlwifi = true;
+  features.efiBootStub = true;
+  features.needsCifsUtils = true;
+  features.canDisableNetfilterConntrackHelpers = true;
+  features.netfilterRPFilter = true;
+} // (args.argsOverride or {}))
diff --git a/pkgs/os-specific/linux/musl/default.nix b/pkgs/os-specific/linux/musl/default.nix
index db7017edd439..abe96e9b9ae6 100644
--- a/pkgs/os-specific/linux/musl/default.nix
+++ b/pkgs/os-specific/linux/musl/default.nix
@@ -2,11 +2,11 @@
 
 stdenv.mkDerivation rec {
   name    = "musl-${version}";
-  version = "1.1.10";
+  version = "1.1.11";
 
   src = fetchurl {
     url    = "http://www.musl-libc.org/releases/${name}.tar.gz";
-    sha256 = "0z4b3j1r0v4zr3v1cpl1v56zx6w8nq1y3wbs8x1zg87pqyqykfs5";
+    sha256 = "0grmmah3d9wajii26010plpinv3cbiq3kfqsblgn84kv3fjnv7mv";
   };
 
   enableParallelBuilding = true;
diff --git a/pkgs/os-specific/linux/nvidia-x11/default.nix b/pkgs/os-specific/linux/nvidia-x11/default.nix
index cbd9a19777e5..953c8c601253 100644
--- a/pkgs/os-specific/linux/nvidia-x11/default.nix
+++ b/pkgs/os-specific/linux/nvidia-x11/default.nix
@@ -12,7 +12,7 @@ assert (!libsOnly) -> kernel != null;
 
 let
 
-  versionNumber = "352.30";
+  versionNumber = "352.41";
 
   # Policy: use the highest stable version as the default (on our master).
   inherit (stdenv.lib) makeLibraryPath;
@@ -28,15 +28,17 @@ stdenv.mkDerivation {
     if stdenv.system == "i686-linux" then
       fetchurl {
         url = "http://us.download.nvidia.com/XFree86/Linux-x86/${versionNumber}/NVIDIA-Linux-x86-${versionNumber}.run";
-        sha256 = "1qrjvf41zk50hw7gjiwg9jxwgpaarlwm019py4wfqgjgb1cbhgjn";
+        sha256 = "1qzn6dhkrpkx015f7y9adafn7fmz7zbxbczzf9930li8pgvmmz5k";
       }
     else if stdenv.system == "x86_64-linux" then
       fetchurl {
         url = "http://us.download.nvidia.com/XFree86/Linux-x86_64/${versionNumber}/NVIDIA-Linux-x86_64-${versionNumber}-no-compat32.run";
-        sha256 = "1h7ghmykhdyy3n853s8yjzc0qbh50qb2kc0khz672b1rna4wqyhg";
+        sha256 = "1k9hmmn5x9snzyggx23km64kjdqjh2kva090ha6mlayyyxrclz56";
       }
     else throw "nvidia-x11 does not support platform ${stdenv.system}";
 
+  patches = [ ./nvidia-4.2.patch ];
+
   inherit versionNumber libsOnly;
   inherit (stdenv) system;
 
diff --git a/pkgs/os-specific/linux/nvidia-x11/nvidia-4.2.patch b/pkgs/os-specific/linux/nvidia-x11/nvidia-4.2.patch
new file mode 100644
index 000000000000..412b786179ae
--- /dev/null
+++ b/pkgs/os-specific/linux/nvidia-x11/nvidia-4.2.patch
@@ -0,0 +1,26 @@
+diff --git a/kernel/nv-frontend.c b/kernel/nv-frontend.c
+index 65bbb1b..be39c8d 100644
+--- a/kernel/nv-frontend.c
++++ b/kernel/nv-frontend.c
+@@ -15,7 +15,7 @@
+ #include "nv-frontend.h"
+ 
+ #if defined(MODULE_LICENSE)
+-MODULE_LICENSE("NVIDIA");
++MODULE_LICENSE("GPL\0NVIDIA");
+ #endif
+ #if defined(MODULE_INFO)
+ MODULE_INFO(supported, "external");
+diff --git a/kernel/nv.c b/kernel/nv.c
+index abe81ed..05945b5 100644
+--- a/kernel/nv.c
++++ b/kernel/nv.c
+@@ -31,7 +31,7 @@
+ 
+ #if defined(NV_VMWARE) || (NV_BUILD_MODULE_INSTANCES != 0)
+ #if defined(MODULE_LICENSE)
+-MODULE_LICENSE("NVIDIA");
++MODULE_LICENSE("GPL\0NVIDIA");
+ #endif
+ #if defined(MODULE_INFO)
+ MODULE_INFO(supported, "external");
diff --git a/pkgs/os-specific/linux/pax-utils/default.nix b/pkgs/os-specific/linux/pax-utils/default.nix
index 13d144c54b09..fe517a710219 100644
--- a/pkgs/os-specific/linux/pax-utils/default.nix
+++ b/pkgs/os-specific/linux/pax-utils/default.nix
@@ -2,11 +2,11 @@
 
 stdenv.mkDerivation rec {
   name = "pax-utils-${version}";
-  version = "1.0.5";
+  version = "1.1.1";
 
   src = fetchurl {
     url = "http://dev.gentoo.org/~vapier/dist/${name}.tar.xz";
-    sha256 = "0vwhmnwai24h654d1zchm5qkbr030ay98l2qdp914ydgwhw9k6pn";
+    sha256 = "0gldvyr96jgbcahq7rl3k4krzyhvlz95ckiqh3yhink56s5z58cy";
   };
 
   makeFlags = [
diff --git a/pkgs/os-specific/linux/policycoreutils/default.nix b/pkgs/os-specific/linux/policycoreutils/default.nix
index 4eb8394a4d34..1933523d9c2d 100644
--- a/pkgs/os-specific/linux/policycoreutils/default.nix
+++ b/pkgs/os-specific/linux/policycoreutils/default.nix
@@ -12,6 +12,8 @@ stdenv.mkDerivation rec {
     sha256 = "0y9l9k60iy21hj0lcvfdfxs1fxydg6d3pxp9rhy7hwr4y5vgh6dq";
   };
 
+  patches = [ ./fix-printf-type.patch ];
+
   postPatch = ''
     # Fix references to libsepol.a
     find . -name Makefile -exec sed -i 's,[^ ]*/libsepol.a,${libsepol}/lib/libsepol.a,g' {} \;
diff --git a/pkgs/os-specific/linux/policycoreutils/fix-printf-type.patch b/pkgs/os-specific/linux/policycoreutils/fix-printf-type.patch
new file mode 100644
index 000000000000..6ab2d6dccc73
--- /dev/null
+++ b/pkgs/os-specific/linux/policycoreutils/fix-printf-type.patch
@@ -0,0 +1,12 @@
+diff -Nru policycoreutils-2.4/setfiles/restore.c policycoreutils-2.4.new/setfiles/restore.c
+--- policycoreutils-2.4/setfiles/restore.c	2015-02-02 09:38:10.000000000 -0500
++++ policycoreutils-2.4.new/setfiles/restore.c	2015-08-29 20:44:13.693023222 -0400
+@@ -118,7 +118,7 @@
+ 		r_opts->count++;
+ 		if (r_opts->count % STAR_COUNT == 0) {
+ 			if (r_opts->progress == 1) {
+-				fprintf(stdout, "\r%luk", (size_t) r_opts->count / STAR_COUNT );
++				fprintf(stdout, "\r%zuk", (size_t) r_opts->count / STAR_COUNT );
+ 			} else {
+ 				if (r_opts->nfile > 0) {
+ 					progress = (r_opts->count < r_opts->nfile) ? (100.0 * r_opts->count / r_opts->nfile) : 100;
diff --git a/pkgs/os-specific/linux/spl/git.nix b/pkgs/os-specific/linux/spl/git.nix
index 9faba199a5da..216ea1fbbcd8 100644
--- a/pkgs/os-specific/linux/spl/git.nix
+++ b/pkgs/os-specific/linux/spl/git.nix
@@ -1,13 +1,13 @@
 { callPackage, fetchFromGitHub, ... } @ args:
 
 callPackage ./generic.nix (args // rec {
-  version = "2015-07-21";
+  version = "2015-08-25";
 
   src = fetchFromGitHub {
     owner = "zfsonlinux";
     repo = "spl";
-    rev = "9eb361aaa537724c9a90ab6a9f33521bfd80bad9";
-    sha256 = "18sv4mw85fbm8i1s8k4y5dc43l6ll2f6hgfrawvzgvwni5i4h7n8";
+    rev = "ae89cf0f34de323c4a7c39bfd9b906acc2635a87";
+    sha256 = "04i3c4qg5zccl1inr17vgkjrz9zr718m64pbrlw9rvc82fw5g199";
   };
 
   patches = [ ./const.patch ./install_prefix.patch ];
diff --git a/pkgs/os-specific/linux/trace-cmd/default.nix b/pkgs/os-specific/linux/trace-cmd/default.nix
index 1a22d094867d..aeb2c371c2ad 100644
--- a/pkgs/os-specific/linux/trace-cmd/default.nix
+++ b/pkgs/os-specific/linux/trace-cmd/default.nix
@@ -2,12 +2,12 @@
 
 stdenv.mkDerivation rec {
   name    = "trace-cmd-${version}";
-  version = "2.5.3";
+  version = "2.6";
 
   src = fetchgit {
     url    = "git://git.kernel.org/pub/scm/linux/kernel/git/rostedt/trace-cmd.git";
     rev    = "refs/tags/trace-cmd-v${version}";
-    sha256 = "32db3df07d0371c2b072029c6c86c4204be8cbbcb53840fa8c42dbf2e35c047b";
+    sha256 = "42286440a45d1b24552a1d3cdb656dc648ad346fc426b5798bacdbffd3c4b226";
   };
 
   buildInputs = [ asciidoc libxslt ];
diff --git a/pkgs/os-specific/linux/xf86-input-wacom/default.nix b/pkgs/os-specific/linux/xf86-input-wacom/default.nix
index 9e475f7aed99..fca9dab22619 100644
--- a/pkgs/os-specific/linux/xf86-input-wacom/default.nix
+++ b/pkgs/os-specific/linux/xf86-input-wacom/default.nix
@@ -3,11 +3,11 @@
 , ncurses, pkgconfig, randrproto, xorgserver, xproto, udev, libXinerama, pixman }:
 
 stdenv.mkDerivation rec {
-  name = "xf86-input-wacom-0.30.0";
+  name = "xf86-input-wacom-0.31.0";
 
   src = fetchurl {
     url = "mirror://sourceforge/linuxwacom/${name}.tar.bz2";
-    sha256 = "1xa1i2ks00fa20c5dlpqzlapzj638a7qm5c0wqc3qvgwliwy9m4a";
+    sha256 = "0xiz5vpkp8zm5m2k909sbvm9v8rf6hwn3gvqr2msswc00hzp5sg7";
   };
 
   buildInputs = [ inputproto libX11 libXext libXi libXrandr libXrender
diff --git a/pkgs/os-specific/linux/zfs/git.nix b/pkgs/os-specific/linux/zfs/git.nix
index 26c48076c4ea..f63a36ce5162 100644
--- a/pkgs/os-specific/linux/zfs/git.nix
+++ b/pkgs/os-specific/linux/zfs/git.nix
@@ -1,13 +1,13 @@
 { callPackage, stdenv, fetchFromGitHub, spl_git, ... } @ args:
 
 callPackage ./generic.nix (args // rec {
-  version = "2015-07-21";
+  version = "2015-08-30";
 
   src = fetchFromGitHub {
     owner = "zfsonlinux";
     repo = "zfs";
-    rev = "3b79cef21294f3ec46c4f71cc5a68a75a4d0ebc7";
-    sha256 = "01l4cg62wgn3wzasskx2nh3a4c74vq8qcwz090x8x1r4c2r4v943";
+    rev = "c6a3a222d3a1d2af94205a218c0ba455200fb945";
+    sha256 = "0alzkngw36ik4vpw0z8nnk5qysh2z6v231c23rw7jlcqfdd8ji8p";
   };
 
   patches = [ ./nix-build.patch ];