about summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorMatthew Bauer <mjbauer95@gmail.com>2018-11-13 19:17:00 -0600
committerGitHub <noreply@github.com>2018-11-13 19:17:00 -0600
commit73951bc0c8c02fabe97e645838a52a12618dcd8f (patch)
treeff4e31068bad8bed19dd69301cf812c77d9bd532 /pkgs/os-specific
parentdaf3297cb46f73522d021e22c4dc7e0eb6920333 (diff)
parent83d02fad5f9e2117309d00eeb3b99f355523c917 (diff)
downloadnixlib-73951bc0c8c02fabe97e645838a52a12618dcd8f.tar
nixlib-73951bc0c8c02fabe97e645838a52a12618dcd8f.tar.gz
nixlib-73951bc0c8c02fabe97e645838a52a12618dcd8f.tar.bz2
nixlib-73951bc0c8c02fabe97e645838a52a12618dcd8f.tar.lz
nixlib-73951bc0c8c02fabe97e645838a52a12618dcd8f.tar.xz
nixlib-73951bc0c8c02fabe97e645838a52a12618dcd8f.tar.zst
nixlib-73951bc0c8c02fabe97e645838a52a12618dcd8f.zip
Merge pull request #50293 from matthewbauer/cleanups2
Add setup-hooks for scons and waf
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/pflask/default.nix14
1 files changed, 2 insertions, 12 deletions
diff --git a/pkgs/os-specific/linux/pflask/default.nix b/pkgs/os-specific/linux/pflask/default.nix
index b4f93e9de3fb..1155a793b014 100644
--- a/pkgs/os-specific/linux/pflask/default.nix
+++ b/pkgs/os-specific/linux/pflask/default.nix
@@ -1,4 +1,4 @@
-{ lib, stdenv, fetchurl, python, waf }:
+{ lib, stdenv, fetchurl, python, wafHook }:
 
 stdenv.mkDerivation rec {
   name = "pflask-${version}";
@@ -10,19 +10,9 @@ stdenv.mkDerivation rec {
     sha256 = "2545fca37f9da484b46b6fb5e3a9bbba6526a9725189fe4af5227ef6e6fca440";
   };
 
+  nativeBuildInputs = [ wafHook ];
   buildInputs = [ python ];
 
-  configurePhase = ''
-    ln -s ${waf} waf
-    python waf configure --prefix=$out
-  '';
-  buildPhase = ''
-    python waf build
-  '';
-  installPhase = ''
-    python waf install
-  '';
-
   meta = {
     description = "Lightweight process containers for Linux";
     homepage    = "https://ghedo.github.io/pflask/";