about summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorJörg Thalheim <joerg@thalheim.io>2020-01-30 14:11:11 +0000
committerJörg Thalheim <joerg@thalheim.io>2020-01-30 14:11:47 +0000
commit6f7c3fbff756dfafc86a33afc6e318e8d73319de (patch)
tree5a65652be670c1c626c4c5978b4755872684fba0 /pkgs/os-specific
parent5b74cd218690155411bd6298b65fd7728eb7bf03 (diff)
downloadnixlib-6f7c3fbff756dfafc86a33afc6e318e8d73319de.tar
nixlib-6f7c3fbff756dfafc86a33afc6e318e8d73319de.tar.gz
nixlib-6f7c3fbff756dfafc86a33afc6e318e8d73319de.tar.bz2
nixlib-6f7c3fbff756dfafc86a33afc6e318e8d73319de.tar.lz
nixlib-6f7c3fbff756dfafc86a33afc6e318e8d73319de.tar.xz
nixlib-6f7c3fbff756dfafc86a33afc6e318e8d73319de.tar.zst
nixlib-6f7c3fbff756dfafc86a33afc6e318e8d73319de.zip
bpftool: fix compilation with 5.5
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/bpftool/default.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/pkgs/os-specific/linux/bpftool/default.nix b/pkgs/os-specific/linux/bpftool/default.nix
index 8b288fc046a6..34ddcc3a213f 100644
--- a/pkgs/os-specific/linux/bpftool/default.nix
+++ b/pkgs/os-specific/linux/bpftool/default.nix
@@ -1,15 +1,19 @@
 { stdenv
 , libopcodes, libbfd, libelf
 , linuxPackages_latest, zlib
+, python3
 }:
 
 stdenv.mkDerivation {
   pname = "bpftool";
   inherit (linuxPackages_latest.kernel) version src;
 
+  nativeBuildInputs = [ python3 ];
   buildInputs = [ libopcodes libbfd libelf zlib ];
 
   preConfigure = ''
+    patchShebangs scripts/bpf_helpers_doc.py
+
     cd tools/bpf/bpftool
     substituteInPlace ./Makefile \
       --replace '/usr/local' "$out" \