about summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorTuomas Tynkkynen <tuomas.tynkkynen@iki.fi>2016-07-16 21:15:23 +0300
committerGitHub <noreply@github.com>2016-07-16 21:15:23 +0300
commit6e0ab36de0bbbf614fa7969d0d0a4aa95faf06e6 (patch)
tree797c872240e567370cbf90ae9c8d1aaf97f23e1d /pkgs/os-specific
parent3634e8ac3eb176a3636dd56f0901115ad658858a (diff)
parentb68689ebb2a746b8088ed10ab4859ce64b9d3873 (diff)
downloadnixlib-6e0ab36de0bbbf614fa7969d0d0a4aa95faf06e6.tar
nixlib-6e0ab36de0bbbf614fa7969d0d0a4aa95faf06e6.tar.gz
nixlib-6e0ab36de0bbbf614fa7969d0d0a4aa95faf06e6.tar.bz2
nixlib-6e0ab36de0bbbf614fa7969d0d0a4aa95faf06e6.tar.lz
nixlib-6e0ab36de0bbbf614fa7969d0d0a4aa95faf06e6.tar.xz
nixlib-6e0ab36de0bbbf614fa7969d0d0a4aa95faf06e6.tar.zst
nixlib-6e0ab36de0bbbf614fa7969d0d0a4aa95faf06e6.zip
Merge pull request #16963 from womfoo/init/cking-kernel-tools
Init {fnotify,fork,power,smem}stat kernel tools
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/fnotifystat/default.nix22
-rw-r--r--pkgs/os-specific/linux/forkstat/default.nix22
-rw-r--r--pkgs/os-specific/linux/powerstat/default.nix22
-rw-r--r--pkgs/os-specific/linux/smemstat/default.nix22
4 files changed, 88 insertions, 0 deletions
diff --git a/pkgs/os-specific/linux/fnotifystat/default.nix b/pkgs/os-specific/linux/fnotifystat/default.nix
new file mode 100644
index 000000000000..5708ed7c4df2
--- /dev/null
+++ b/pkgs/os-specific/linux/fnotifystat/default.nix
@@ -0,0 +1,22 @@
+{ stdenv, lib, fetchurl }:
+
+stdenv.mkDerivation rec {
+  name = "fnotifystat-${version}";
+  version = "0.01.14";
+  src = fetchurl {
+    url = "http://kernel.ubuntu.com/~cking/tarballs/fnotifystat/fnotifystat-${version}.tar.gz";
+    sha256 = "1cc3w94v8b4nfpkgr33gfzxpwaf43brqyc0fla9p70gk3hxjqzi5";
+  };
+  installFlags = [ "DESTDIR=$(out)" ];
+  postInstall = ''
+    mv $out/usr/* $out
+    rm -r $out/usr
+  '';
+  meta = with lib; {
+    description = "File activity monitoring tool";
+    homepage = http://kernel.ubuntu.com/~cking/fnotifystat/;
+    license = licenses.gpl2;
+    platforms = platforms.linux;
+    maintainers = with maintainers; [ womfoo ];
+  };
+}
diff --git a/pkgs/os-specific/linux/forkstat/default.nix b/pkgs/os-specific/linux/forkstat/default.nix
new file mode 100644
index 000000000000..3a253003e8e1
--- /dev/null
+++ b/pkgs/os-specific/linux/forkstat/default.nix
@@ -0,0 +1,22 @@
+{ stdenv, lib, fetchurl }:
+
+stdenv.mkDerivation rec {
+  name = "forkstat-${version}";
+  version = "0.01.13";
+  src = fetchurl {
+    url = "http://kernel.ubuntu.com/~cking/tarballs/forkstat/forkstat-${version}.tar.gz";
+    sha256 = "12dmqpv0q3x166sya93rhcj7vs4868x7y7lwfwv9l54hhirpamhq";
+  };
+  installFlags = [ "DESTDIR=$(out)" ];
+  postInstall = ''
+    mv $out/usr/* $out
+    rm -r $out/usr
+  '';
+  meta = with lib; {
+    description = "Process fork/exec/exit monitoring tool";
+    homepage = http://kernel.ubuntu.com/~cking/forkstat/;
+    license = licenses.gpl2;
+    platforms = platforms.linux;
+    maintainers = with maintainers; [ womfoo ];
+  };
+}
diff --git a/pkgs/os-specific/linux/powerstat/default.nix b/pkgs/os-specific/linux/powerstat/default.nix
new file mode 100644
index 000000000000..9604a67ddd9a
--- /dev/null
+++ b/pkgs/os-specific/linux/powerstat/default.nix
@@ -0,0 +1,22 @@
+{ stdenv, lib, fetchurl }:
+
+stdenv.mkDerivation rec {
+  name = "powerstat-${version}";
+  version = "0.02.10";
+  src = fetchurl {
+    url = "http://kernel.ubuntu.com/~cking/tarballs/powerstat/powerstat-${version}.tar.gz";
+    sha256 = "11n2k20h27j7m8j0l524w23xlkjhapsb3ml1qpx1si7gf0pkglcl";
+  };
+  installFlags = [ "DESTDIR=$(out)" ];
+  postInstall = ''
+    mv $out/usr/* $out
+    rm -r $out/usr
+  '';
+  meta = with lib; {
+    description = "Laptop power measuring tool";
+    homepage = http://kernel.ubuntu.com/~cking/powerstat/;
+    license = licenses.gpl2;
+    platforms = platforms.linux;
+    maintainers = with maintainers; [ womfoo ];
+  };
+}
diff --git a/pkgs/os-specific/linux/smemstat/default.nix b/pkgs/os-specific/linux/smemstat/default.nix
new file mode 100644
index 000000000000..a38c819bc6ff
--- /dev/null
+++ b/pkgs/os-specific/linux/smemstat/default.nix
@@ -0,0 +1,22 @@
+{ stdenv, lib, fetchurl }:
+
+stdenv.mkDerivation rec {
+  name = "smemstat-${version}";
+  version = "0.01.14";
+  src = fetchurl {
+    url = "http://kernel.ubuntu.com/~cking/tarballs/smemstat/smemstat-${version}.tar.gz";
+    sha256 = "0qkpbg0n40d8m9jzf3ylpdp65zzs344zbjn8khha4plbwg00ijrw";
+  };
+  installFlags = [ "DESTDIR=$(out)" ];
+  postInstall = ''
+    mv $out/usr/* $out
+    rm -r $out/usr
+  '';
+  meta = with lib; {
+    description = "Memory usage monitoring tool";
+    homepage = http://kernel.ubuntu.com/~cking/smemstat/;
+    license = licenses.gpl2;
+    platforms = platforms.linux;
+    maintainers = with maintainers; [ womfoo ];
+  };
+}