about summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorgithub-actions[bot] <41898282+github-actions[bot]@users.noreply.github.com>2022-11-28 06:01:53 +0000
committerGitHub <noreply@github.com>2022-11-28 06:01:53 +0000
commit6aeef7531c5396d5c3bc531c3b5a01a7a7de143d (patch)
tree0c427f311dc37eed4cd8e89feef450ee757503bd /pkgs/os-specific
parent4a8531fddce4366c9ab3566d80e451274c5cbdeb (diff)
parent90dcbd04ef283da9fdc4e5b445e4c6e86312882a (diff)
downloadnixlib-6aeef7531c5396d5c3bc531c3b5a01a7a7de143d.tar
nixlib-6aeef7531c5396d5c3bc531c3b5a01a7a7de143d.tar.gz
nixlib-6aeef7531c5396d5c3bc531c3b5a01a7a7de143d.tar.bz2
nixlib-6aeef7531c5396d5c3bc531c3b5a01a7a7de143d.tar.lz
nixlib-6aeef7531c5396d5c3bc531c3b5a01a7a7de143d.tar.xz
nixlib-6aeef7531c5396d5c3bc531c3b5a01a7a7de143d.tar.zst
nixlib-6aeef7531c5396d5c3bc531c3b5a01a7a7de143d.zip
Merge staging-next into staging
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/intel-compute-runtime/default.nix18
1 files changed, 8 insertions, 10 deletions
diff --git a/pkgs/os-specific/linux/intel-compute-runtime/default.nix b/pkgs/os-specific/linux/intel-compute-runtime/default.nix
index 177a9d58e2d4..8ea51a1ebdb0 100644
--- a/pkgs/os-specific/linux/intel-compute-runtime/default.nix
+++ b/pkgs/os-specific/linux/intel-compute-runtime/default.nix
@@ -1,9 +1,9 @@
-{ lib, stdenv
+{ lib
+, stdenv
 , fetchFromGitHub
 , patchelf
 , cmake
 , pkg-config
-
 , intel-gmmlib
 , intel-graphics-compiler
 , libva
@@ -11,13 +11,13 @@
 
 stdenv.mkDerivation rec {
   pname = "intel-compute-runtime";
-  version = "22.35.24055";
+  version = "22.43.24558";
 
   src = fetchFromGitHub {
     owner = "intel";
     repo = "compute-runtime";
     rev = version;
-    sha256 = "sha256-MOWlhzhEGYyHGk6N+H7O2BLho4YFyvcCbj/zafhzLEw=";
+    sha256 = "sha256-/hiDJLtEOLbnFjT697yLie5E7819fZM3xricPwe4xN0=";
   };
 
   nativeBuildInputs = [ cmake pkg-config ];
@@ -26,10 +26,8 @@ stdenv.mkDerivation rec {
 
   cmakeFlags = [
     "-DSKIP_UNIT_TESTS=1"
-
     "-DIGC_DIR=${intel-graphics-compiler}"
     "-DOCL_ICD_VENDORDIR=${placeholder "out"}/etc/OpenCL/vendors"
-
     # The install script assumes this path is relative to CMAKE_INSTALL_PREFIX
     "-DCMAKE_INSTALL_LIBDIR=lib"
   ];
@@ -45,10 +43,10 @@ stdenv.mkDerivation rec {
   '';
 
   meta = with lib; {
-    homepage    = "https://github.com/intel/compute-runtime";
+    homepage = "https://github.com/intel/compute-runtime";
     description = "Intel Graphics Compute Runtime for OpenCL. Replaces Beignet for Gen8 (Broadwell) and beyond";
-    license     = licenses.mit;
-    platforms   = platforms.linux;
-    maintainers = with maintainers; [ gloaming ];
+    license = licenses.mit;
+    platforms = [ "x86_64-linux" "aarch64-linux" ];
+    maintainers = with maintainers; [ SuperSandro2000 ];
   };
 }