about summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorFranz Pletz <fpletz@fnordicwalking.de>2017-06-22 00:41:25 +0200
committerFranz Pletz <fpletz@fnordicwalking.de>2017-06-22 00:41:25 +0200
commit6338c50a84a4ac64262c3a39d9464df35e9bce87 (patch)
tree3c939f53cab990d8e7614ccd019a5d197b9c322e /pkgs/os-specific
parent29a485a8cda44449181e40d4f9b14f02d70b6c93 (diff)
parentdd3f2e648a6ee5dc7ba88bf2e3d13b6b47686350 (diff)
downloadnixlib-6338c50a84a4ac64262c3a39d9464df35e9bce87.tar
nixlib-6338c50a84a4ac64262c3a39d9464df35e9bce87.tar.gz
nixlib-6338c50a84a4ac64262c3a39d9464df35e9bce87.tar.bz2
nixlib-6338c50a84a4ac64262c3a39d9464df35e9bce87.tar.lz
nixlib-6338c50a84a4ac64262c3a39d9464df35e9bce87.tar.xz
nixlib-6338c50a84a4ac64262c3a39d9464df35e9bce87.tar.zst
nixlib-6338c50a84a4ac64262c3a39d9464df35e9bce87.zip
Merge branch 'master' into staging
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/iproute/default.nix9
-rw-r--r--pkgs/os-specific/linux/kernel/common-config.nix4
-rw-r--r--pkgs/os-specific/linux/kernel/linux-hardened-copperhead.nix27
-rw-r--r--pkgs/os-specific/linux/kernel/linux-testing.nix6
-rw-r--r--pkgs/os-specific/linux/libcap-ng/default.nix4
-rw-r--r--pkgs/os-specific/linux/libnl/default.nix17
-rw-r--r--pkgs/os-specific/linux/lxc/default.nix15
-rw-r--r--pkgs/os-specific/linux/lxcfs/default.nix10
-rw-r--r--pkgs/os-specific/linux/ply/default.nix11
-rw-r--r--pkgs/os-specific/linux/powertop/default.nix7
-rw-r--r--pkgs/os-specific/linux/tpacpi-bat/default.nix4
-rw-r--r--pkgs/os-specific/linux/v4l-utils/default.nix8
-rw-r--r--pkgs/os-specific/linux/wpa_supplicant/gui.nix4
13 files changed, 78 insertions, 48 deletions
diff --git a/pkgs/os-specific/linux/iproute/default.nix b/pkgs/os-specific/linux/iproute/default.nix
index 1ff68fc04080..4ffc99b6ced3 100644
--- a/pkgs/os-specific/linux/iproute/default.nix
+++ b/pkgs/os-specific/linux/iproute/default.nix
@@ -4,11 +4,11 @@
 
 stdenv.mkDerivation rec {
   name = "iproute2-${version}";
-  version = "4.9.0";
+  version = "4.11.0";
 
   src = fetchurl {
     url = "mirror://kernel/linux/utils/net/iproute2/${name}.tar.xz";
-    sha256 = "1i0n071hiqxw1gisngw2jln3kcp9sh47n6fj5hdwqrvp7w20zwy0";
+    sha256 = "09l0phf09mw17bn3xlzfr80sbhw14mq8xv28iz5x15m6pll10rvj";
   };
 
   patches = lib.optionals enableFan [
@@ -31,6 +31,7 @@ stdenv.mkDerivation rec {
     "MANDIR=$(out)/share/man"
     "BASH_COMPDIR=$(out)/share/bash-completion/completions"
     "DOCDIR=$(TMPDIR)/share/doc/${name}" # Don't install docs
+    "HDRDIR=$(TMPDIR)/include/iproute2" # Don't install headers
   ];
 
   buildFlags = [
@@ -47,10 +48,10 @@ stdenv.mkDerivation rec {
   enableParallelBuilding = true;
 
   meta = with stdenv.lib; {
-    homepage = http://www.linuxfoundation.org/collaborate/workgroups/networking/iproute2;
+    homepage = https://wiki.linuxfoundation.org/networking/iproute2;
     description = "A collection of utilities for controlling TCP/IP networking and traffic control in Linux";
     platforms = platforms.linux;
     license = licenses.gpl2;
-    maintainers = with maintainers; [ eelco wkennington ];
+    maintainers = with maintainers; [ eelco wkennington fpletz ];
   };
 }
diff --git a/pkgs/os-specific/linux/kernel/common-config.nix b/pkgs/os-specific/linux/kernel/common-config.nix
index b23d52b39e3c..ec90620fce13 100644
--- a/pkgs/os-specific/linux/kernel/common-config.nix
+++ b/pkgs/os-specific/linux/kernel/common-config.nix
@@ -472,8 +472,10 @@ with stdenv.lib;
   SCHED_TRACER y
   STACK_TRACER y
 
-  ${optionalString (versionOlder version "4.11") ''
+  ${if versionOlder version "4.11" then ''
     UPROBE_EVENT? y
+  '' else ''
+    UPROBE_EVENTS? y
   ''}
 
   ${optionalString (versionAtLeast version "4.4") ''
diff --git a/pkgs/os-specific/linux/kernel/linux-hardened-copperhead.nix b/pkgs/os-specific/linux/kernel/linux-hardened-copperhead.nix
new file mode 100644
index 000000000000..ae47a3842f71
--- /dev/null
+++ b/pkgs/os-specific/linux/kernel/linux-hardened-copperhead.nix
@@ -0,0 +1,27 @@
+{ stdenv, fetchFromGitHub, perl, buildLinux, ... } @ args:
+
+let
+  version = "4.11.6";
+  revision = "c";
+  sha256 = "1n1j1y5g5fcvgpqjfq14fbg4cm32k420kbazipqbi84h9zwifa69";
+in
+
+import ./generic.nix (args // {
+  version = "${version}-${revision}";
+  extraMeta.branch = "4.11";
+  modDirVersion = version;
+
+  src = fetchFromGitHub {
+    inherit sha256;
+    owner = "copperhead";
+    repo = "linux-hardened";
+    rev = "${version}.${revision}";
+  };
+
+  kernelPatches = args.kernelPatches;
+
+  features.iwlwifi = true;
+  features.efiBootStub = true;
+  features.needsCifsUtils = true;
+  features.netfilterRPFilter = true;
+} // (args.argsOverride or {}))
diff --git a/pkgs/os-specific/linux/kernel/linux-testing.nix b/pkgs/os-specific/linux/kernel/linux-testing.nix
index c56a25c3c260..6bde598c47ab 100644
--- a/pkgs/os-specific/linux/kernel/linux-testing.nix
+++ b/pkgs/os-specific/linux/kernel/linux-testing.nix
@@ -1,13 +1,13 @@
 { stdenv, fetchurl, perl, buildLinux, ... } @ args:
 
 import ./generic.nix (args // rec {
-  version = "4.12-rc5";
-  modDirVersion = "4.12.0-rc5";
+  version = "4.12-rc6";
+  modDirVersion = "4.12.0-rc6";
   extraMeta.branch = "4.12";
 
   src = fetchurl {
     url = "https://git.kernel.org/torvalds/t/linux-${version}.tar.gz";
-    sha256 = "0d3lpf429fqrf6i529y0pjdwnpq2v82agn3xhw4jwkriib9i425x";
+    sha256 = "0yqs65kmrksphca8f959g9ca9kpdwbp3ad5v594wvwsdk0q4sqgc";
   };
 
   features.iwlwifi = true;
diff --git a/pkgs/os-specific/linux/libcap-ng/default.nix b/pkgs/os-specific/linux/libcap-ng/default.nix
index ea54f1a39fd1..d4625687c472 100644
--- a/pkgs/os-specific/linux/libcap-ng/default.nix
+++ b/pkgs/os-specific/linux/libcap-ng/default.nix
@@ -6,11 +6,11 @@ stdenv.mkDerivation rec {
   name = "libcap-ng-${version}";
   # When updating make sure to test that the version with
   # all of the python bindings still works
-  version = "0.7.7";
+  version = "0.7.8";
 
   src = fetchurl {
     url = "${meta.homepage}/${name}.tar.gz";
-    sha256 = "0syhyrixk7fqvwis3k7iddn75g0qxysc1q5fifvzccxk7774jmb1";
+    sha256 = "0pyhjxgsph3p28ayk4ynxab6wvzaqmazk1nkamx11m2w8jbzj6n2";
   };
 
   nativeBuildInputs = [ swig ];
diff --git a/pkgs/os-specific/linux/libnl/default.nix b/pkgs/os-specific/linux/libnl/default.nix
index dc0dadf92e0e..8066eddd4f3d 100644
--- a/pkgs/os-specific/linux/libnl/default.nix
+++ b/pkgs/os-specific/linux/libnl/default.nix
@@ -1,25 +1,26 @@
-{ stdenv, fetchFromGitHub, autoreconfHook, bison, flex, pkgconfig }:
+{ stdenv, lib, fetchFromGitHub, autoreconfHook, bison, flex, pkgconfig }:
 
-let version = "3.2.29"; in
+let version = "3.3.0"; in
 stdenv.mkDerivation {
   name = "libnl-${version}";
 
   src = fetchFromGitHub {
-    sha256 = "0y8fcb1bfbdvxgckq5p6l4jzx0kvv3g11svy6d5v3i6zy9kkq8wh";
-    rev = "libnl3_2_29";
     repo = "libnl";
     owner = "thom311";
+    rev = "libnl${lib.replaceStrings ["."] ["_"] version}";
+    sha256 = "1796kyq2lkhz2802v9kp32vlxf8ynlyqgyw9nhmry3qh5d0ahcsv";
   };
 
   outputs = [ "bin" "dev" "out" "man" ];
 
   nativeBuildInputs = [ autoreconfHook bison flex pkgconfig ];
 
-  meta = {
+  meta = with lib; {
     inherit version;
     homepage = "http://www.infradead.org/~tgr/libnl/";
-    description = "Linux NetLink interface library";
-    maintainers = [ ];
-    platforms = stdenv.lib.platforms.linux;
+    description = "Linux Netlink interface library suite";
+    license = licenses.lgpl21;
+    maintainers = with maintainers; [ fpletz ];
+    platforms = platforms.linux;
   };
 }
diff --git a/pkgs/os-specific/linux/lxc/default.nix b/pkgs/os-specific/linux/lxc/default.nix
index bab7038aa475..1d432f9bbd99 100644
--- a/pkgs/os-specific/linux/lxc/default.nix
+++ b/pkgs/os-specific/linux/lxc/default.nix
@@ -12,11 +12,11 @@ in
 with stdenv.lib;
 stdenv.mkDerivation rec {
   name = "lxc-${version}";
-  version = "2.0.7";
+  version = "2.0.8";
 
   src = fetchurl {
     url = "https://linuxcontainers.org/downloads/lxc/lxc-${version}.tar.gz";
-    sha256 = "0paz0lgb9dzpgahysad1cr6gz54l6xyhqdx6dzw2kh3fy1sw028w";
+    sha256 = "15449r56rqg3487kzsnfvz0w4p5ajrq0krcsdh6c9r6g0ark93hd";
   };
 
   nativeBuildInputs = [
@@ -29,13 +29,12 @@ stdenv.mkDerivation rec {
 
   patches = [
     ./support-db2x.patch
-    (fetchurl {
-      name = "CVE-2017-5985.patch";
-      url = "https://github.com/lxc/lxc/commit/d512bd5efb0e407eba350c4e649c464a65b712a3.patch";
-      sha256 = "0v1rhlfviadsxj2wmbl7nqb64p6y2bxm9y43sc44jg3k6mkr0r5c";
-    })
   ];
 
+  postPatch = ''
+    sed -i '/chmod u+s/d' src/lxc/Makefile.am
+  '';
+
   XML_CATALOG_FILES = "${docbook_xml_dtd_45}/xml/dtd/docbook/catalog.xml";
 
   # FIXME
@@ -81,7 +80,7 @@ stdenv.mkDerivation rec {
   '';
 
   meta = {
-    homepage = "http://lxc.sourceforge.net";
+    homepage = "https://linuxcontainers.org/";
     description = "Userspace tools for Linux Containers, a lightweight virtualization system";
     license = licenses.lgpl21Plus;
 
diff --git a/pkgs/os-specific/linux/lxcfs/default.nix b/pkgs/os-specific/linux/lxcfs/default.nix
index 2555ce5c6c31..c23457c6b5f6 100644
--- a/pkgs/os-specific/linux/lxcfs/default.nix
+++ b/pkgs/os-specific/linux/lxcfs/default.nix
@@ -2,15 +2,13 @@
 
 with stdenv.lib;
 stdenv.mkDerivation rec {
-  # use unstable because it fixed some serious crashes,
-  # stable should be reconsidered in future
-  name = "lxcfs-unstable-2017-03-02";
+  name = "lxcfs-2.0.7";
 
   src = fetchFromGitHub {
     owner = "lxc";
     repo = "lxcfs";
-    sha256 = "1say5bf6gknzs0aymvrg2xiypc311gcdcfdmvb2vnz058pmianq9";
-    rev = "4a6707e130b4b65a33606ebc18a95ec471f4bf40";
+    rev = name;
+    sha256 = "1z6d52dc12rcplgc9jdgi3lbxm6ahlsjgs1k8v8kvn261xsq1m0a";
   };
 
   nativeBuildInputs = [ pkgconfig help2man autoreconfHook ];
@@ -34,6 +32,6 @@ stdenv.mkDerivation rec {
     description = "FUSE filesystem for LXC";
     license = licenses.asl20;
     platforms = platforms.linux;
-    maintainers = with maintainers; [ mic92 ];
+    maintainers = with maintainers; [ mic92 fpletz ];
   };
 }
diff --git a/pkgs/os-specific/linux/ply/default.nix b/pkgs/os-specific/linux/ply/default.nix
index 9d4bdb1e27d3..a9c84516ef84 100644
--- a/pkgs/os-specific/linux/ply/default.nix
+++ b/pkgs/os-specific/linux/ply/default.nix
@@ -1,9 +1,12 @@
-{ stdenv, kernel, fetchFromGitHub, autoreconfHook, yacc, flex, bison }:
+{ stdenv, kernel, fetchFromGitHub, autoreconfHook, yacc, flex, bison, p7zip }:
+
+assert kernel != null -> stdenv.lib.versionAtLeast kernel.version "4.0";
+
 let
   version = "1.0.beta1-9e810b1";
 in stdenv.mkDerivation {
   name = "ply-${version}";
-  nativeBuildInputs = [ autoreconfHook flex yacc ];
+  nativeBuildInputs = [ autoreconfHook flex yacc p7zip ];
 
   src = fetchFromGitHub {
     owner = "iovisor";
@@ -14,7 +17,9 @@ in stdenv.mkDerivation {
 
   preAutoreconf = ''
     # ply wants to install header fails to its build directory
-    xz -d < ${kernel.src} | tar -xf -
+    # use 7z to handle multiple archive formats transparently
+    7z x ${kernel.src} -so | 7z x -aoa -si -ttar
+
     configureFlagsArray+=(--with-kerneldir=$(echo $(pwd)/linux-*))
     ./autogen.sh --prefix=$out
   '';
diff --git a/pkgs/os-specific/linux/powertop/default.nix b/pkgs/os-specific/linux/powertop/default.nix
index 4d81126af444..5a10f455ea06 100644
--- a/pkgs/os-specific/linux/powertop/default.nix
+++ b/pkgs/os-specific/linux/powertop/default.nix
@@ -1,11 +1,12 @@
 { stdenv, fetchurl, gettext, libnl, ncurses, pciutils, pkgconfig, zlib }:
 
 stdenv.mkDerivation rec {
-  name = "powertop-2.8";
+  name = "powertop-${version}";
+  version = "2.9";
 
   src = fetchurl {
-    url = "https://01.org/sites/default/files/downloads/powertop/${name}.tar.gz";
-    sha256 = "0nlwazxbnn0k6q5f5b09wdhw0f194lpzkp3l7vxansqhfczmcyx8";
+    url = "https://01.org/sites/default/files/downloads/powertop/powertop-v${version}.tar.gz";
+    sha256 = "0l4jjlf05li2mc6g8nrss3h435wjhmnqd8m7v3kha3x0x7cbfzxa";
   };
 
   nativeBuildInputs = [ pkgconfig ];
diff --git a/pkgs/os-specific/linux/tpacpi-bat/default.nix b/pkgs/os-specific/linux/tpacpi-bat/default.nix
index bf60331d8ade..fbc1685c577c 100644
--- a/pkgs/os-specific/linux/tpacpi-bat/default.nix
+++ b/pkgs/os-specific/linux/tpacpi-bat/default.nix
@@ -3,13 +3,13 @@
 # Requires the acpi_call kernel module in order to run.
 stdenv.mkDerivation rec {
   name = "tpacpi-bat-${version}";
-  version = "3.0";
+  version = "3.1";
 
   src = fetchFromGitHub {
     owner = "teleshoes";
     repo = "tpacpi-bat";
     rev = "v${version}";
-    sha256 = "0l72qvjk5j7sg9x4by7an0xwx65x10dx82fky8lnwlwfv54vgg8l";
+    sha256 = "0wbaz34z99gqx721alh5vmpxpj2yxg3x9m8jqyivfi1wfpwc2nd5";
   };
 
   buildInputs = [ perl ];
diff --git a/pkgs/os-specific/linux/v4l-utils/default.nix b/pkgs/os-specific/linux/v4l-utils/default.nix
index c0e065b3b555..622bf4fbd5cc 100644
--- a/pkgs/os-specific/linux/v4l-utils/default.nix
+++ b/pkgs/os-specific/linux/v4l-utils/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, lib, fetchurl, pkgconfig, perl, makeQtWrapper
+{ stdenv, lib, fetchurl, pkgconfig, perl
 , libjpeg, udev
 , withUtils ? true
 , withGUI ? true, alsaLib, libX11, qtbase, mesa_glu
@@ -29,7 +29,7 @@ stdenv.mkDerivation rec {
     ln -s "$dev/include/libv4l1-videodev.h" "$dev/include/videodev.h"
   '';
 
-  nativeBuildInputs = [ pkgconfig perl ] ++ lib.optional (withUtils && withGUI) makeQtWrapper;
+  nativeBuildInputs = [ pkgconfig perl ];
 
   buildInputs = [ udev ] ++ lib.optionals (withUtils && withGUI) [ alsaLib libX11 qtbase mesa_glu ];
 
@@ -41,10 +41,6 @@ stdenv.mkDerivation rec {
     patchShebangs .
   '';
 
-  postInstall = lib.optionalString (withUtils && withGUI) ''
-    wrapQtProgram $out/bin/qv4l2
-  '';
-
   meta = with stdenv.lib; {
     description = "V4L utils and libv4l, provide common image formats regardless of the v4l device";
     homepage = http://linuxtv.org/projects.php;
diff --git a/pkgs/os-specific/linux/wpa_supplicant/gui.nix b/pkgs/os-specific/linux/wpa_supplicant/gui.nix
index d2bd6ff739fd..06a38b291661 100644
--- a/pkgs/os-specific/linux/wpa_supplicant/gui.nix
+++ b/pkgs/os-specific/linux/wpa_supplicant/gui.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, qtbase, qmakeHook, inkscape, imagemagick, wpa_supplicant }:
+{ stdenv, fetchurl, qtbase, qmake, inkscape, imagemagick, wpa_supplicant }:
 
 stdenv.mkDerivation {
   name = "wpa_gui-${wpa_supplicant.version}";
@@ -6,7 +6,7 @@ stdenv.mkDerivation {
   inherit (wpa_supplicant) src;
 
   buildInputs = [ qtbase ];
-  nativeBuildInputs = [ qmakeHook inkscape imagemagick ];
+  nativeBuildInputs = [ qmake inkscape imagemagick ];
 
   prePatch = ''
     cd wpa_supplicant/wpa_gui-qt4