about summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorMaximilian Bosch <maximilian@mbosch.me>2020-12-28 11:13:22 +0100
committerGitHub <noreply@github.com>2020-12-28 11:13:22 +0100
commit5239dc4d9e06da8a18bc3a528a5b312d79cae8aa (patch)
tree9462cd03f3ade488c57b654acf4b0a922c3b1e50 /pkgs/os-specific
parent4fc53b59aecbc25c0e173163d60155f8fca14bfd (diff)
parent80563cef699e8295cc12e47c5e34a1cc806242d5 (diff)
downloadnixlib-5239dc4d9e06da8a18bc3a528a5b312d79cae8aa.tar
nixlib-5239dc4d9e06da8a18bc3a528a5b312d79cae8aa.tar.gz
nixlib-5239dc4d9e06da8a18bc3a528a5b312d79cae8aa.tar.bz2
nixlib-5239dc4d9e06da8a18bc3a528a5b312d79cae8aa.tar.lz
nixlib-5239dc4d9e06da8a18bc3a528a5b312d79cae8aa.tar.xz
nixlib-5239dc4d9e06da8a18bc3a528a5b312d79cae8aa.tar.zst
nixlib-5239dc4d9e06da8a18bc3a528a5b312d79cae8aa.zip
Merge pull request #107786 from freezeboy/update-atop
atop: 2.4.0 -> 2.6.0
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/atop/default.nix20
1 files changed, 11 insertions, 9 deletions
diff --git a/pkgs/os-specific/linux/atop/default.nix b/pkgs/os-specific/linux/atop/default.nix
index 0d8392cbcd8a..7557497b959e 100644
--- a/pkgs/os-specific/linux/atop/default.nix
+++ b/pkgs/os-specific/linux/atop/default.nix
@@ -1,22 +1,24 @@
 {stdenv, fetchurl, zlib, ncurses}:
 
 stdenv.mkDerivation rec {
-  version = "2.4.0";
   pname = "atop";
+  version = "2.6.0";
 
   src = fetchurl {
     url = "https://www.atoptool.nl/download/atop-${version}.tar.gz";
-    sha256 = "0s9xlxlzz688a80zxld840zkrmzw998rdkkg6yc7ssq8fw50275y";
+    sha256 = "nsLKOlcWkvfvqglfmaUQZDK8txzCLNbElZfvBIEFj3I=";
   };
 
   buildInputs = [zlib ncurses];
 
   makeFlags = [
-    ''SCRPATH=$out/etc/atop''
-    ''LOGPATH=/var/log/atop''
-    ''INIPATH=$out/etc/rc.d/init.d''
-    ''CRNPATH=$out/etc/cron.d''
-    ''ROTPATH=$out/etc/logrotate.d''
+    "SCRPATH=$out/etc/atop"
+    "LOGPATH=/var/log/atop"
+    "INIPATH=$out/etc/rc.d/init.d"
+    "SYSDPATH=$out/lib/systemd/system"
+    "CRNPATH=$out/etc/cron.d"
+    "DEFPATH=$out/etc/default"
+    "ROTPATH=$out/etc/logrotate.d"
   ];
 
   preConfigure = ''
@@ -28,9 +30,9 @@ stdenv.mkDerivation rec {
     sed -e 's/chmod 04711/chmod 0711/g' -i Makefile
   '';
 
+  installTargets = [ "systemdinstall" ];
   preInstall = ''
     mkdir -p "$out"/{bin,sbin}
-    make systemdinstall $makeFlags
   '';
 
   meta = with stdenv.lib; {
@@ -42,7 +44,7 @@ stdenv.mkDerivation rec {
       Atop is an ASCII full-screen performance monitor that is capable of reporting the activity of all processes (even if processes have finished during the interval), daily logging of system and process activity for long-term analysis, highlighting overloaded system resources by using colors, etc. At regular intervals, it shows system-level activity related to the CPU, memory, swap, disks and network layers, and for every active process it shows the CPU utilization, memory growth, disk utilization, priority, username, state, and exit code.
     '';
     inherit version;
-    license = licenses.gpl2;
+    license = licenses.gpl2Plus;
     downloadPage = "http://atoptool.nl/downloadatop.php";
   };
 }