about summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorAlyssa Ross <hi@alyssa.is>2024-02-27 13:41:37 +0100
committerAlyssa Ross <hi@alyssa.is>2024-02-27 13:44:16 +0100
commit45f1428902a6fe08ff343a7ebb7254cd1ca98785 (patch)
treecb6b8f930c58576c03ac30589b273fff1c89ee2b /pkgs/os-specific
parent661d1becc7fdb64894cb4741528f574587537f2f (diff)
downloadnixlib-45f1428902a6fe08ff343a7ebb7254cd1ca98785.tar
nixlib-45f1428902a6fe08ff343a7ebb7254cd1ca98785.tar.gz
nixlib-45f1428902a6fe08ff343a7ebb7254cd1ca98785.tar.bz2
nixlib-45f1428902a6fe08ff343a7ebb7254cd1ca98785.tar.lz
nixlib-45f1428902a6fe08ff343a7ebb7254cd1ca98785.tar.xz
nixlib-45f1428902a6fe08ff343a7ebb7254cd1ca98785.tar.zst
nixlib-45f1428902a6fe08ff343a7ebb7254cd1ca98785.zip
zfs_2_1: 2.1.14 -> 2.1.15
This adds compatibility with newer kernels, which fixes
nixosTests.zfs.series_2_1, which broke when the default kernel version
was bumped.

This means we no longer need the removeLinuxDRM option at all, but
I've kept it around as a no-op so people can leave it set in case the
same thing happens again in future.
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/zfs/2_1.nix14
1 files changed, 4 insertions, 10 deletions
diff --git a/pkgs/os-specific/linux/zfs/2_1.nix b/pkgs/os-specific/linux/zfs/2_1.nix
index 4642bc20f6fc..73cc0d962703 100644
--- a/pkgs/os-specific/linux/zfs/2_1.nix
+++ b/pkgs/os-specific/linux/zfs/2_1.nix
@@ -2,7 +2,6 @@
 , kernel ? null
 , stdenv
 , linuxKernel
-, removeLinuxDRM ? false
 , lib
 , nixosTests
 , ...
@@ -16,20 +15,15 @@ callPackage ./generic.nix args {
   # this attribute is the correct one for this package.
   kernelModuleAttribute = "zfs_2_1";
   # check the release notes for compatible kernels
-  kernelCompatible =
-    if stdenv'.isx86_64 || removeLinuxDRM
-    then kernel.kernelOlder "6.6"
-    else kernel.kernelOlder "6.2";
+  kernelCompatible = kernel.kernelOlder "6.8";
 
-  latestCompatibleLinuxPackages = if stdenv'.isx86_64 || removeLinuxDRM
-    then linuxKernel.packages.linux_6_5
-    else linuxKernel.packages.linux_6_1;
+  latestCompatibleLinuxPackages = linuxKernel.packages.linux_6_7;
 
   # This is a fixed version to the 2.1.x series, move only
   # if the 2.1.x series moves.
-  version = "2.1.14";
+  version = "2.1.15";
 
-  hash = "sha256-RVAoZbV9yclGuN+D37SB6UCRFbbLEpBoyrQOQCVsQwE=";
+  hash = "sha256-zFO8fMbirEOrn5W57rAN7IWY6EIXG8jDXqhP7BWJyiY=";
 
   tests = [
     nixosTests.zfs.series_2_1