about summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <tobias.geerinckx.rice@gmail.com>2015-01-12 16:30:27 +0100
committerTobias Geerinckx-Rice <tobias.geerinckx.rice@gmail.com>2015-01-12 16:30:28 +0100
commit40ed9007f15b11949137020a8e5a682c6b777723 (patch)
tree1e718e393ff6a7c8375d43a02003e59a1ee363f8 /pkgs/os-specific
parent520cc3518a67760bc92f81ce3f1f2769eba16ecf (diff)
downloadnixlib-40ed9007f15b11949137020a8e5a682c6b777723.tar
nixlib-40ed9007f15b11949137020a8e5a682c6b777723.tar.gz
nixlib-40ed9007f15b11949137020a8e5a682c6b777723.tar.bz2
nixlib-40ed9007f15b11949137020a8e5a682c6b777723.tar.lz
nixlib-40ed9007f15b11949137020a8e5a682c6b777723.tar.xz
nixlib-40ed9007f15b11949137020a8e5a682c6b777723.tar.zst
nixlib-40ed9007f15b11949137020a8e5a682c6b777723.zip
readeontop: build without patches & include some git bugfixes
Also add my initial longDescription, and build in parallel.
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/radeontop/default.nix38
-rw-r--r--pkgs/os-specific/linux/radeontop/install-paths.patch36
-rw-r--r--pkgs/os-specific/linux/radeontop/version-header.patch21
3 files changed, 18 insertions, 77 deletions
diff --git a/pkgs/os-specific/linux/radeontop/default.nix b/pkgs/os-specific/linux/radeontop/default.nix
index ed159bbf37f9..921021833c1a 100644
--- a/pkgs/os-specific/linux/radeontop/default.nix
+++ b/pkgs/os-specific/linux/radeontop/default.nix
@@ -1,39 +1,37 @@
-{ stdenv, fetchurl, substituteAll, pkgconfig
-, gettext, ncurses, libdrm, libpciaccess }:
+{ stdenv, fetchgit, pkgconfig, gettext, ncurses, libdrm, libpciaccess }:
 
 stdenv.mkDerivation rec {
   name = "radeontop-${version}";
-  version = "0.8";
+  version = "v0.8-8-g575a416";
 
-  src = fetchurl {
-    url = "https://github.com/clbr/radeontop/archive/v${version}.tar.gz";
-    sha256 = "12c4kpr9zy2a21k8mck9cbfwm54x1l0i96va97m70pc9ramf2c24";
+  src = fetchgit {
+    url = git://github.com/clbr/radeontop.git;
+    rev = "575a416596dbedb25bc6f3f0b16a0e2296fbb9bb";
+    sha256 = "6100a7159384cfcd71e59ef7096450e975d01786ee4e3a7cf9c0e56045c4ac91";
   };
 
   buildInputs = [ pkgconfig gettext ncurses libdrm libpciaccess ];
 
-  patches = [
-    ./install-paths.patch
+  enableParallelBuilding = true;
 
-    # The default generation of version.h expects a git clone.
-    (substituteAll {
-      src = ./version-header.patch;
-      inherit version;
-    })
-  ];
-
-  postPatch = ''
-    substituteInPlace radeontop.c \
-      --replace /usr/share/locale $out/share/locale
+  patchPhase = ''
+    substituteInPlace getver.sh --replace ver=unknown ver=${version}
   '';
 
-  makeFlags = "DESTDIR=$(out)";
+  makeFlags = "PREFIX=$(out)";
 
   meta = with stdenv.lib; {
     description = "Top-like tool for viewing AMD Radeon GPU utilization";
+    longDescription = ''
+      View GPU utilization, both for the total activity percent and individual
+      blocks. Supports R600 and later cards: even Southern Islands should work.
+      Works with both the open drivers and AMD Catalyst. Total GPU utilization
+      is also valid for OpenCL loads; the other blocks are only useful for GL
+      loads. Requires root rights or other permissions to read /dev/mem.
+    '';
     homepage = https://github.com/clbr/radeontop;
     platforms = platforms.linux;
     license = licenses.gpl3;
-    maintainers = [ maintainers.rycee ];
+    maintainers = with maintainers; [ rycee nckx ];
   };
 }
diff --git a/pkgs/os-specific/linux/radeontop/install-paths.patch b/pkgs/os-specific/linux/radeontop/install-paths.patch
deleted file mode 100644
index 59aee99d0bc3..000000000000
--- a/pkgs/os-specific/linux/radeontop/install-paths.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-diff -Nurp radeontop-0.8-orig/Makefile radeontop-0.8/Makefile
---- radeontop-0.8-orig/Makefile	2015-01-03 09:34:30.205507608 +0100
-+++ radeontop-0.8/Makefile	2015-01-03 09:43:22.835174006 +0100
-@@ -7,7 +7,6 @@
- #	nostrip	disable stripping, default off
- #	plain	apply neither -g nor -s.
- 
--PREFIX ?= /usr
- INSTALL ?= install
- 
- nls ?= 1
-@@ -74,10 +73,10 @@ trans:
- 	--package-name radeontop
- 
- install: all
--	$(INSTALL) -D -m755 $(bin) $(DESTDIR)/$(PREFIX)/sbin/$(bin)
--	$(INSTALL) -D -m644 radeontop.1 $(DESTDIR)/$(PREFIX)/share/man/man1/radeontop.1
-+	$(INSTALL) -D -m755 $(bin) $(DESTDIR)/sbin/$(bin)
-+	$(INSTALL) -D -m644 radeontop.1 $(DESTDIR)/share/man/man1/radeontop.1
- ifeq ($(nls), 1)
--	$(MAKE) -C translations install PREFIX=$(PREFIX)
-+	$(MAKE) -C translations install DESTDIR=$(DESTDIR)
- endif
- 
- man:
-diff -Nurp radeontop-0.8-orig/translations/Makefile radeontop-0.8/translations/Makefile
---- radeontop-0.8-orig/translations/Makefile	2015-01-03 09:34:30.205507608 +0100
-+++ radeontop-0.8/translations/Makefile	2015-01-03 09:43:40.235309691 +0100
-@@ -15,6 +15,6 @@ $(obj): $(src)
- 	$(MSGFMT) -o $@ $<
- 
- %.inst: %.mo
--	$(INSTALL) -D -m 644 $< $(DESTDIR)/$(PREFIX)/share/locale/$*/LC_MESSAGES/radeontop.mo
-+	$(INSTALL) -D -m 644 $< $(DESTDIR)/share/locale/$*/LC_MESSAGES/radeontop.mo
- 
- install: all $(inst)
diff --git a/pkgs/os-specific/linux/radeontop/version-header.patch b/pkgs/os-specific/linux/radeontop/version-header.patch
deleted file mode 100644
index 784464794d72..000000000000
--- a/pkgs/os-specific/linux/radeontop/version-header.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -Nurp radeontop-0.8-orig/include/version.h radeontop-0.8/include/version.h
---- radeontop-0.8-orig/include/version.h	1970-01-01 01:00:00.000000000 +0100
-+++ radeontop-0.8/include/version.h	2015-01-03 09:34:58.114335049 +0100
-@@ -0,0 +1,6 @@
-+#ifndef VER_H
-+#define VER_H
-+
-+#define VERSION "@version@"
-+
-+#endif
-diff -Nurp radeontop-0.8-orig/Makefile radeontop-0.8/Makefile
---- radeontop-0.8-orig/Makefile	2015-01-03 09:34:30.205507608 +0100
-+++ radeontop-0.8/Makefile	2015-01-03 09:38:36.765881422 +0100
-@@ -67,7 +67,6 @@ clean:
- .git:
- 
- $(verh): .git
--	./getver.sh
- 
- trans:
- 	xgettext -o translations/radeontop.pot -k_ *.c \