about summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2014-01-19 22:35:24 -0500
committerShea Levy <shea@shealevy.com>2014-01-19 22:35:24 -0500
commit3ae5e801a51c7f5a1b5370901b23d736af1d4b1c (patch)
tree9a6cc506ef4ac73ff3138ef3b830ec41bf2ee064 /pkgs/os-specific
parentb529a34b4a743d57fbe456afc84109eab31f8c09 (diff)
downloadnixlib-3ae5e801a51c7f5a1b5370901b23d736af1d4b1c.tar
nixlib-3ae5e801a51c7f5a1b5370901b23d736af1d4b1c.tar.gz
nixlib-3ae5e801a51c7f5a1b5370901b23d736af1d4b1c.tar.bz2
nixlib-3ae5e801a51c7f5a1b5370901b23d736af1d4b1c.tar.lz
nixlib-3ae5e801a51c7f5a1b5370901b23d736af1d4b1c.tar.xz
nixlib-3ae5e801a51c7f5a1b5370901b23d736af1d4b1c.tar.zst
nixlib-3ae5e801a51c7f5a1b5370901b23d736af1d4b1c.zip
Linux 3.13
Signed-off-by: Shea Levy <shea@shealevy.com>
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/kernel/common-config.nix4
-rw-r--r--pkgs/os-specific/linux/kernel/linux-3.13.nix18
2 files changed, 21 insertions, 1 deletions
diff --git a/pkgs/os-specific/linux/kernel/common-config.nix b/pkgs/os-specific/linux/kernel/common-config.nix
index 01a605aac309..8b96a321634d 100644
--- a/pkgs/os-specific/linux/kernel/common-config.nix
+++ b/pkgs/os-specific/linux/kernel/common-config.nix
@@ -63,7 +63,9 @@ with stdenv.lib;
 
   # Networking options.
   IP_PNP n
+  ${optionalString (versionOlder version "3.13") ''
   IPV6_PRIVACY y
+  ''}
   NETFILTER_ADVANCED y
   IP_VS_PROTO_TCP y
   IP_VS_PROTO_UDP y
@@ -176,7 +178,7 @@ with stdenv.lib;
   AIC79XX_DEBUG_ENABLE n
   AIC7XXX_DEBUG_ENABLE n
   AIC94XX_DEBUG n
-  ${optionalString (versionAtLeast version "3.3") ''
+  ${optionalString (versionAtLeast version "3.3" && versionOlder version "3.13") ''
     AUDIT_LOGINUID_IMMUTABLE y
   ''}
   B43_PCMCIA y
diff --git a/pkgs/os-specific/linux/kernel/linux-3.13.nix b/pkgs/os-specific/linux/kernel/linux-3.13.nix
new file mode 100644
index 000000000000..967de85b7b3f
--- /dev/null
+++ b/pkgs/os-specific/linux/kernel/linux-3.13.nix
@@ -0,0 +1,18 @@
+{ stdenv, fetchurl, ... } @ args:
+
+import ./generic.nix (args // rec {
+  version = "3.13";
+
+  modDirVersion = "3.13.0";
+
+  src = fetchurl {
+    url = "mirror://kernel/linux/kernel/v3.x/linux-${version}.tar.xz";
+    sha256 = "4d5e5eee5f276424c32e9591f1b6c971baedc7b49f28ce03d1f48b1e5d6226a2";
+  };
+
+  features.iwlwifi = true;
+  features.efiBootStub = true;
+  features.needsCifsUtils = true;
+  features.canDisableNetfilterConntrackHelpers = true;
+  features.netfilterRPFilter = true;
+})