about summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorWill Dietz <w@wdtz.org>2019-10-07 18:01:49 -0500
committerGitHub <noreply@github.com>2019-10-07 18:01:49 -0500
commit3a9e0f7a78a4756200f7c2f3fe65ebf6cde07609 (patch)
tree257181eeea6fadc14cf5452d98f1a26614c12940 /pkgs/os-specific
parent917200c7287c2c5bae3eeef18d2c6208743e1388 (diff)
parent647a90fd925bb47423423b878faccf635be2c982 (diff)
downloadnixlib-3a9e0f7a78a4756200f7c2f3fe65ebf6cde07609.tar
nixlib-3a9e0f7a78a4756200f7c2f3fe65ebf6cde07609.tar.gz
nixlib-3a9e0f7a78a4756200f7c2f3fe65ebf6cde07609.tar.bz2
nixlib-3a9e0f7a78a4756200f7c2f3fe65ebf6cde07609.tar.lz
nixlib-3a9e0f7a78a4756200f7c2f3fe65ebf6cde07609.tar.xz
nixlib-3a9e0f7a78a4756200f7c2f3fe65ebf6cde07609.tar.zst
nixlib-3a9e0f7a78a4756200f7c2f3fe65ebf6cde07609.zip
Merge pull request #68911 from dtzWill/feature/power-calibrate
power-calibrate: init at 0.01.28
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/power-calibrate/default.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/pkgs/os-specific/linux/power-calibrate/default.nix b/pkgs/os-specific/linux/power-calibrate/default.nix
new file mode 100644
index 000000000000..75c6f1716fc5
--- /dev/null
+++ b/pkgs/os-specific/linux/power-calibrate/default.nix
@@ -0,0 +1,24 @@
+{ stdenv, lib, fetchurl }:
+
+stdenv.mkDerivation rec {
+  pname = "power-calibrate";
+  version = "0.01.28";
+
+  src = fetchurl {
+    url = "https://kernel.ubuntu.com/~cking/tarballs/${pname}/${pname}-${version}.tar.gz";
+    sha256 = "1miyjs0vngzfdlsxhn5gndcalzkh28grg4m6faivvp1c6mjp794m";
+  };
+
+  installFlags = [
+    "BINDIR=${placeholder "out"}/bin"
+    "MANDIR=${placeholder "out"}/share/man/man8"
+  ];
+
+  meta = with lib; {
+    description = "Tool to calibrate power consumption";
+    homepage = "https://kernel.ubuntu.com/~cking/power-calibrate/";
+    license = licenses.gpl2;
+    platforms = platforms.linux;
+    maintainers = with maintainers; [ dtzWill ];
+  };
+}