about summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorLinus Heckemann <git@sphalerite.org>2019-05-14 17:37:19 +0200
committerGitHub <noreply@github.com>2019-05-14 17:37:19 +0200
commit1d37727453a3ce764b505d7375138db18633386e (patch)
tree4a9df41f312912228cdc729b2adf433a225faaaa /pkgs/os-specific
parentfaf5e8ad8cf2a4b4a09f86b1a6474f1c32479af9 (diff)
parente4c269813c7a41b7b6e3b615a9cb68b2972b4fb5 (diff)
downloadnixlib-1d37727453a3ce764b505d7375138db18633386e.tar
nixlib-1d37727453a3ce764b505d7375138db18633386e.tar.gz
nixlib-1d37727453a3ce764b505d7375138db18633386e.tar.bz2
nixlib-1d37727453a3ce764b505d7375138db18633386e.tar.lz
nixlib-1d37727453a3ce764b505d7375138db18633386e.tar.xz
nixlib-1d37727453a3ce764b505d7375138db18633386e.tar.zst
nixlib-1d37727453a3ce764b505d7375138db18633386e.zip
Merge pull request #61162 from lheckemann/kernel-preempt-voluntary
Kernel config: use PREEMPT_VOLUNTARY
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/kernel/common-config.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/pkgs/os-specific/linux/kernel/common-config.nix b/pkgs/os-specific/linux/kernel/common-config.nix
index 58a2429d47c6..8a735ea7b910 100644
--- a/pkgs/os-specific/linux/kernel/common-config.nix
+++ b/pkgs/os-specific/linux/kernel/common-config.nix
@@ -548,7 +548,9 @@ let
       TEST_ASYNC_DRIVER_PROBE  = option no;
       WW_MUTEX_SELFTEST        = option no;
       XZ_DEC_TEST              = option no;
-    } // optionalAttrs (features.criu or false) ({
+    };
+
+    criu = optionalAttrs (features.criu or false) ({
       EXPERT              = yes;
       CHECKPOINT_RESTORE  = yes;
     } // optionalAttrs (features.criu_revert_expert or true) {
@@ -690,6 +692,9 @@ let
       # Enable AMD's ROCm GPU compute stack
       HSA_AMD = whenAtLeast "4.20" yes;
 
+      PREEMPT = no;
+      PREEMPT_VOLUNTARY = yes;
+
     } // optionalAttrs (stdenv.hostPlatform.system == "x86_64-linux" || stdenv.hostPlatform.system == "aarch64-linux") {
       # Enable memory hotplug support
       # Allows you to dynamically add & remove memory to a VM client running NixOS without requiring a reboot