about summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2018-10-30 20:35:15 +0100
committerFrederik Rietdijk <fridh@fridh.nl>2018-10-30 20:35:15 +0100
commit1d196d99be8f9122e201f3bff0b87b8f1c4d4248 (patch)
tree5a701a9fa63398165678228684a5a28b5a6886f4 /pkgs/os-specific
parent50744a279ca9e7985f30ece576c0670b45d197bd (diff)
parent0e0d20fb5facbaafe04d7b96cff7bab174375e5c (diff)
downloadnixlib-1d196d99be8f9122e201f3bff0b87b8f1c4d4248.tar
nixlib-1d196d99be8f9122e201f3bff0b87b8f1c4d4248.tar.gz
nixlib-1d196d99be8f9122e201f3bff0b87b8f1c4d4248.tar.bz2
nixlib-1d196d99be8f9122e201f3bff0b87b8f1c4d4248.tar.lz
nixlib-1d196d99be8f9122e201f3bff0b87b8f1c4d4248.tar.xz
nixlib-1d196d99be8f9122e201f3bff0b87b8f1c4d4248.tar.zst
nixlib-1d196d99be8f9122e201f3bff0b87b8f1c4d4248.zip
Merge staging-next into staging
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/mdadm/default.nix5
-rw-r--r--pkgs/os-specific/linux/upower/default.nix6
-rw-r--r--pkgs/os-specific/linux/zfs/default.nix4
3 files changed, 8 insertions, 7 deletions
diff --git a/pkgs/os-specific/linux/mdadm/default.nix b/pkgs/os-specific/linux/mdadm/default.nix
index 52a5f16bc52c..c6c5f8436902 100644
--- a/pkgs/os-specific/linux/mdadm/default.nix
+++ b/pkgs/os-specific/linux/mdadm/default.nix
@@ -14,11 +14,11 @@ let
   '';
 in
 stdenv.mkDerivation rec {
-  name = "mdadm-4.0";
+  name = "mdadm-4.1";
 
   src = fetchurl {
     url = "mirror://kernel/linux/utils/raid/mdadm/${name}.tar.xz";
-    sha256 = "1ad3mma641946wn5lsllwf0lifw9lps34fv1nnkhyfpd9krffshx";
+    sha256 = "0jjgjgqijpdp7ijh8slzzjjw690kydb1jjadf0x5ilq85628hxmb";
   };
 
   # This is to avoid self-references, which causes the initrd to explode
@@ -47,6 +47,7 @@ stdenv.mkDerivation rec {
     description = "Programs for managing RAID arrays under Linux";
     homepage = http://neil.brown.name/blog/mdadm;
     license = licenses.gpl2;
+    maintainers = with maintainers; [ ekleog ];
     platforms = platforms.linux;
   };
 }
diff --git a/pkgs/os-specific/linux/upower/default.nix b/pkgs/os-specific/linux/upower/default.nix
index 629f61bf5b16..6c6e411000ac 100644
--- a/pkgs/os-specific/linux/upower/default.nix
+++ b/pkgs/os-specific/linux/upower/default.nix
@@ -4,11 +4,11 @@
 }:
 
 stdenv.mkDerivation rec {
-  name = "upower-0.99.7";
+  name = "upower-0.99.9";
 
   src = fetchurl {
-    url = "https://upower.freedesktop.org/releases/${name}.tar.xz";
-    sha256 = "00d4830yvg84brdhz4kn60lr3r8rn2y8gdbhmhxm78i5mgvc5g14";
+    url = https://gitlab.freedesktop.org/upower/upower/uploads/2282c7c0e53fb31816b824c9d1f547e8/upower-0.99.9.tar.xz;
+    sha256 = "046ix7j7hmb7ycv8v54668kjsrgjhzwxn299c1d87vdnkd38kfh1";
   };
 
   buildInputs =
diff --git a/pkgs/os-specific/linux/zfs/default.nix b/pkgs/os-specific/linux/zfs/default.nix
index cae06dbd0f38..ed83313e5ddf 100644
--- a/pkgs/os-specific/linux/zfs/default.nix
+++ b/pkgs/os-specific/linux/zfs/default.nix
@@ -158,7 +158,7 @@ in {
   # to be adapted
   zfsStable = common {
     # comment/uncomment if breaking kernel versions are known
-    # incompatibleKernelVersion = null;
+    incompatibleKernelVersion = "4.19";
 
     # this package should point to the latest release.
     version = "0.7.11";
@@ -177,7 +177,7 @@ in {
 
   zfsUnstable = common rec {
     # comment/uncomment if breaking kernel versions are known
-    incompatibleKernelVersion = null;
+    incompatibleKernelVersion = "4.19";
 
     # this package should point to a version / git revision compatible with the latest kernel release
     version = "0.8.0-rc1";