about summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <tobias.geerinckx.rice@gmail.com>2015-09-07 02:08:23 +0200
committerTobias Geerinckx-Rice <tobias.geerinckx.rice@gmail.com>2015-09-07 02:09:48 +0200
commit1102018a0004a1541e587908b7c457e7f4888549 (patch)
treee987216e751b45ce21f67eb390f9c1ac939efff4 /pkgs/os-specific
parent7fa5710d50b245a853de299bf18b84265bd49564 (diff)
downloadnixlib-1102018a0004a1541e587908b7c457e7f4888549.tar
nixlib-1102018a0004a1541e587908b7c457e7f4888549.tar.gz
nixlib-1102018a0004a1541e587908b7c457e7f4888549.tar.bz2
nixlib-1102018a0004a1541e587908b7c457e7f4888549.tar.lz
nixlib-1102018a0004a1541e587908b7c457e7f4888549.tar.xz
nixlib-1102018a0004a1541e587908b7c457e7f4888549.tar.zst
nixlib-1102018a0004a1541e587908b7c457e7f4888549.zip
htop: touch all headers
Fix the following build failure:

```
config.status: executing libtool commands
building
make flags: SHELL=/nix/store/548wfw1i43glkx8lkyjmbg59h6127qky-bash-4.3-p39/bin/bash
./scripts/MakeHeader.py ColumnsPanel.c
/usr/bin/env: python: No such file or directory
Makefile:2164: recipe for target 'ColumnsPanel.h' failed
make: *** [ColumnsPanel.h] Error 127
builder for ‘/nix/store/6rai1vs6jsw8y5z5jff98f0f8jzfa12n-htop-1.0.3-584-8f07868f.drv’ failed with exit code 2
```
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/htop/default.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/pkgs/os-specific/linux/htop/default.nix b/pkgs/os-specific/linux/htop/default.nix
index 873795c9752b..8f3250f85f7f 100644
--- a/pkgs/os-specific/linux/htop/default.nix
+++ b/pkgs/os-specific/linux/htop/default.nix
@@ -13,6 +13,10 @@ stdenv.mkDerivation rec {
   buildInputs = [ ncurses ];
   nativeBuildInputs = [ autoreconfHook ];
 
+  postPatch = ''
+    touch *.h # unnecessary regeneration requires Python
+  '';
+
   meta = {
     description = "An interactive process viewer for Linux";
     homepage = "http://htop.sourceforge.net";