about summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorKirill Boltaev <aske@fmap.me>2016-09-13 20:42:55 +0300
committerKirill Boltaev <aske@fmap.me>2016-09-13 21:09:24 +0300
commit0f37287df5c4ba0343c292ddfe827224efa87daf (patch)
treece3a7a0659c5c478cb75c96c93051b83532a8d9b /pkgs/os-specific
parent4b55b0358ad7c636b581bb8b665540f013ef68af (diff)
downloadnixlib-0f37287df5c4ba0343c292ddfe827224efa87daf.tar
nixlib-0f37287df5c4ba0343c292ddfe827224efa87daf.tar.gz
nixlib-0f37287df5c4ba0343c292ddfe827224efa87daf.tar.bz2
nixlib-0f37287df5c4ba0343c292ddfe827224efa87daf.tar.lz
nixlib-0f37287df5c4ba0343c292ddfe827224efa87daf.tar.xz
nixlib-0f37287df5c4ba0343c292ddfe827224efa87daf.tar.zst
nixlib-0f37287df5c4ba0343c292ddfe827224efa87daf.zip
treewide: explicitly specify gtk version
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/kernel/perf.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/pkgs/os-specific/linux/kernel/perf.nix b/pkgs/os-specific/linux/kernel/perf.nix
index 4b1120afa4e7..69a951875a53 100644
--- a/pkgs/os-specific/linux/kernel/perf.nix
+++ b/pkgs/os-specific/linux/kernel/perf.nix
@@ -1,11 +1,11 @@
 { lib, stdenv, kernel, elfutils, python, perl, newt, slang, asciidoc, xmlto
 , docbook_xsl, docbook_xml_dtd_45, libxslt, flex, bison, pkgconfig, libunwind, binutils
 , libiberty
-, zlib, withGtk ? false, gtk ? null }:
+, zlib, withGtk ? false, gtk2 ? null }:
 
 with lib;
 
-assert withGtk -> gtk != null;
+assert withGtk -> gtk2 != null;
 assert versionAtLeast kernel.version "3.12";
 
 stdenv.mkDerivation {
@@ -26,7 +26,7 @@ stdenv.mkDerivation {
   nativeBuildInputs = [ asciidoc xmlto docbook_xsl docbook_xml_dtd_45 libxslt
       flex bison libiberty ];
   buildInputs = [ elfutils python perl newt slang pkgconfig libunwind binutils zlib ] ++
-    stdenv.lib.optional withGtk gtk;
+    stdenv.lib.optional withGtk gtk2;
 
   # Note: we don't add elfutils to buildInputs, since it provides a
   # bad `ld' and other stuff.