about summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorJohn Ericson <subscribe@JohnEricson.me>2018-09-15 01:37:18 -0400
committerGitHub <noreply@github.com>2018-09-15 01:37:18 -0400
commit0bfdab21cf69f823b6fe647192bb063a93618fc2 (patch)
treea012f43d8a5d2796aa2f8e39d0cf0f840af88446 /pkgs/os-specific
parent218ce4de5083a4b969df3db349b08f5a2737b628 (diff)
parentb8ce6a31f555a2e4471880cc4c01b629e7d6d36f (diff)
downloadnixlib-0bfdab21cf69f823b6fe647192bb063a93618fc2.tar
nixlib-0bfdab21cf69f823b6fe647192bb063a93618fc2.tar.gz
nixlib-0bfdab21cf69f823b6fe647192bb063a93618fc2.tar.bz2
nixlib-0bfdab21cf69f823b6fe647192bb063a93618fc2.tar.lz
nixlib-0bfdab21cf69f823b6fe647192bb063a93618fc2.tar.xz
nixlib-0bfdab21cf69f823b6fe647192bb063a93618fc2.tar.zst
nixlib-0bfdab21cf69f823b6fe647192bb063a93618fc2.zip
Merge pull request #46574 from obsidiansystems/elf-header
elf-header: Init at <libc version> 
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/kernel-headers/default.nix4
1 files changed, 1 insertions, 3 deletions
diff --git a/pkgs/os-specific/linux/kernel-headers/default.nix b/pkgs/os-specific/linux/kernel-headers/default.nix
index e82b785f624a..09fa4fbfd3a7 100644
--- a/pkgs/os-specific/linux/kernel-headers/default.nix
+++ b/pkgs/os-specific/linux/kernel-headers/default.nix
@@ -2,8 +2,6 @@
 , fetchurl, perl
 }:
 
-assert stdenvNoCC.hostPlatform.isLinux;
-
 let
   common = { version, sha256, patches ? null }: stdenvNoCC.mkDerivation {
     name = "linux-headers-${version}";
@@ -13,7 +11,7 @@ let
       inherit sha256;
     };
 
-    ARCH = stdenvNoCC.hostPlatform.platform.kernelArch;
+    ARCH = stdenvNoCC.hostPlatform.platform.kernelArch or (throw "missing kernelArch");
 
     # It may look odd that we use `stdenvNoCC`, and yet explicit depend on a cc.
     # We do this so we have a build->build, not build->host, C compiler.