about summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorAnderson Torres <torres.anderson.85@protonmail.com>2020-12-26 23:53:48 -0300
committerGitHub <noreply@github.com>2020-12-26 23:53:48 -0300
commit086946df119fea386448a3110f257aafa29e9bed (patch)
tree8242f1f596d8613355ef946582a13f4fc7b7f51f /pkgs/os-specific
parent9ed0fa8cf38d326d132c34c998b94bc5fb21bd5b (diff)
parent0d0ff21f2f25021ab1661725579f3d5ca9a619d9 (diff)
downloadnixlib-086946df119fea386448a3110f257aafa29e9bed.tar
nixlib-086946df119fea386448a3110f257aafa29e9bed.tar.gz
nixlib-086946df119fea386448a3110f257aafa29e9bed.tar.bz2
nixlib-086946df119fea386448a3110f257aafa29e9bed.tar.lz
nixlib-086946df119fea386448a3110f257aafa29e9bed.tar.xz
nixlib-086946df119fea386448a3110f257aafa29e9bed.tar.zst
nixlib-086946df119fea386448a3110f257aafa29e9bed.zip
Merge pull request #91203 from davidak/zsa
nixos/zsa: init at unstable-2020-12-16
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/zsa-udev-rules/default.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/pkgs/os-specific/linux/zsa-udev-rules/default.nix b/pkgs/os-specific/linux/zsa-udev-rules/default.nix
new file mode 100644
index 000000000000..76150affe49f
--- /dev/null
+++ b/pkgs/os-specific/linux/zsa-udev-rules/default.nix
@@ -0,0 +1,33 @@
+{ stdenv, fetchFromGitHub }:
+
+stdenv.mkDerivation {
+  pname = "zsa-udev-rules";
+  version = "unstable-2020-12-16";
+
+  # TODO: use version and source from nixpkgs/pkgs/development/tools/wally-cli/default.nix after next release
+  src = fetchFromGitHub {
+    owner = "zsa";
+    repo = "wally";
+    rev = "e5dde3c700beab39fb941c6941e55535bf9b2af6";
+    sha256 = "0pkybi32r1hrmpa1mc8qlzhv7xy5n5rr5ah25lbr0cipp1bda417";
+  };
+
+  # it only installs files
+  dontConfigure = true;
+  dontBuild = true;
+  dontFixup = true;
+
+  installPhase = ''
+    mkdir -p $out/lib/udev/rules.d
+    cp dist/linux64/50-oryx.rules $out/lib/udev/rules.d/
+    cp dist/linux64/50-wally.rules $out/lib/udev/rules.d/
+  '';
+
+  meta = with stdenv.lib; {
+    description = "udev rules for ZSA devices";
+    license = licenses.mit;
+    maintainers = with maintainers; [ davidak ];
+    platforms = platforms.linux;
+    homepage = "https://github.com/zsa/wally/wiki/Linux-install#2-create-a-udev-rule-file";
+  };
+}