about summary refs log tree commit diff
path: root/pkgs/misc
diff options
context:
space:
mode:
authorWilliamHsieh <wh31110@gmail.com>2024-01-12 17:20:17 +0800
committerGitHub <noreply@github.com>2024-01-12 10:20:17 +0100
commitfeab83792948416260d13fee7cc6b0b95f182014 (patch)
tree97c599ffc57ba218c7f237337f1d98492e6e2d34 /pkgs/misc
parent59af5c3e45eef4e04384e2f9c0ebae58b39e2f68 (diff)
downloadnixlib-feab83792948416260d13fee7cc6b0b95f182014.tar
nixlib-feab83792948416260d13fee7cc6b0b95f182014.tar.gz
nixlib-feab83792948416260d13fee7cc6b0b95f182014.tar.bz2
nixlib-feab83792948416260d13fee7cc6b0b95f182014.tar.lz
nixlib-feab83792948416260d13fee7cc6b0b95f182014.tar.xz
nixlib-feab83792948416260d13fee7cc6b0b95f182014.tar.zst
nixlib-feab83792948416260d13fee7cc6b0b95f182014.zip
tmux-fingers: 1.0.1 -> 2.1.1 (#280173)
---------

Co-authored-by: williamhsieh <williamhsieh@synology.com>
Co-authored-by: Jörg Thalheim <Mic92@users.noreply.github.com>
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/tmux-plugins/default.nix21
1 files changed, 12 insertions, 9 deletions
diff --git a/pkgs/misc/tmux-plugins/default.nix b/pkgs/misc/tmux-plugins/default.nix
index ed9dae360230..8fa8f654d76b 100644
--- a/pkgs/misc/tmux-plugins/default.nix
+++ b/pkgs/misc/tmux-plugins/default.nix
@@ -244,23 +244,26 @@ in rec {
 
   fingers = mkTmuxPlugin rec {
     pluginName = "fingers";
-    rtpFilePath = "tmux-fingers.tmux";
-    version = "1.0.1";
+    rtpFilePath = "load-config.tmux";
+    version = "2.1.1";
     src = fetchFromGitHub {
       owner = "Morantron";
       repo = "tmux-fingers";
-      rev = version;
-      sha256 = "0gp37m3d0irrsih96qv2yalvr1wmf1n64589d4qzyzq16lzyjcr0";
-      fetchSubmodules = true;
+      rev = "${version}";
+      sha256 = "sha256-1YMh6m8M6FKf8RPXsOfWCVC5CXSr/MynguwkG7O+oEY=";
     };
-    nativeBuildInputs = [ pkgs.makeWrapper ];
+    nativeBuildInputs = [ pkgs.makeWrapper pkgs.crystal pkgs.shards ];
     postInstall = ''
-      for f in config.sh tmux-fingers.sh setup-fingers-mode-bindings.sh; do
-      wrapProgram $target/scripts/$f \
+      shards build --production
+      rm -rf $target/* $target/.*
+      cp -r bin $target/bin
+      echo "$target/bin/${pluginName} load-config" > $target/${rtpFilePath}
+      chmod +x $target/${rtpFilePath}
+
+      wrapProgram $target/${rtpFilePath} \
         --prefix PATH : ${with pkgs; lib.makeBinPath (
           [ gawk ] ++ lib.optionals stdenv.isDarwin [ reattach-to-user-namespace ]
         )}
-      done
     '';
   };