about summary refs log tree commit diff
path: root/pkgs/misc
diff options
context:
space:
mode:
authorJan Tojnar <jtojnar@gmail.com>2019-09-22 16:39:56 +0200
committerJan Tojnar <jtojnar@gmail.com>2019-09-22 16:39:56 +0200
commitf2b9f5baa546dbdef9a1cd1ba236391740b4492f (patch)
treed1061c93f77fbc8a8516362c9e24b3c52aa13ab1 /pkgs/misc
parentf80e55fc2e4904848c7dc2b91f2247c651c30979 (diff)
parent11c2b06dd2cf9ea86920ff9bb3939a3f5eb41a27 (diff)
downloadnixlib-f2b9f5baa546dbdef9a1cd1ba236391740b4492f.tar
nixlib-f2b9f5baa546dbdef9a1cd1ba236391740b4492f.tar.gz
nixlib-f2b9f5baa546dbdef9a1cd1ba236391740b4492f.tar.bz2
nixlib-f2b9f5baa546dbdef9a1cd1ba236391740b4492f.tar.lz
nixlib-f2b9f5baa546dbdef9a1cd1ba236391740b4492f.tar.xz
nixlib-f2b9f5baa546dbdef9a1cd1ba236391740b4492f.tar.zst
nixlib-f2b9f5baa546dbdef9a1cd1ba236391740b4492f.zip
Merge branch 'staging-next' into staging
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/cups/drivers/brlaser/default.nix22
-rw-r--r--pkgs/misc/vim-plugins/generated.nix11
-rw-r--r--pkgs/misc/vim-plugins/overrides.nix4
-rw-r--r--pkgs/misc/vim-plugins/vim-plugin-names1
4 files changed, 35 insertions, 3 deletions
diff --git a/pkgs/misc/cups/drivers/brlaser/default.nix b/pkgs/misc/cups/drivers/brlaser/default.nix
index 948e5ed72ab1..bf0f4ef82799 100644
--- a/pkgs/misc/cups/drivers/brlaser/default.nix
+++ b/pkgs/misc/cups/drivers/brlaser/default.nix
@@ -2,13 +2,13 @@
 
 stdenv.mkDerivation rec {
   pname = "brlaser";
-  version = "4";
+  version = "5";
 
   src = fetchFromGitHub {
     owner = "pdewacht";
     repo = "brlaser";
     rev = "v${version}";
-    sha256 = "1yy4mpf68c82h245srh2sd1yip29w6kx14gxk4hxkv496gf55lw5";
+    sha256 = "133fx49wkg1v8r4kcishd035hlsscv8kc2q4jnln5qmyhpyygjyy";
   };
 
   nativeBuildInputs = [ cmake ];
@@ -25,13 +25,29 @@ stdenv.mkDerivation rec {
        This driver is known to work with these printers:
 
            Brother DCP-1510
+           Brother DCP-1602
            Brother DCP-7030
            Brother DCP-7040
            Brother DCP-7055
            Brother DCP-7055W
+           Brother DCP-7060D
            Brother DCP-7065DN
-           Brother HL-L2300D
+           Brother DCP-7080
+           Brother DCP-L2500D
+           Brother DCP-L2540DW
+           Brother HL-1110 series
+           Brother HL-1200 series
+           Brother HL-L2300D series
+           Brother HL-L2320D series
+           Brother HL-L2340D series
+           Brother HL-L2360D series
+           Brother MFC-1910W
+           Brother MFC-7240
            Brother MFC-7360N
+           Brother MFC-7365DN
+           Brother MFC-7840W
+           Brother MFC-L2710DW
+           Lenovo M7605D
       '';
     homepage = https://github.com/pdewacht/brlaser;
     license = licenses.gpl2;
diff --git a/pkgs/misc/vim-plugins/generated.nix b/pkgs/misc/vim-plugins/generated.nix
index d6537ad820ed..cb0e37782013 100644
--- a/pkgs/misc/vim-plugins/generated.nix
+++ b/pkgs/misc/vim-plugins/generated.nix
@@ -775,6 +775,17 @@ let
     };
   };
 
+  defx-nvim = buildVimPluginFrom2Nix {
+    pname = "defx-nvim";
+    version = "2019-08-19";
+    src = fetchFromGitHub {
+      owner = "Shougo";
+      repo = "defx.nvim";
+      rev = "dbd2dceea914ecaa71d24a1d6036f1981becdca5";
+      sha256 = "1gl18s39v7k1p6z7hchq1k16f6f1i2ccq76as562c0nvn68jdqi8";
+    };
+  };
+
   delimitMate = buildVimPluginFrom2Nix {
     pname = "delimitMate";
     version = "2017-06-19";
diff --git a/pkgs/misc/vim-plugins/overrides.nix b/pkgs/misc/vim-plugins/overrides.nix
index 5fff24e9e5f9..4d127c20e31a 100644
--- a/pkgs/misc/vim-plugins/overrides.nix
+++ b/pkgs/misc/vim-plugins/overrides.nix
@@ -166,6 +166,10 @@ self: super: {
     '';
   });
 
+  defx-nvim = super.defx-nvim.overrideAttrs(old: {
+    dependencies = with super; [ nvim-yarp ];
+  });
+
   deoplete-fish = super.deoplete-fish.overrideAttrs(old: {
     dependencies = with super; [ deoplete-nvim vim-fish ];
   });
diff --git a/pkgs/misc/vim-plugins/vim-plugin-names b/pkgs/misc/vim-plugins/vim-plugin-names
index 9a177c91d294..926c509d12f0 100644
--- a/pkgs/misc/vim-plugins/vim-plugin-names
+++ b/pkgs/misc/vim-plugins/vim-plugin-names
@@ -340,6 +340,7 @@ sebastianmarkow/deoplete-rust
 sheerun/vim-polyglot
 Shougo/context_filetype.vim
 Shougo/denite.nvim
+Shougo/defx.nvim
 Shougo/deol.nvim
 Shougo/deoplete-lsp
 Shougo/deoplete.nvim