about summary refs log tree commit diff
path: root/pkgs/misc
diff options
context:
space:
mode:
authorSilvan Mosberger <infinisil@icloud.com>2019-03-26 22:08:21 +0100
committerSilvan Mosberger <infinisil@icloud.com>2019-03-26 22:36:52 +0100
commitf214efa6f128f36f4ecac5bee3e2227158b36391 (patch)
treebdee1e54d4ad0681d8e635fa81708f703704088a /pkgs/misc
parent607b0a1fa848da49acbbce0f6d953760a5b33304 (diff)
downloadnixlib-f214efa6f128f36f4ecac5bee3e2227158b36391.tar
nixlib-f214efa6f128f36f4ecac5bee3e2227158b36391.tar.gz
nixlib-f214efa6f128f36f4ecac5bee3e2227158b36391.tar.bz2
nixlib-f214efa6f128f36f4ecac5bee3e2227158b36391.tar.lz
nixlib-f214efa6f128f36f4ecac5bee3e2227158b36391.tar.xz
nixlib-f214efa6f128f36f4ecac5bee3e2227158b36391.tar.zst
nixlib-f214efa6f128f36f4ecac5bee3e2227158b36391.zip
vimPlugins.vim-stylish-haskell: Patch path to executable
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/vim-plugins/overrides.nix10
1 files changed, 9 insertions, 1 deletions
diff --git a/pkgs/misc/vim-plugins/overrides.nix b/pkgs/misc/vim-plugins/overrides.nix
index 23914e02c01c..c3865fa1e00f 100644
--- a/pkgs/misc/vim-plugins/overrides.nix
+++ b/pkgs/misc/vim-plugins/overrides.nix
@@ -2,7 +2,7 @@
 , python, cmake, meson, vim, ruby
 , which, fetchgit, fetchurl
 , llvmPackages, rustPlatform
-, xkb-switch, fzf, skim
+, xkb-switch, fzf, skim, stylish-haskell
 , python3, boost, icu, ncurses
 , ycmd, rake
 , gobject-introspection, glib, wrapGAppsHook
@@ -405,4 +405,12 @@ self: super: {
     };
   });
 
+  vim-stylish-haskell = super.vim-stylish-haskell.overrideAttrs (old: {
+    postPatch = old.postPatch or "" + ''
+      substituteInPlace ftplugin/haskell/stylish-haskell.vim --replace \
+        'g:stylish_haskell_command = "stylish-haskell"' \
+        'g:stylish_haskell_command = "${stylish-haskell}/bin/stylish-haskell"'
+    '';
+  });
+
 }