about summary refs log tree commit diff
path: root/pkgs/misc
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2017-09-11 15:38:09 +0100
committerGitHub <noreply@github.com>2017-09-11 15:38:09 +0100
commitee9b549afe4fbbf17d2a312de55cfbeaa4651ab4 (patch)
tree313eabdcd3b97a916bd50d219695b21c5b6e5d0c /pkgs/misc
parente61022ac5553b2d62aa4c82517b2ca0f203533da (diff)
parentf068f3f209a25a64a1932cccd8bfb5753dcf5ec6 (diff)
downloadnixlib-ee9b549afe4fbbf17d2a312de55cfbeaa4651ab4.tar
nixlib-ee9b549afe4fbbf17d2a312de55cfbeaa4651ab4.tar.gz
nixlib-ee9b549afe4fbbf17d2a312de55cfbeaa4651ab4.tar.bz2
nixlib-ee9b549afe4fbbf17d2a312de55cfbeaa4651ab4.tar.lz
nixlib-ee9b549afe4fbbf17d2a312de55cfbeaa4651ab4.tar.xz
nixlib-ee9b549afe4fbbf17d2a312de55cfbeaa4651ab4.tar.zst
nixlib-ee9b549afe4fbbf17d2a312de55cfbeaa4651ab4.zip
Merge pull request #29150 from Lassulus/mupen64-update
mupen64plus: 1.5 -> 2.5
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/emulators/mupen64plus/default.nix36
1 files changed, 14 insertions, 22 deletions
diff --git a/pkgs/misc/emulators/mupen64plus/default.nix b/pkgs/misc/emulators/mupen64plus/default.nix
index 0e3c156c16ae..ea35ee8ac54b 100644
--- a/pkgs/misc/emulators/mupen64plus/default.nix
+++ b/pkgs/misc/emulators/mupen64plus/default.nix
@@ -1,35 +1,27 @@
-{stdenv, fetchurl, which, pkgconfig, SDL, gtk2, mesa, SDL_ttf}:
+{stdenv, lib, fetchurl, boost, dash, freetype, libpng, pkgconfig, SDL, which, zlib }:
+
+stdenv.mkDerivation rec {
+  name = "mupen64plus-${version}";
+  version = "2.5";
 
-stdenv.mkDerivation {
-  name = "mupen64plus-1.5";
   src = fetchurl {
-    url = http://mupen64plus.googlecode.com/files/Mupen64Plus-1-5-src.tar.gz;
-    sha256 = "0gygfgyr2sg4yx77ijk133d1ra0v1yxi4xjxrg6kp3zdjmhdmcjq";
+    url = "https://github.com/mupen64plus/mupen64plus-core/releases/download/${version}/mupen64plus-bundle-src-${version}.tar.gz";
+    sha256 = "0rmsvfn4zfvbhz6gf1xkb7hnwflv6sbklwjz2xk4dlpj4vcbjxcw";
   };
 
-  buildInputs = [ which pkgconfig SDL gtk2 mesa SDL_ttf ];
-
-  hardeningDisable = [ "format" ];
-
-  preConfigure = ''
-    # Some C++ incompatibility fixes
-    sed -i -e 's|char \* extstr = strstr|const char * extstr = strstr|' glide64/Main.cpp
-    sed -i -e 's|char \* extstr = strstr|const char * extstr = strstr|' glide64/Combine.cpp
+  buildInputs = [ boost dash freetype libpng pkgconfig SDL which zlib ];
 
-    # Fix some hardcoded paths
-    sed -i -e "s|/usr/local|$out|g" main/main.c
-
-    # Remove PATH environment variable from install script
-    sed -i -e "s|export PATH=|#export PATH=|" ./install.sh
+  buildPhase = ''
+    dash m64p_build.sh PREFIX="$out" COREDIR="$out/lib/" PLUGINDIR="$out/lib/mupen64plus" SHAREDIR="$out/share/mupen64plus"
+  '';
+  installPhase = ''
+    dash m64p_install.sh DESTDIR="$out" PREFIX=""
   '';
-
-  buildPhase = "make all";
-  installPhase = "PREFIX=$out make install";
 
   meta = {
     description = "A Nintendo 64 Emulator";
     license = stdenv.lib.licenses.gpl2Plus;
-    homepage = http://code.google.com/p/mupen64plus;
+    homepage = http://www.mupen64plus.org/;
     maintainers = [ stdenv.lib.maintainers.sander ];
     platforms = stdenv.lib.platforms.linux;
   };