about summary refs log tree commit diff
path: root/pkgs/misc
diff options
context:
space:
mode:
authorSCOTT-HAMILTON <sgn.hamilton+github@protonmail.com>2020-12-09 23:58:10 +0100
committerGitHub <noreply@github.com>2020-12-09 17:58:10 -0500
commitdc09a890c50e5332750e183275b89dbfca36535a (patch)
tree026e212dd2b343cd2e8e642598dfb3d409a8e632 /pkgs/misc
parentf493e6264372fd420a9d72d75136a4564e9aca48 (diff)
downloadnixlib-dc09a890c50e5332750e183275b89dbfca36535a.tar
nixlib-dc09a890c50e5332750e183275b89dbfca36535a.tar.gz
nixlib-dc09a890c50e5332750e183275b89dbfca36535a.tar.bz2
nixlib-dc09a890c50e5332750e183275b89dbfca36535a.tar.lz
nixlib-dc09a890c50e5332750e183275b89dbfca36535a.tar.xz
nixlib-dc09a890c50e5332750e183275b89dbfca36535a.tar.zst
nixlib-dc09a890c50e5332750e183275b89dbfca36535a.zip
melonDS: 0.8.3 -> 0.9 (and build fix) (#106489)
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/emulators/melonDS/default.nix43
1 files changed, 22 insertions, 21 deletions
diff --git a/pkgs/misc/emulators/melonDS/default.nix b/pkgs/misc/emulators/melonDS/default.nix
index 94fbeba0e075..e5c972e079d4 100644
--- a/pkgs/misc/emulators/melonDS/default.nix
+++ b/pkgs/misc/emulators/melonDS/default.nix
@@ -1,41 +1,42 @@
-{ stdenv, fetchFromGitHub, cmake, pkgconfig, SDL2, gtk3, libpcap, wrapGAppsHook }:
+{ stdenv
+, fetchFromGitHub
+, mkDerivation
+, cmake
+, pkgconfig
+, SDL2
+, qtbase
+, libpcap
+, libslirp
+, wrapGAppsHook
+}:
 
-stdenv.mkDerivation rec {
+mkDerivation rec {
   pname = "melonDS";
-  version = "0.8.3";
-  ## When updating to the release after 0.8.3,
-  ##  - Uncomment:
-  ##      cmakeFlags = [ "-UUNIX_PORTABLE" ];
-  ##  - Remove the postInstall, since cmake should then take care of installing icons, .desktop file, and romlist.bin
-  ##    (see https://github.com/Arisotura/melonDS/pull/546)
+  version = "0.9";
 
   src = fetchFromGitHub {
     owner = "Arisotura";
     repo = pname;
     rev = version;
-    sha256 = "1lqmfwjpkdqfkns1aaxlp4yrg6i0r66mxfr4rrj7b5286k44hqwn";
+    sha256 = "0m45m1ch0az8l3d3grjbqvi5vvydbffxwka9w3k3qiia50m7fnph";
   };
 
   enableParallelBuilding = true;
   nativeBuildInputs = [ cmake pkgconfig wrapGAppsHook ];
-  buildInputs = [ SDL2 gtk3 libpcap ];
+  buildInputs = [
+    SDL2
+    qtbase
+    libpcap
+    libslirp
+  ];
 
-  postInstall = ''
-    install -Dm644 -t $out/share/melonDS/ ../romlist.bin
-    install -Dm644 -t $out/share/applications/ ../flatpak/*.desktop
-
-    for i in ../icon/melon_*.png; do
-      d="''${i##*_}"
-      d="$out/share/icons/hicolor/''${d%.png}/apps"
-      install -D $i "$d/net.kuribo64.melonds.png"
-    done
-  '';
+  cmakeFlags = [ "-UUNIX_PORTABLE" ];
 
   meta = with stdenv.lib; {
     homepage = "http://melonds.kuribo64.net/";
     description = "Work in progress Nintendo DS emulator";
     license = licenses.gpl3Plus;
-    maintainers = with maintainers; [ artemist benley ];
+    maintainers = with maintainers; [ artemist benley shamilton ];
     platforms = platforms.linux;
   };
 }