about summary refs log tree commit diff
path: root/pkgs/misc
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2019-05-07 19:29:06 +0200
committerGitHub <noreply@github.com>2019-05-07 19:29:06 +0200
commita80982b4c9e5dc9a34973638d62b0c748bef4eec (patch)
tree2d2d426102de35f584636864dd5228b509de6a6a /pkgs/misc
parent6ae8aed1c2ec25a523c809bb5b0c3e3e89d0bb5e (diff)
parent0196d8f11cff9790531f7599153a077bb493b9cf (diff)
downloadnixlib-a80982b4c9e5dc9a34973638d62b0c748bef4eec.tar
nixlib-a80982b4c9e5dc9a34973638d62b0c748bef4eec.tar.gz
nixlib-a80982b4c9e5dc9a34973638d62b0c748bef4eec.tar.bz2
nixlib-a80982b4c9e5dc9a34973638d62b0c748bef4eec.tar.lz
nixlib-a80982b4c9e5dc9a34973638d62b0c748bef4eec.tar.xz
nixlib-a80982b4c9e5dc9a34973638d62b0c748bef4eec.tar.zst
nixlib-a80982b4c9e5dc9a34973638d62b0c748bef4eec.zip
Merge staging-next into master
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/jackaudio/darwin-cf.patch49
-rw-r--r--pkgs/misc/jackaudio/default.nix23
2 files changed, 11 insertions, 61 deletions
diff --git a/pkgs/misc/jackaudio/darwin-cf.patch b/pkgs/misc/jackaudio/darwin-cf.patch
deleted file mode 100644
index 0fc0902a0c48..000000000000
--- a/pkgs/misc/jackaudio/darwin-cf.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-diff --git a/common/Jackdmp.cpp b/common/Jackdmp.cpp
-index 7eea281..4b8d75d 100644
---- a/common/Jackdmp.cpp
-+++ b/common/Jackdmp.cpp
-@@ -50,43 +50,11 @@ are "hard-coded" in the source. A much better approach would be to use the contr
- - get available drivers and their possible parameters, then prepare to parse them.
- */
-
--#ifdef __APPLE__
--#include <CoreFoundation/CFNotificationCenter.h>
--#include <CoreFoundation/CoreFoundation.h>
--
--static void notify_server_start(const char* server_name)
--{
--    // Send notification to be used in the JackRouter plugin
--    CFStringRef ref = CFStringCreateWithCString(NULL, server_name, kCFStringEncodingMacRoman);
--    CFNotificationCenterPostNotificationWithOptions(CFNotificationCenterGetDistributedCenter(),
--            CFSTR("com.grame.jackserver.start"),
--            ref,
--            NULL,
--            kCFNotificationDeliverImmediately | kCFNotificationPostToAllSessions);
--    CFRelease(ref);
--}
--
--static void notify_server_stop(const char* server_name)
--{
--    // Send notification to be used in the JackRouter plugin
--    CFStringRef ref1 = CFStringCreateWithCString(NULL, server_name, kCFStringEncodingMacRoman);
--    CFNotificationCenterPostNotificationWithOptions(CFNotificationCenterGetDistributedCenter(),
--            CFSTR("com.grame.jackserver.stop"),
--            ref1,
--            NULL,
--            kCFNotificationDeliverImmediately | kCFNotificationPostToAllSessions);
--    CFRelease(ref1);
--}
--
--#else
--
- static void notify_server_start(const char* server_name)
- {}
- static void notify_server_stop(const char* server_name)
- {}
-
--#endif
--
- static void copyright(FILE* file)
- {
-     fprintf(file, "jackdmp " VERSION "\n"
-
diff --git a/pkgs/misc/jackaudio/default.nix b/pkgs/misc/jackaudio/default.nix
index 556b66befe63..a7b3e5f0fdef 100644
--- a/pkgs/misc/jackaudio/default.nix
+++ b/pkgs/misc/jackaudio/default.nix
@@ -1,8 +1,9 @@
 { stdenv, fetchFromGitHub, pkgconfig, python2Packages, makeWrapper
+, fetchpatch
 , bash, libsamplerate, libsndfile, readline, eigen, celt
-, wafHook
+, wafHook, aften
 # Darwin Dependencies
-, aften, AudioToolbox, CoreAudio, CoreFoundation
+, AudioUnit, CoreAudio, cf-private, libobjc, Accelerate
 
 # Optional Dependencies
 , dbus ? null, libffado ? null, alsaLib ? null
@@ -39,22 +40,20 @@ stdenv.mkDerivation rec {
   nativeBuildInputs = [ pkgconfig python makeWrapper wafHook ];
   buildInputs = [ libsamplerate libsndfile readline eigen celt
     optDbus optPythonDBus optLibffado optAlsaLib optLibopus
-  ] ++ optionals stdenv.isDarwin [ aften AudioToolbox CoreAudio CoreFoundation ];
-
-  # CoreFoundation 10.10 doesn't include CFNotificationCenter.h yet.
-  patches = optionals stdenv.isDarwin [ ./darwin-cf.patch ];
+    aften
+  ] ++ optionals stdenv.isDarwin [
+    AudioUnit CoreAudio Accelerate cf-private libobjc
+  ];
 
   prePatch = ''
     substituteInPlace svnversion_regenerate.sh \
         --replace /bin/bash ${bash}/bin/bash
   '';
 
-  # It looks like one of the frameworks depends on <CoreFoundation/CFAttributedString.h>
-  # since frameworks are impure we also have to use the impure CoreFoundation here.
-  # FIXME: remove when CoreFoundation is updated to 10.11
-  preConfigure = optionalString stdenv.isDarwin ''
-    export NIX_CFLAGS_COMPILE="-F${CoreFoundation}/Library/Frameworks $NIX_CFLAGS_COMPILE"
-  '';
+  patches = [ (fetchpatch {
+    url = "https://github.com/jackaudio/jack2/commit/d851fada460d42508a6f82b19867f63853062583.patch";
+    sha256 = "1iwwxjzvgrj7dz3s8alzlhcgmcarjcbkrgvsmy6kafw21pyyw7hp";
+  }) ];
 
   wafConfigureFlags = [
     "--classic"