about summary refs log tree commit diff
path: root/pkgs/misc
diff options
context:
space:
mode:
authorNikolay Amiantov <ab@fmap.me>2016-06-23 13:55:27 +0300
committerNikolay Amiantov <ab@fmap.me>2016-06-23 14:01:09 +0300
commit9e8592d6b9531347845eff12f35666335646ce29 (patch)
tree5c075fbdf476aac4f101eadc5e84753004c83b80 /pkgs/misc
parent7de7a35d59bceb8f97647015c2f712787f8f50ba (diff)
downloadnixlib-9e8592d6b9531347845eff12f35666335646ce29.tar
nixlib-9e8592d6b9531347845eff12f35666335646ce29.tar.gz
nixlib-9e8592d6b9531347845eff12f35666335646ce29.tar.bz2
nixlib-9e8592d6b9531347845eff12f35666335646ce29.tar.lz
nixlib-9e8592d6b9531347845eff12f35666335646ce29.tar.xz
nixlib-9e8592d6b9531347845eff12f35666335646ce29.tar.zst
nixlib-9e8592d6b9531347845eff12f35666335646ce29.zip
wine: set default features in all-packages
I haven't noticed that we actually _do_ set some flags already
in all-packages, just not all the old ones. Use that way instead.
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/emulators/wine/default.nix34
1 files changed, 17 insertions, 17 deletions
diff --git a/pkgs/misc/emulators/wine/default.nix b/pkgs/misc/emulators/wine/default.nix
index 260c02e4d1b6..deeff3c73437 100644
--- a/pkgs/misc/emulators/wine/default.nix
+++ b/pkgs/misc/emulators/wine/default.nix
@@ -10,26 +10,26 @@
   wineRelease ? "stable",
   wineBuild ? (if system == "x86_64-linux" then "wineWow" else "wine32"),
   libtxc_dxtn_Name ? "libtxc_dxtn_s2tc",
-  pngSupport ? true,
-  jpegSupport ? true,
+  pngSupport ? false,
+  jpegSupport ? false,
   tiffSupport ? false,
-  gettextSupport ? true,
-  fontconfigSupport ? true,
-  alsaSupport ? true,
+  gettextSupport ? false,
+  fontconfigSupport ? false,
+  alsaSupport ? false,
   gtkSupport ? false,
-  openglSupport ? true,
-  tlsSupport ? true,
+  openglSupport ? false,
+  tlsSupport ? false,
   gstreamerSupport ? false,
-  cupsSupport ? true,
-  colorManagementSupport ? true,
-  dbusSupport ? true,
-  mpg123Support ? true,
-  openalSupport ? true,
+  cupsSupport ? false,
+  colorManagementSupport ? false,
+  dbusSupport ? false,
+  mpg123Support ? false,
+  openalSupport ? false,
   openclSupport ? false,
-  cairoSupport ? true,
+  cairoSupport ? false,
   odbcSupport ? false,
   netapiSupport ? false,
-  cursesSupport ? true,
+  cursesSupport ? false,
   vaSupport ? false,
   pcapSupport ? false,
   v4lSupport ? false,
@@ -37,9 +37,9 @@
   gsmSupport ? false,
   gphoto2Support ? false,
   ldapSupport ? false,
-  pulseaudioSupport ? true,
-  xineramaSupport ? true,
-  xmlSupport ? true }:
+  pulseaudioSupport ? false,
+  xineramaSupport ? false,
+  xmlSupport ? false }:
 
 let wine-build = build: release:
       lib.getAttr build (callPackage ./packages.nix {