about summary refs log tree commit diff
path: root/pkgs/misc
diff options
context:
space:
mode:
authorTimo Kaufmann <timokau@zoho.com>2020-03-17 23:04:10 +0100
committerTimo Kaufmann <timokau@zoho.com>2020-03-17 23:04:10 +0100
commit880f5a61251647d7dcb52c04e37062bd23d0202a (patch)
treed105b7066953a3001c1ae61f916a983aff8b9e50 /pkgs/misc
parente6b5bcd70f9c67b3cbbc60158a5ef047b82daaa6 (diff)
downloadnixlib-880f5a61251647d7dcb52c04e37062bd23d0202a.tar
nixlib-880f5a61251647d7dcb52c04e37062bd23d0202a.tar.gz
nixlib-880f5a61251647d7dcb52c04e37062bd23d0202a.tar.bz2
nixlib-880f5a61251647d7dcb52c04e37062bd23d0202a.tar.lz
nixlib-880f5a61251647d7dcb52c04e37062bd23d0202a.tar.xz
nixlib-880f5a61251647d7dcb52c04e37062bd23d0202a.tar.zst
nixlib-880f5a61251647d7dcb52c04e37062bd23d0202a.zip
vimPlugins.vim-pandoc: fix startup
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/vim-plugins/overrides.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/pkgs/misc/vim-plugins/overrides.nix b/pkgs/misc/vim-plugins/overrides.nix
index e4710e27193c..a8bf2f56b2af 100644
--- a/pkgs/misc/vim-plugins/overrides.nix
+++ b/pkgs/misc/vim-plugins/overrides.nix
@@ -112,6 +112,21 @@ self: super: {
     '';
   });
 
+  vim-pandoc = super.vim-pandoc.overrideAttrs(old: {
+    patches = (super.patches or []) ++ [
+      # Fix a failure on startup, which breaks the rplugin manifest generation
+      # https://github.com/vim-pandoc/vim-pandoc/pull/363#issuecomment-599080366
+      (fetchpatch {
+        name = "fix-fdetect.patch";
+        url = "https://github.com/vim-pandoc/vim-pandoc/commit/da4c0b0325c1bfad20f7cfd15abb53943fe22fc4.patch";
+        revert = true;
+        # For some reason that part was already reverted upstream.
+        excludes = ["ftdetect/pandoc.vim"];
+        sha256 = "10nykgsqpxx5hlagk83khjl8p58zx7z3bcryzinv5vv52wlqkq5p";
+      })
+    ];
+  });
+
   clighter8 = super.clighter8.overrideAttrs(old: {
     preFixup = ''
       sed "/^let g:clighter8_libclang_path/s|')$|${llvmPackages.clang.cc.lib}/lib/libclang.so')|" \