about summary refs log tree commit diff
path: root/pkgs/misc
diff options
context:
space:
mode:
authorHoang Xuan Phu <phuhimself@phunehehe.net>2016-09-17 16:40:15 +0800
committerHoang Xuan Phu <phuhimself@phunehehe.net>2016-09-17 16:40:15 +0800
commit4ccbab01a921d9fa17d2e49365a5b31857f1a61f (patch)
treeaaed56a69b6ad98feea557cb57170830d31cc22b /pkgs/misc
parentc5b7d262e5e6f27031e218d439e2305db643860c (diff)
downloadnixlib-4ccbab01a921d9fa17d2e49365a5b31857f1a61f.tar
nixlib-4ccbab01a921d9fa17d2e49365a5b31857f1a61f.tar.gz
nixlib-4ccbab01a921d9fa17d2e49365a5b31857f1a61f.tar.bz2
nixlib-4ccbab01a921d9fa17d2e49365a5b31857f1a61f.tar.lz
nixlib-4ccbab01a921d9fa17d2e49365a5b31857f1a61f.tar.xz
nixlib-4ccbab01a921d9fa17d2e49365a5b31857f1a61f.tar.zst
nixlib-4ccbab01a921d9fa17d2e49365a5b31857f1a61f.zip
vim-plugins: add acp, rainbow and vim-repeat
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/vim-plugins/default.nix33
-rw-r--r--pkgs/misc/vim-plugins/vim-plugin-names3
2 files changed, 36 insertions, 0 deletions
diff --git a/pkgs/misc/vim-plugins/default.nix b/pkgs/misc/vim-plugins/default.nix
index 7121ef689ae8..9a2e46987226 100644
--- a/pkgs/misc/vim-plugins/default.nix
+++ b/pkgs/misc/vim-plugins/default.nix
@@ -497,6 +497,17 @@ rec {
 
   };
 
+  acp = buildVimPluginFrom2Nix { # created by nix#NixDerivation
+    name = "acp-2013-02-05";
+    src = fetchgit {
+      url = "git://github.com/eikenb/acp";
+      rev = "5c627cec37d0d3b1670cb250d84e176e8b0c644e";
+      sha256 = "0h7s4nvxin7m2caka7g1hhlxj1bbiwsvw8s2lqwlh7nq43v23ghg";
+    };
+    dependencies = [];
+
+  };
+
   elm-vim = buildVimPluginFrom2Nix { # created by nix#NixDerivation
     name = "elm-vim-2016-07-25";
     src = fetchgit {
@@ -838,6 +849,17 @@ rec {
 
   };
 
+  rainbow = buildVimPluginFrom2Nix { # created by nix#NixDerivation
+    name = "rainbow-2016-08-08";
+    src = fetchgit {
+      url = "git://github.com/luochen1990/rainbow";
+      rev = "eeb35ccece20f2648b44580c484c6e57eec3c92b";
+      sha256 = "0s1ygjm5czzj1idrw4f13gg60zljznb6bs7fps4i3wl2mbmw5641";
+    };
+    dependencies = [];
+
+  };
+
   vim-xkbswitch = buildVimPluginFrom2Nix { # created by nix#NixDerivation
     name = "vim-xkbswitch-2016-01-31";
     src = fetchgit {
@@ -1146,6 +1168,17 @@ rec {
 
   };
 
+  vim-repeat = buildVimPluginFrom2Nix { # created by nix#NixDerivation
+    name = "vim-repeat-2015-05-09";
+    src = fetchgit {
+      url = "git://github.com/tpope/vim-repeat";
+      rev = "7a6675f092842c8f81e71d5345bd7cdbf3759415";
+      sha256 = "0p8g5y3vyl1765lj1r8jpc06l465f9bagivq6k8ndajbg049brl7";
+    };
+    dependencies = [];
+
+  };
+
   hasksyn = buildVimPluginFrom2Nix { # created by nix#NixDerivation
     name = "hasksyn-2014-09-03";
     src = fetchgit {
diff --git a/pkgs/misc/vim-plugins/vim-plugin-names b/pkgs/misc/vim-plugins/vim-plugin-names
index 6cef8885ce0b..71c65f74a9c5 100644
--- a/pkgs/misc/vim-plugins/vim-plugin-names
+++ b/pkgs/misc/vim-plugins/vim-plugin-names
@@ -33,6 +33,7 @@
 "github:ctrlpvim/ctrlp.vim"
 "github:digitaltoad/vim-jade"
 "github:eagletmt/neco-ghc"
+"github:eikenb/acp"
 "github:elmcast/elm-vim"
 "github:embear/vim-localvimrc"
 "github:enomsg/vim-haskellConcealPlus"
@@ -64,6 +65,7 @@
 "github:lepture/vim-jinja"
 "github:lervag/vimtex"
 "github:lokaltog/vim-easymotion"
+"github:luochen1990/rainbow"
 "github:lyokha/vim-xkbswitch"
 "github:mhinz/vim-startify"
 "github:mkasa/lushtags"
@@ -91,6 +93,7 @@
 "github:thinca/vim-quickrun"
 "github:tomasr/molokai"
 "github:tpope/vim-eunuch"
+"github:tpope/vim-repeat"
 "github:travitch/hasksyn"
 "github:twinside/vim-haskellconceal"
 "github:valloric/youcompleteme"