about summary refs log tree commit diff
path: root/pkgs/misc
diff options
context:
space:
mode:
authorJohn Ericson <Ericson2314@yahoo.com>2017-09-05 18:10:32 -0400
committerGitHub <noreply@github.com>2017-09-05 18:10:32 -0400
commit40e917d35d0c2227de46484213858eb3268aebb7 (patch)
treedb0d8e18a3c228b3848401bc37970a14ce7ef3ce /pkgs/misc
parentfea02e30f1cce6a853c0b4724d503caee811f96f (diff)
parent9626ffbf14981b7ab618ef85a8ef6ee917d13df4 (diff)
downloadnixlib-40e917d35d0c2227de46484213858eb3268aebb7.tar
nixlib-40e917d35d0c2227de46484213858eb3268aebb7.tar.gz
nixlib-40e917d35d0c2227de46484213858eb3268aebb7.tar.bz2
nixlib-40e917d35d0c2227de46484213858eb3268aebb7.tar.lz
nixlib-40e917d35d0c2227de46484213858eb3268aebb7.tar.xz
nixlib-40e917d35d0c2227de46484213858eb3268aebb7.tar.zst
nixlib-40e917d35d0c2227de46484213858eb3268aebb7.zip
Merge pull request #29023 from obsidiansystems/deps-reorg
misc pkgs: Reorganize dependencies ahead of #26805
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/my-env/default.nix10
1 files changed, 3 insertions, 7 deletions
diff --git a/pkgs/misc/my-env/default.nix b/pkgs/misc/my-env/default.nix
index 13102877d7e7..aec79f1c5cf5 100644
--- a/pkgs/misc/my-env/default.nix
+++ b/pkgs/misc/my-env/default.nix
@@ -62,11 +62,7 @@
     , cleanupCmds ? "", shell ? "${pkgs.bashInteractive}/bin/bash --norc"}:
 
 mkDerivation {
-  # The setup.sh script from stdenv will expect the native build inputs in
-  # the nativeBuildInputs environment variable.
-  nativeBuildInputs = [ ] ++ buildInputs;
-  # Trick to bypass the stdenv usual change of propagatedBuildInputs => propagatedNativeBuildInputs
-  propagatedBuildInputs2 = propagatedBuildInputs;
+  inherit buildInputs propagatedBuildInputs;
 
   name = "env-${name}";
   phases = [ "buildPhase" "fixupPhase" ];
@@ -89,8 +85,8 @@ mkDerivation {
         "$setupNew" > "$s"
     cat >> "$out/dev-envs/''${name/env-/}" << EOF
       defaultNativeBuildInputs="$defaultNativeBuildInputs"
-      nativeBuildInputs="$nativeBuildInputs"
-      propagatedBuildInputs="$propagatedBuildInputs2"
+      buildInputs="$buildInputs"
+      propagatedBuildInputs="$propagatedBuildInputs"
       # the setup-new script wants to write some data to a temp file.. so just let it do that and tidy up afterwards
       tmp="\$("${pkgs.coreutils}/bin/mktemp" -d)"
       NIX_BUILD_TOP="\$tmp"