about summary refs log tree commit diff
path: root/pkgs/misc
diff options
context:
space:
mode:
authorTuomas Tynkkynen <tuomas@tuxera.com>2016-07-04 15:17:46 +0300
committerTuomas Tynkkynen <tuomas@tuxera.com>2016-07-04 15:17:46 +0300
commit4085f4de5f5b0798fe27d0622c932254c2573b5a (patch)
tree1fdeab27ee5dd5fca47ce929a101e8078e7788f6 /pkgs/misc
parent79ed40cd698a9f61cfbc0322f70177784edb2df2 (diff)
parent55aecd308eff773c7ee6ce754ed75fcf69bde133 (diff)
downloadnixlib-4085f4de5f5b0798fe27d0622c932254c2573b5a.tar
nixlib-4085f4de5f5b0798fe27d0622c932254c2573b5a.tar.gz
nixlib-4085f4de5f5b0798fe27d0622c932254c2573b5a.tar.bz2
nixlib-4085f4de5f5b0798fe27d0622c932254c2573b5a.tar.lz
nixlib-4085f4de5f5b0798fe27d0622c932254c2573b5a.tar.xz
nixlib-4085f4de5f5b0798fe27d0622c932254c2573b5a.tar.zst
nixlib-4085f4de5f5b0798fe27d0622c932254c2573b5a.zip
Merge branch 'pr-newest-uboot' into master
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/uboot/default.nix24
-rw-r--r--pkgs/misc/uboot/vexpress-Use-config_distro_bootcmd.patch82
2 files changed, 17 insertions, 89 deletions
diff --git a/pkgs/misc/uboot/default.nix b/pkgs/misc/uboot/default.nix
index 605208a757b4..2cf9cbb1ab80 100644
--- a/pkgs/misc/uboot/default.nix
+++ b/pkgs/misc/uboot/default.nix
@@ -10,13 +10,13 @@ let
            stdenv.mkDerivation (rec {
 
     name = "uboot-${defconfig}-${version}";
-    version = "2016.01";
+    version = "2016.05";
 
     nativeBuildInputs = [ bc dtc ];
 
     src = fetchurl {
       url = "ftp://ftp.denx.de/pub/u-boot/u-boot-${version}.tar.bz2";
-      sha256 = "1md5jpq5n9jh08s7sdkjrvg2q7kpzwa7yrpgl9581ncrjfx2yyg5";
+      sha256 = "0wdivib8kbm17qr6r7n7wyzg5vnwpagvwk5m0z80rbssc5sj5l47";
     };
 
     configurePhase = ''
@@ -68,6 +68,12 @@ in rec {
     filesToInstall = ["u-boot-sunxi-with-spl.bin"];
   };
 
+  ubootBeagleboneBlack = buildUBoot rec {
+    defconfig = "am335x_boneblack_defconfig";
+    targetPlatforms = ["armv7l-linux"];
+    filesToInstall = ["MLO" "u-boot.img"];
+  };
+
   ubootJetsonTK1 = buildUBoot rec {
     defconfig = "jetson-tk1_defconfig";
     targetPlatforms = ["armv7l-linux"];
@@ -86,12 +92,16 @@ in rec {
     filesToInstall = ["u-boot.bin"];
   };
 
-  # Intended only for QEMU's vexpress-a9 emulation target!
-  ubootVersatileExpressCA9 = buildUBoot rec {
-    defconfig = "vexpress_ca9x4_defconfig";
+  ubootRaspberryPi2 = buildUBoot rec {
+    defconfig = "rpi_2_defconfig";
+    targetPlatforms = ["armv7l-linux"];
+    filesToInstall = ["u-boot.bin"];
+  };
+
+  ubootRaspberryPi3 = buildUBoot rec {
+    defconfig = "rpi_3_32b_defconfig";
     targetPlatforms = ["armv7l-linux"];
-    filesToInstall = ["u-boot"];
-    patches = [ ./vexpress-Use-config_distro_bootcmd.patch ];
+    filesToInstall = ["u-boot.bin"];
   };
 
   ubootWandboard = buildUBoot rec {
diff --git a/pkgs/misc/uboot/vexpress-Use-config_distro_bootcmd.patch b/pkgs/misc/uboot/vexpress-Use-config_distro_bootcmd.patch
deleted file mode 100644
index 218132c7758e..000000000000
--- a/pkgs/misc/uboot/vexpress-Use-config_distro_bootcmd.patch
+++ /dev/null
@@ -1,82 +0,0 @@
-From 98f62c27fe481dc2d444d70265268d2369d8a998 Mon Sep 17 00:00:00 2001
-From: Tuomas Tynkkynen <tuomas.tynkkynen@iki.fi>
-Date: Mon, 8 Jun 2015 22:29:23 +0300
-Subject: [PATCH] vexpress: Use config_distro_bootcmd
-
-Also had to hack cli_readline.c, as one codepath in
-cli_readline_into_buffer doesn't respect the timeout.
----
- common/cli_readline.c             | 12 +++++++++++-
- configs/vexpress_ca9x4_defconfig  |  2 --
- include/configs/vexpress_common.h |  2 +-
- 3 files changed, 12 insertions(+), 4 deletions(-)
-
-diff --git a/common/cli_readline.c b/common/cli_readline.c
-index c1476e4..5063a0a 100644
---- a/common/cli_readline.c
-+++ b/common/cli_readline.c
-@@ -517,6 +517,7 @@ int cli_readline_into_buffer(const char *const prompt, char *buffer,
- 	int	plen = 0;			/* prompt length	*/
- 	int	col;				/* output column cnt	*/
- 	char	c;
-+	int first = 1;
- 
- 	/* print prompt */
- 	if (prompt) {
-@@ -528,7 +529,16 @@ int cli_readline_into_buffer(const char *const prompt, char *buffer,
- 	for (;;) {
- 		if (bootretry_tstc_timeout())
- 			return -2;	/* timed out */
--		WATCHDOG_RESET();	/* Trigger watchdog, if needed */
-+		if (first && timeout) {
-+			uint64_t etime = endtick(timeout);
-+
-+			while (!tstc()) {	/* while no incoming data */
-+				if (get_ticks() >= etime)
-+					return -2;	/* timed out */
-+				WATCHDOG_RESET();
-+			}
-+			first = 0;
-+		}
- 
- #ifdef CONFIG_SHOW_ACTIVITY
- 		while (!tstc()) {
-diff --git a/configs/vexpress_ca9x4_defconfig b/configs/vexpress_ca9x4_defconfig
-index 2947fc1..9a5123d 100644
---- a/configs/vexpress_ca9x4_defconfig
-+++ b/configs/vexpress_ca9x4_defconfig
-@@ -5,11 +5,9 @@ CONFIG_TARGET_VEXPRESS_CA9X4=y
- # CONFIG_CMD_IMLS is not set
- # CONFIG_CMD_XIMG is not set
- # CONFIG_CMD_EDITENV is not set
--# CONFIG_CMD_ENV_EXISTS is not set
- # CONFIG_CMD_LOADB is not set
- # CONFIG_CMD_LOADS is not set
- # CONFIG_CMD_FPGA is not set
--# CONFIG_CMD_ECHO is not set
- # CONFIG_CMD_ITEST is not set
- # CONFIG_CMD_SETEXPR is not set
- # CONFIG_CMD_NFS is not set
-diff --git a/include/configs/vexpress_common.h b/include/configs/vexpress_common.h
-index 98f6ae9..062532a 100644
---- a/include/configs/vexpress_common.h
-+++ b/include/configs/vexpress_common.h
-@@ -185,7 +185,6 @@
- 					 CONFIG_SYS_INIT_RAM_SIZE - \
- 					 GENERATED_GBL_DATA_SIZE)
- #define CONFIG_SYS_INIT_SP_ADDR		CONFIG_SYS_GBL_DATA_OFFSET
--#define CONFIG_CMD_ECHO
- 
- #include <config_distro_defaults.h>
- 
-@@ -225,6 +224,7 @@
- #define CONFIG_EXTRA_ENV_SETTINGS \
- 		CONFIG_PLATFORM_ENV_SETTINGS \
-                 BOOTENV \
-+		"fdtfile=vexpress-v2p-ca9.dtb\0" \
- 		"console=ttyAMA0,38400n8\0" \
- 		"dram=1024M\0" \
- 		"root=/dev/sda1 rw\0" \
--- 
-2.6.0
-