about summary refs log tree commit diff
path: root/pkgs/misc
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2018-07-13 19:34:19 +0200
committerFrederik Rietdijk <fridh@fridh.nl>2018-07-13 19:34:19 +0200
commit3e31d23d994b94b9883a39037e328c026491b999 (patch)
treeaa5fec3413ae5b31a32ce37423ed677206121883 /pkgs/misc
parent0a7741110ca7ceba76d4d0a7a83dbd823c3c7cf4 (diff)
parent2c07921cff84dfb0b9e0f6c2d10ee2bfee6a85ac (diff)
downloadnixlib-3e31d23d994b94b9883a39037e328c026491b999.tar
nixlib-3e31d23d994b94b9883a39037e328c026491b999.tar.gz
nixlib-3e31d23d994b94b9883a39037e328c026491b999.tar.bz2
nixlib-3e31d23d994b94b9883a39037e328c026491b999.tar.lz
nixlib-3e31d23d994b94b9883a39037e328c026491b999.tar.xz
nixlib-3e31d23d994b94b9883a39037e328c026491b999.tar.zst
nixlib-3e31d23d994b94b9883a39037e328c026491b999.zip
Merge master into staging
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/seafile-shared/default.nix4
-rw-r--r--pkgs/misc/uboot/default.nix29
2 files changed, 8 insertions, 25 deletions
diff --git a/pkgs/misc/seafile-shared/default.nix b/pkgs/misc/seafile-shared/default.nix
index c47b3c322ca5..0425fb430c5b 100644
--- a/pkgs/misc/seafile-shared/default.nix
+++ b/pkgs/misc/seafile-shared/default.nix
@@ -1,14 +1,14 @@
 {stdenv, fetchFromGitHub, which, autoreconfHook, pkgconfig, curl, vala, python, intltool, fuse, ccnet}:
 
 stdenv.mkDerivation rec {
-  version = "6.2.1";
+  version = "6.2.2";
   name = "seafile-shared-${version}";
 
   src = fetchFromGitHub {
     owner = "haiwen";
     repo = "seafile";
     rev = "v${version}";
-    sha256 = "199ivh6fbz4sgbz15mr6m8985yky5n3z6vpcpnh2ldjx4277gq68";
+    sha256 = "05swp7sjp7pzgp8hjjr2prg0wq213l04iyqdfwwasdczdx6j6g59";
   };
 
   nativeBuildInputs = [ pkgconfig which autoreconfHook vala intltool ];
diff --git a/pkgs/misc/uboot/default.nix b/pkgs/misc/uboot/default.nix
index bac766c7b722..2a628e0cdf49 100644
--- a/pkgs/misc/uboot/default.nix
+++ b/pkgs/misc/uboot/default.nix
@@ -1,16 +1,9 @@
-{ stdenv, fetchurl, fetchpatch, bc, dtc, openssl, python2, swig
+{ stdenv, fetchurl, fetchpatch, bc, bison, dtc, flex, openssl, python2, swig
 , armTrustedFirmwareAllwinner
 , hostPlatform, buildPackages
 }:
 
 let
-  # Various changes for 64-bit sunxi boards, (hopefully) destined for 2018.05
-  sunxiPatch = fetchpatch {
-    name = "sunxi.patch";
-    url = "https://github.com/u-boot/u-boot/compare/v2018.05...dezgeg:2018-05-sunxi.patch";
-    sha256 = "1dfv4s1f71iv80vjxgyghv4pcwjv4mjphk75a8hfl3jdbpd66d36";
-  };
-
   buildUBoot = { filesToInstall
             , installDir ? "$out"
             , defconfig
@@ -21,25 +14,17 @@ let
            stdenv.mkDerivation (rec {
 
     name = "uboot-${defconfig}-${version}";
-    version = "2018.05";
+    version = "2018.07";
 
     src = fetchurl {
       url = "ftp://ftp.denx.de/pub/u-boot/u-boot-${version}.tar.bz2";
-      sha256 = "0j60p4iskzb4hamxgykc6gd7xchxfka1zwh8hv08r9rrc4m3r8ad";
+      sha256 = "1m7nw64mxflpc6sqvnz2kb5fxfkb4mrpy8b1wi15dcwipj4dy44z";
     };
 
     patches = [
       (fetchpatch {
-        url = https://github.com/dezgeg/u-boot/commit/rpi-2018-05-patch1.patch;
-        sha256 = "0xvw16mp6mm36987rd5yb8bw0n5b3p1gq35wch2gbj15wx55450p";
-      })
-      (fetchpatch {
-        url = https://github.com/dezgeg/u-boot/commit/rpi-2018-05-patch2.patch;
-        sha256 = "0q1a5l5rfgddncxrjk59qr1f5587dwbvcf6z15bsfl2invs19m2b";
-      })
-      (fetchpatch {
-        url = https://github.com/dezgeg/u-boot/commit/pythonpath-2018-03.patch;
-        sha256 = "1rhhlhrwhv7ic1n5i720jfh2cxwrkssrkvinllyjy3j9k9bpzcqd";
+        url = https://github.com/dezgeg/u-boot/commit/pythonpath-2018-07.patch;
+        sha256 = "096zqrlr8m9lxjma0iv7y6x78qswfs3q1w2irjkbmcvniz1azbs8";
       })
       (fetchpatch {
         url = https://github.com/dezgeg/u-boot/commit/extlinux-path-length-2018-03.patch;
@@ -51,7 +36,7 @@ let
       patchShebangs tools
     '';
 
-    nativeBuildInputs = [ bc dtc openssl python2 swig ];
+    nativeBuildInputs = [ bc bison dtc flex openssl python2 swig ];
     depsBuildBuild = [ buildPackages.stdenv.cc ];
 
     hardeningDisable = [ "all" ];
@@ -180,7 +165,6 @@ in rec {
   };
 
   ubootPine64 = buildUBoot rec {
-    extraPatches = [sunxiPatch];
     defconfig = "pine64_plus_defconfig";
     extraMeta.platforms = ["aarch64-linux"];
     BL31 = "${armTrustedFirmwareAllwinner}/bl31.bin";
@@ -236,7 +220,6 @@ in rec {
   };
 
   ubootSopine = buildUBoot rec {
-    extraPatches = [sunxiPatch];
     defconfig = "sopine_baseboard_defconfig";
     extraMeta.platforms = ["aarch64-linux"];
     BL31 = "${armTrustedFirmwareAllwinner}/bl31.bin";