about summary refs log tree commit diff
path: root/pkgs/misc
diff options
context:
space:
mode:
authorRaito Bezarius <masterancpp@gmail.com>2023-09-16 04:03:52 +0200
committerRaito Bezarius <masterancpp@gmail.com>2023-09-16 04:04:06 +0200
commit32104c2fec1299dcd2e1253dfcfc1894b1096469 (patch)
tree6b16f0c909f8e0a59f3ebde95abd4e8fc698b80d /pkgs/misc
parent50c6120a3e14a15b507f07237d4748c6ebacbba5 (diff)
downloadnixlib-32104c2fec1299dcd2e1253dfcfc1894b1096469.tar
nixlib-32104c2fec1299dcd2e1253dfcfc1894b1096469.tar.gz
nixlib-32104c2fec1299dcd2e1253dfcfc1894b1096469.tar.bz2
nixlib-32104c2fec1299dcd2e1253dfcfc1894b1096469.tar.lz
nixlib-32104c2fec1299dcd2e1253dfcfc1894b1096469.tar.xz
nixlib-32104c2fec1299dcd2e1253dfcfc1894b1096469.tar.zst
nixlib-32104c2fec1299dcd2e1253dfcfc1894b1096469.zip
ubootTools: add `efivar.py` as a tool
`efivar.py` enable a user to manipulate the EFI variable store on disk
that U-Boot uses.

This is useful to prepare a SecureBoot set of variables that can be seeded
inside of U-Boot directly if you do not have a proper OP-TEE on your platform.
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/uboot/default.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/pkgs/misc/uboot/default.nix b/pkgs/misc/uboot/default.nix
index 6c002851db6f..d4be6a73b9fc 100644
--- a/pkgs/misc/uboot/default.nix
+++ b/pkgs/misc/uboot/default.nix
@@ -15,6 +15,7 @@
 , openssl
 , swig
 , which
+, python3
 , armTrustedFirmwareAllwinner
 , armTrustedFirmwareAllwinnerH6
 , armTrustedFirmwareAllwinnerH616
@@ -152,6 +153,10 @@ in {
       "tools/mkenvimage"
       "tools/mkimage"
     ];
+
+    pythonScriptsToInstall = {
+      "tools/efivar.py" = (python3.withPackages (ps: [ ps.pyopenssl ]));
+    };
   };
 
   ubootA20OlinuxinoLime = buildUBoot {