about summary refs log tree commit diff
path: root/pkgs/misc
diff options
context:
space:
mode:
authorAnders Sildnes <andsild@posteo.net>2018-01-25 15:03:24 +0100
committerAnders Sildnes <andsild@posteo.net>2018-02-01 16:22:21 +0100
commit1af14e0f1e0d7287b83066fe492e0b4e9eb20adc (patch)
tree20b9aa8de596e80dbff5fec379210dd25547cefe /pkgs/misc
parent7aa5e6bfafe9d6436a019c692e3638bc918e6ebe (diff)
downloadnixlib-1af14e0f1e0d7287b83066fe492e0b4e9eb20adc.tar
nixlib-1af14e0f1e0d7287b83066fe492e0b4e9eb20adc.tar.gz
nixlib-1af14e0f1e0d7287b83066fe492e0b4e9eb20adc.tar.bz2
nixlib-1af14e0f1e0d7287b83066fe492e0b4e9eb20adc.tar.lz
nixlib-1af14e0f1e0d7287b83066fe492e0b4e9eb20adc.tar.xz
nixlib-1af14e0f1e0d7287b83066fe492e0b4e9eb20adc.tar.zst
nixlib-1af14e0f1e0d7287b83066fe492e0b4e9eb20adc.zip
vim-plugins/open-browser: init
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/vim-plugins/default.nix12
-rw-r--r--pkgs/misc/vim-plugins/vim-plugin-names1
2 files changed, 13 insertions, 0 deletions
diff --git a/pkgs/misc/vim-plugins/default.nix b/pkgs/misc/vim-plugins/default.nix
index 1fcc187d75e7..9ede44ab8797 100644
--- a/pkgs/misc/vim-plugins/default.nix
+++ b/pkgs/misc/vim-plugins/default.nix
@@ -112,6 +112,7 @@ rec {
   neomru = neomru-vim;
   echodoc = echodoc-vim;
   context-filetype = context_filetype-vim;
+  open-browser = open-browser-vim;
   concealedyank = concealedyank-vim;
   cute-python = vim-cute-python-git;
   vim-grepper = vim-grepper-git;
@@ -2155,6 +2156,17 @@ rec {
 
   };
 
+  open-browser-vim = buildVimPluginFrom2Nix { # created by nix#NixDerivation
+    name = "open-browser-vim-2017-12-15";
+    src = fetchgit {
+      url = "https://github.com/tyru/open-browser.vim";
+      rev = "ee8decb2b26020320128eecd7a96383d995c8804";
+      sha256 = "1a9j13h174lkp1gqd80idwdb8d74gdkyfgvb2l153jcqyvwpzcl2";
+    };
+    dependencies = [];
+
+  };
+
   youcompleteme = buildVimPluginFrom2Nix { # created by nix#NixDerivation
     name = "youcompleteme-2017-12-03";
     src = fetchgit {
diff --git a/pkgs/misc/vim-plugins/vim-plugin-names b/pkgs/misc/vim-plugins/vim-plugin-names
index ed316d609f15..73db19560693 100644
--- a/pkgs/misc/vim-plugins/vim-plugin-names
+++ b/pkgs/misc/vim-plugins/vim-plugin-names
@@ -245,6 +245,7 @@
 "github:shougo/echodoc.vim"
 "github:shougo/context_filetype.vim"
 "github:elzr/vim-json"
+"github:tyru/open-browser.vim"
 "github:kana/vim-operator-user"
 "github:kana/vim-niceblock"
 "github:kana/vim-operator-replace"