about summary refs log tree commit diff
path: root/pkgs/misc
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2019-05-02 08:43:14 +0200
committerFrederik Rietdijk <fridh@fridh.nl>2019-05-02 08:43:14 +0200
commit155c9d8e18cb41306e229c2a069539350aae2626 (patch)
tree29d836d3110dcba554c166713237c834ee208cf3 /pkgs/misc
parent7909ed1dee47fa154c63937bbf2c0351fe9bbdc8 (diff)
parent1cc005168be91b67e03ae9c1bd45dad3eed34f74 (diff)
downloadnixlib-155c9d8e18cb41306e229c2a069539350aae2626.tar
nixlib-155c9d8e18cb41306e229c2a069539350aae2626.tar.gz
nixlib-155c9d8e18cb41306e229c2a069539350aae2626.tar.bz2
nixlib-155c9d8e18cb41306e229c2a069539350aae2626.tar.lz
nixlib-155c9d8e18cb41306e229c2a069539350aae2626.tar.xz
nixlib-155c9d8e18cb41306e229c2a069539350aae2626.tar.zst
nixlib-155c9d8e18cb41306e229c2a069539350aae2626.zip
Merge master into staging-next
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/emulators/caprice32/default.nix22
-rw-r--r--pkgs/misc/emulators/wine/sources.nix10
-rw-r--r--pkgs/misc/themes/tetra/default.nix36
-rw-r--r--pkgs/misc/uboot/rock64-fdt-dtc-compatibility.patch105
-rw-r--r--pkgs/misc/uboot/rock64.nix2
-rw-r--r--pkgs/misc/uboot/rockpro64.nix2
6 files changed, 125 insertions, 52 deletions
diff --git a/pkgs/misc/emulators/caprice32/default.nix b/pkgs/misc/emulators/caprice32/default.nix
index 42b8e5229e99..a8068e9b47b6 100644
--- a/pkgs/misc/emulators/caprice32/default.nix
+++ b/pkgs/misc/emulators/caprice32/default.nix
@@ -2,18 +2,22 @@
 
 stdenv.mkDerivation rec {
 
-  repo = "caprice32";
-  version = "unstable-2018-03-05";
-  rev = "317fe638111e245d67e301f6f295094d3c859a70";
-  name = "${repo}-${version}";
+  pname = "caprice32";
+  version = "4.5.0";
 
   src = fetchFromGitHub {
-    inherit rev repo;
+    repo = "caprice32";
+    rev = "v${version}";
     owner = "ColinPitrat";
-    sha256 = "1bywpmkizixcnr057k8zq9nlw0zhcmwkiriln0krgdcm7d3h9b86";
+    sha256 = "056vrf5yq1574g93ix8hnjqqbdqza3qcjv0f8rvpsslqcbizma9y";
   };
 
   postPatch = "substituteInPlace cap32.cfg --replace /usr/local $out";
+  nativeBuildInputs = [ pkgconfig ];
+  buildInputs = [ libpng SDL freetype zlib ];
+
+  #fix GIT_HASH avoid depend on git 
+  makeFlags = [ "GIT_HASH=${src.rev}" "DESTDIR=$(out)" "prefix=/"];
 
   meta = with stdenv.lib; {
     description = "A complete emulation of CPC464, CPC664 and CPC6128";
@@ -21,9 +25,5 @@ stdenv.mkDerivation rec {
     license = licenses.gpl2;
     maintainers = [ maintainers.genesis ];
     platforms = platforms.linux;
-  };
-
-  nativeBuildInputs = [ pkgconfig ];
-  buildInputs = [ libpng SDL freetype zlib ];
-  makeFlags = [ "GIT_HASH=${src.rev}" "DESTDIR=$(out)" "prefix=/"];
+  };  
 }
diff --git a/pkgs/misc/emulators/wine/sources.nix b/pkgs/misc/emulators/wine/sources.nix
index 70fadf7683f1..ef22bd9a3ac7 100644
--- a/pkgs/misc/emulators/wine/sources.nix
+++ b/pkgs/misc/emulators/wine/sources.nix
@@ -31,24 +31,24 @@ in rec {
 
     ## see http://wiki.winehq.org/Mono
     mono = fetchurl rec {
-      version = "4.8.2";
+      version = "4.8.3";
       url = "http://dl.winehq.org/wine/wine-mono/${version}/wine-mono-${version}.msi";
-      sha256 = "1hvwhqdb11j9yzhhw86fjhj9bawg76zrh0wnx658pn5xghhk2jhy";
+      sha256 = "0xhavcjwwr21am3bxp2cxlvykwasw8y4g8p470j5fg7skc0izynn";
     };
   };
 
   unstable = fetchurl rec {
     # NOTE: Don't forget to change the SHA256 for staging as well.
-    version = "4.6";
+    version = "4.7";
     url = "https://dl.winehq.org/wine/source/4.x/wine-${version}.tar.xz";
-    sha256 = "1nk2nlkdklwpd0kbq8hx59gl05b5wglcla0v3892by6k4kwh341j";
+    sha256 = "1c5swx6jj0hz9w2jgyl30pdjcq9n62qp1rmqyq1d4q2a6n291jiv";
     inherit (stable) mono gecko32 gecko64;
   };
 
   staging = fetchFromGitHub rec {
     # https://github.com/wine-staging/wine-staging/releases
     inherit (unstable) version;
-    sha256 = "0mripibsi1p8h2j9ngqszkcjppdxji027ss4shqwb0nypaydd9w2";
+    sha256 = "1sgyq57dyzchwnvkgx96bcx5rv821s0vidzdyz7x5711j7xmiv70";
     owner = "wine-staging";
     repo = "wine-staging";
     rev = "v${version}";
diff --git a/pkgs/misc/themes/tetra/default.nix b/pkgs/misc/themes/tetra/default.nix
deleted file mode 100644
index 3f36ea8f01b9..000000000000
--- a/pkgs/misc/themes/tetra/default.nix
+++ /dev/null
@@ -1,36 +0,0 @@
-{ stdenv, fetchFromGitHub, gtk3, sassc }:
-
-stdenv.mkDerivation rec {
-  name = "tetra-gtk-theme-${version}";
-  version = "201903";
-
-  src = fetchFromGitHub {
-    owner  = "hrdwrrsk";
-    repo   = "tetra-gtk-theme";
-    rev    = version;
-    sha256 = "0ycxvz16gg8rjlg71dzbfnqlh0y62v35j8dvgs8rckfb48xm0xvs";
-  };
-
-  preBuild = ''
-    # Shut up inkscape's warnings
-    export HOME="$NIX_BUILD_ROOT"
-  '';
-
-  nativeBuildInputs = [ sassc ];
-  buildInputs = [ gtk3 ];
-
-  postPatch = "patchShebangs .";
-
-  installPhase = ''
-    mkdir -p $out/share/themes
-    ./install.sh -d $out/share/themes
-  '';
-
-  meta = with stdenv.lib; {
-    description = "Adwaita-based gtk+ theme with design influence from elementary OS and Vertex gtk+ theme";
-    homepage    = https://github.com/hrdwrrsk/tetra-gtk-theme;
-    license     = licenses.gpl3;
-    maintainers = with maintainers; [ dtzWill ];
-    platforms   = platforms.linux;
-  };
-}
diff --git a/pkgs/misc/uboot/rock64-fdt-dtc-compatibility.patch b/pkgs/misc/uboot/rock64-fdt-dtc-compatibility.patch
new file mode 100644
index 000000000000..92725cac5b45
--- /dev/null
+++ b/pkgs/misc/uboot/rock64-fdt-dtc-compatibility.patch
@@ -0,0 +1,105 @@
+From fbee2adffd39b03e10262b09779faef94c4d5a9d Mon Sep 17 00:00:00 2001
+From: Ben Wolsieffer <benwolsieffer@gmail.com>
+Date: Thu, 18 Apr 2019 15:50:24 -0400
+Subject: [PATCH] fdt: make compatible with dtc >=1.4.6
+
+Signed-off-by: Ben Wolsieffer <benwolsieffer@gmail.com>
+---
+ include/libfdt_env.h         | 6 +++---
+ lib/libfdt/fdt.h             | 6 +++---
+ lib/libfdt/libfdt.h          | 6 +++---
+ lib/libfdt/libfdt_internal.h | 6 +++---
+ tools/dtoc/fdt.py            | 2 +-
+ 5 files changed, 13 insertions(+), 13 deletions(-)
+
+diff --git a/include/libfdt_env.h b/include/libfdt_env.h
+index 6c6845f76c..1fbcd0ef83 100644
+--- a/include/libfdt_env.h
++++ b/include/libfdt_env.h
+@@ -6,8 +6,8 @@
+  * SPDX-License-Identifier:	LGPL-2.1+
+  */
+ 
+-#ifndef _LIBFDT_ENV_H
+-#define _LIBFDT_ENV_H
++#ifndef LIBFDT_ENV_H
++#define LIBFDT_ENV_H
+ 
+ #include "compiler.h"
+ #include "linux/types.h"
+@@ -32,4 +32,4 @@ typedef __be64 fdt64_t;
+ /* adding a ramdisk needs 0x44 bytes in version 2008.10 */
+ #define FDT_RAMDISK_OVERHEAD	0x80
+ 
+-#endif /* _LIBFDT_ENV_H */
++#endif /* LIBFDT_ENV_H */
+diff --git a/lib/libfdt/fdt.h b/lib/libfdt/fdt.h
+index 3134d78332..38cc182739 100644
+--- a/lib/libfdt/fdt.h
++++ b/lib/libfdt/fdt.h
+@@ -1,5 +1,5 @@
+-#ifndef _FDT_H
+-#define _FDT_H
++#ifndef FDT_H
++#define FDT_H
+ /*
+  * libfdt - Flat Device Tree manipulation
+  * Copyright (C) 2006 David Gibson, IBM Corporation.
+@@ -64,4 +64,4 @@ struct fdt_property {
+ #define FDT_V16_SIZE	FDT_V3_SIZE
+ #define FDT_V17_SIZE	(FDT_V16_SIZE + sizeof(fdt32_t))
+ 
+-#endif /* _FDT_H */
++#endif /* FDT_H */
+diff --git a/lib/libfdt/libfdt.h b/lib/libfdt/libfdt.h
+index cb533f4275..9345a59f05 100644
+--- a/lib/libfdt/libfdt.h
++++ b/lib/libfdt/libfdt.h
+@@ -1,5 +1,5 @@
+-#ifndef _LIBFDT_H
+-#define _LIBFDT_H
++#ifndef LIBFDT_H
++#define LIBFDT_H
+ /*
+  * libfdt - Flat Device Tree manipulation
+  * Copyright (C) 2006 David Gibson, IBM Corporation.
+@@ -2189,4 +2189,4 @@ int fdt_device_is_available(const void *blob, int node);
+ int fdt_node_offset_by_phandle_node(const void *fdt, int node, uint32_t phandle);
+ #endif /* SWIG */
+ 
+-#endif /* _LIBFDT_H */
++#endif /* LIBFDT_H */
+diff --git a/lib/libfdt/libfdt_internal.h b/lib/libfdt/libfdt_internal.h
+index 9a79fe85dd..8fdda7ee79 100644
+--- a/lib/libfdt/libfdt_internal.h
++++ b/lib/libfdt/libfdt_internal.h
+@@ -1,5 +1,5 @@
+-#ifndef _LIBFDT_INTERNAL_H
+-#define _LIBFDT_INTERNAL_H
++#ifndef LIBFDT_INTERNAL_H
++#define LIBFDT_INTERNAL_H
+ /*
+  * libfdt - Flat Device Tree manipulation
+  * Copyright (C) 2006 David Gibson, IBM Corporation.
+@@ -47,4 +47,4 @@ static inline struct fdt_reserve_entry *_fdt_mem_rsv_w(void *fdt, int n)
+ 
+ #define FDT_SW_MAGIC		(~FDT_MAGIC)
+ 
+-#endif /* _LIBFDT_INTERNAL_H */
++#endif /* LIBFDT_INTERNAL_H */
+diff --git a/tools/dtoc/fdt.py b/tools/dtoc/fdt.py
+index dbc338653b..ac2191fb37 100644
+--- a/tools/dtoc/fdt.py
++++ b/tools/dtoc/fdt.py
+@@ -360,7 +360,7 @@ class Fdt:
+         poffset = libfdt.fdt_first_property_offset(self._fdt, node._offset)
+         while poffset >= 0:
+             p = self._fdt_obj.get_property_by_offset(poffset)
+-            prop = Prop(node, poffset, p.name, p.value)
++            prop = Prop(node, poffset, p.name, p)
+             props_dict[prop.name] = prop
+ 
+             poffset = libfdt.fdt_next_property_offset(self._fdt, poffset)
+-- 
+2.21.0
+
diff --git a/pkgs/misc/uboot/rock64.nix b/pkgs/misc/uboot/rock64.nix
index af8d044387a4..614d1ec1f8fb 100644
--- a/pkgs/misc/uboot/rock64.nix
+++ b/pkgs/misc/uboot/rock64.nix
@@ -15,6 +15,8 @@ in buildUBoot rec {
     sha256 = "0gclcd034qfhfbabrdqmky08i0hlwmn63n0zg6mndplms5qpcx75";
   };
 
+  patches = [ ./rock64-fdt-dtc-compatibility.patch ];
+
   extraMakeFlags = [ "BL31=${armTrustedFirmwareRK3328}/bl31.elf" "u-boot.itb" "all" ];
 
   # Close to being blob free, but the U-Boot TPL causes the kernel to hang after a few minutes
diff --git a/pkgs/misc/uboot/rockpro64.nix b/pkgs/misc/uboot/rockpro64.nix
index d8802e6d5f55..be5f7afa342c 100644
--- a/pkgs/misc/uboot/rockpro64.nix
+++ b/pkgs/misc/uboot/rockpro64.nix
@@ -15,6 +15,8 @@ in buildUBoot rec {
     sha256 = "0gclcd034qfhfbabrdqmky08i0hlwmn63n0zg6mndplms5qpcx75";
   };
 
+  patches = [ ./rock64-fdt-dtc-compatibility.patch ];
+
   # Upstream ATF hangs in SPL
   extraMakeFlags = [ "BL31=${rkbin}/rk33/rk3399_bl31_v1.17.elf" "u-boot.itb" "all" ];