about summary refs log tree commit diff
path: root/pkgs/misc
diff options
context:
space:
mode:
authorBernardo Meurer <bernardo@meurer.org>2021-02-06 01:51:16 +0000
committerGitHub <noreply@github.com>2021-02-06 01:51:16 +0000
commit1545cce64d793db2ada6ba4f1ceeb1efdb157312 (patch)
tree30592c8df9d16831ac158e1dfcc1d785949cd24f /pkgs/misc
parentef6c06cc2865347597ac2e892c93ff34268553e3 (diff)
parent0ec2ea8c17edc8d218dd9f3cf4bb3d9327026825 (diff)
downloadnixlib-1545cce64d793db2ada6ba4f1ceeb1efdb157312.tar
nixlib-1545cce64d793db2ada6ba4f1ceeb1efdb157312.tar.gz
nixlib-1545cce64d793db2ada6ba4f1ceeb1efdb157312.tar.bz2
nixlib-1545cce64d793db2ada6ba4f1ceeb1efdb157312.tar.lz
nixlib-1545cce64d793db2ada6ba4f1ceeb1efdb157312.tar.xz
nixlib-1545cce64d793db2ada6ba4f1ceeb1efdb157312.tar.zst
nixlib-1545cce64d793db2ada6ba4f1ceeb1efdb157312.zip
Merge pull request #112034 from SFrijters/wine6
wine{Unstable,Staging}: 6.0-rc4 -> 6.1 / wineStable: 5.0.3 -> 6.0
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/emulators/wine/cert-path-stable.patch24
-rw-r--r--pkgs/misc/emulators/wine/sources.nix16
2 files changed, 8 insertions, 32 deletions
diff --git a/pkgs/misc/emulators/wine/cert-path-stable.patch b/pkgs/misc/emulators/wine/cert-path-stable.patch
deleted file mode 100644
index da01a4778102..000000000000
--- a/pkgs/misc/emulators/wine/cert-path-stable.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff --git a/dlls/crypt32/rootstore.c b/dlls/crypt32/rootstore.c
-index f795181..fb4926a 100644
---- a/dlls/crypt32/rootstore.c
-+++ b/dlls/crypt32/rootstore.c
-@@ -18,6 +18,7 @@
- #include "config.h"
- #include <stdarg.h>
- #include <stdio.h>
-+#include <stdlib.h> /* getenv */
- #include <sys/types.h>
- #ifdef HAVE_SYS_STAT_H
- #include <sys/stat.h>
-@@ -916,6 +917,11 @@ static void read_trusted_roots_from_known_locations(HCERTSTORE store)
- 
-         for (i = 0; !ret && i < ARRAY_SIZE(CRYPT_knownLocations); i++)
-             ret = import_certs_from_path(CRYPT_knownLocations[i], from, TRUE);
-+
-+        char *nix_cert_file = getenv("NIX_SSL_CERT_FILE");
-+        if (nix_cert_file != NULL)
-+            ret = import_certs_from_path(nix_cert_file, from, TRUE);
-+
-         check_and_store_certs(from, store);
-     }
-     CertCloseStore(from, 0);
diff --git a/pkgs/misc/emulators/wine/sources.nix b/pkgs/misc/emulators/wine/sources.nix
index 3a5abe18d754..15e2f80aa4ea 100644
--- a/pkgs/misc/emulators/wine/sources.nix
+++ b/pkgs/misc/emulators/wine/sources.nix
@@ -13,9 +13,9 @@ let fetchurl = args@{url, sha256, ...}:
 in rec {
 
   stable = fetchurl rec {
-    version = "5.0.3";
-    url = "https://dl.winehq.org/wine/source/5.0/wine-${version}.tar.xz";
-    sha256 = "sha256-nBo1Ni/VE9/1yEW/dtpj6hBaeUrHFEqlA/cTYa820i8=";
+    version = "6.0";
+    url = "https://dl.winehq.org/wine/source/6.0/wine-${version}.tar.xz";
+    sha256 = "sha256-tJMGXy+D7kKcYuLsWGmKPPY+94ci4bIHZYIxUuhYLFY=";
 
     ## see http://wiki.winehq.org/Gecko
     gecko32 = fetchurl rec {
@@ -38,15 +38,15 @@ in rec {
 
     patches = [
       # Also look for root certificates at $NIX_SSL_CERT_FILE
-      ./cert-path-stable.patch
+      ./cert-path.patch
     ];
   };
 
   unstable = fetchurl rec {
     # NOTE: Don't forget to change the SHA256 for staging as well.
-    version = "6.0-rc4";
-    url = "https://dl.winehq.org/wine/source/6.0/wine-${version}.tar.xz";
-    sha256 = "sha256-ndeBORgnfYmtPbvZEesaetocknePF8cnyjqfulkcfsU=";
+    version = "6.1";
+    url = "https://dl.winehq.org/wine/source/6.x/wine-${version}.tar.xz";
+    sha256 = "sha256-qSwkMIxIuFG13CKh01aWpXMRxEezHsn6VD7FsKpzoUk=";
     inherit (stable) mono gecko32 gecko64;
 
     patches = [
@@ -58,7 +58,7 @@ in rec {
   staging = fetchFromGitHub rec {
     # https://github.com/wine-staging/wine-staging/releases
     inherit (unstable) version;
-    sha256 = "sha256-GdFiCGnGSDOxGERlfsPMJdSrQTvnx8gf4z4joqIKT7c=";
+    sha256 = "sha256-uu6wvWT54Zvp86KfUcKepGxjQ6JHRQ7Yuu4yeROdHeo=";
     owner = "wine-staging";
     repo = "wine-staging";
     rev = "v${version}";