about summary refs log tree commit diff
path: root/pkgs/misc
diff options
context:
space:
mode:
authorSefa Eyeoglu <contact@scrumplex.net>2023-06-24 13:49:56 +0200
committerSefa Eyeoglu <contact@scrumplex.net>2023-06-24 14:28:03 +0200
commit1410783ff5df4169b2a1fe468905e6c9488c688a (patch)
tree59dc6e0e0cb459351a81aa7b335900c1c34bd862 /pkgs/misc
parentde1624865fb4d14df27ffd6029891136c7a43f8d (diff)
downloadnixlib-1410783ff5df4169b2a1fe468905e6c9488c688a.tar
nixlib-1410783ff5df4169b2a1fe468905e6c9488c688a.tar.gz
nixlib-1410783ff5df4169b2a1fe468905e6c9488c688a.tar.bz2
nixlib-1410783ff5df4169b2a1fe468905e6c9488c688a.tar.lz
nixlib-1410783ff5df4169b2a1fe468905e6c9488c688a.tar.xz
nixlib-1410783ff5df4169b2a1fe468905e6c9488c688a.tar.zst
nixlib-1410783ff5df4169b2a1fe468905e6c9488c688a.zip
vencord: set standalone build mode
This tells Vencord that it is not installed using its Git installation
method. Currently this doesn't do anything, as the only consumer of this
value is the updater code, that has been effectively disabled using a
patch.

Signed-off-by: Sefa Eyeoglu <contact@scrumplex.net>
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/vencord/default.nix12
1 files changed, 7 insertions, 5 deletions
diff --git a/pkgs/misc/vencord/default.nix b/pkgs/misc/vencord/default.nix
index f06b9af56936..38dbc1fa8f81 100644
--- a/pkgs/misc/vencord/default.nix
+++ b/pkgs/misc/vencord/default.nix
@@ -36,6 +36,7 @@ buildNpmPackage rec {
   npmDepsHash = "sha256-m+hczXog03Gz81CP/blkRJPaTrEhmLQFvVtOfWKYQL4=";
   npmFlags = [ "--legacy-peer-deps" ];
   npmBuildScript = if buildWebExtension then "buildWeb" else "build";
+  npmBuildFlags = [ "--" "--standalone" ];
 
   prePatch = ''
     cp ${./package-lock.json} ./package-lock.json
@@ -49,11 +50,12 @@ buildNpmPackage rec {
     ./disable-updater-ui.patch
   ];
 
-  installPhase = if buildWebExtension then ''
-    cp -r dist/chromium-unpacked/ $out
-  '' else ''
-    cp -r dist/ $out
-  '';
+  installPhase =
+    if buildWebExtension then ''
+      cp -r dist/chromium-unpacked/ $out
+    '' else ''
+      cp -r dist/ $out
+    '';
 
   meta = with lib; {
     description = "Vencord web extension";