about summary refs log tree commit diff
path: root/pkgs/misc
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2019-07-26 14:45:31 +0200
committerFrederik Rietdijk <fridh@fridh.nl>2019-07-26 14:45:31 +0200
commit0f6bda38fe1148d191cf619e69cb47f17cc184cf (patch)
treedc4c8d532343cbcca9d4f22e31021dd8436f8c59 /pkgs/misc
parent883a1dffcfe4734a3b13a034869e94edafc90322 (diff)
parentc9793b81b8f72dd291e0ba14724bbbf96c2a5309 (diff)
downloadnixlib-0f6bda38fe1148d191cf619e69cb47f17cc184cf.tar
nixlib-0f6bda38fe1148d191cf619e69cb47f17cc184cf.tar.gz
nixlib-0f6bda38fe1148d191cf619e69cb47f17cc184cf.tar.bz2
nixlib-0f6bda38fe1148d191cf619e69cb47f17cc184cf.tar.lz
nixlib-0f6bda38fe1148d191cf619e69cb47f17cc184cf.tar.xz
nixlib-0f6bda38fe1148d191cf619e69cb47f17cc184cf.tar.zst
nixlib-0f6bda38fe1148d191cf619e69cb47f17cc184cf.zip
Merge staging-next into staging
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/emulators/wine/base.nix4
-rw-r--r--pkgs/misc/tmux-plugins/default.nix20
2 files changed, 23 insertions, 1 deletions
diff --git a/pkgs/misc/emulators/wine/base.nix b/pkgs/misc/emulators/wine/base.nix
index 8edf7ad39597..01d096599155 100644
--- a/pkgs/misc/emulators/wine/base.nix
+++ b/pkgs/misc/emulators/wine/base.nix
@@ -46,7 +46,9 @@ stdenv.mkDerivation ((lib.optionalAttrs (buildScript != null) {
   ++ lib.optional udevSupport            pkgs.udev
   ++ lib.optional vulkanSupport          pkgs.vulkan-loader
   ++ lib.optional sdlSupport             pkgs.SDL2
-  ++ lib.optionals gstreamerSupport      (with pkgs.gst_all_1; [ gstreamer gst-plugins-base gst-plugins-good gst-plugins-bad gst-plugins-ugly gst-libav ])
+  ++ lib.optionals gstreamerSupport      (with pkgs.gst_all_1;
+    [ gstreamer gst-plugins-base gst-plugins-good gst-plugins-ugly gst-libav 
+    (gst-plugins-bad.override { enableZbar = false; }) ])
   ++ lib.optionals gtkSupport    [ pkgs.gtk3 pkgs.glib ]
   ++ lib.optionals openclSupport [ pkgs.opencl-headers pkgs.ocl-icd ]
   ++ lib.optionals xmlSupport    [ pkgs.libxml2 pkgs.libxslt ]
diff --git a/pkgs/misc/tmux-plugins/default.nix b/pkgs/misc/tmux-plugins/default.nix
index 6c85f9a6329f..8d885cbf5169 100644
--- a/pkgs/misc/tmux-plugins/default.nix
+++ b/pkgs/misc/tmux-plugins/default.nix
@@ -1,4 +1,5 @@
 { fetchgit
+, fetchFromGitHub
 , lib
 , pkgs
 , reattach-to-user-namespace
@@ -90,6 +91,15 @@ in rec {
     };
   };
 
+  ctrlw = mkDerivation {
+    pluginName = "ctrlw";
+    src = fetchgit {
+      url = "https://github.com/eraserhd/tmux-ctrlw";
+      rev = "2354b5d56828813d0f7a4b228ca74b6134c2695f";
+      sha256 = "00hy1axmki8h2285mivsj923z327xkq89wfl2x4dxc71xjhdl216";
+    };
+  };
+
   fpp = mkDerivation {
     pluginName = "fpp";
     src = fetchgit {
@@ -215,6 +225,16 @@ in rec {
     };
   };
 
+  tmux-colors-solarized = mkDerivation {
+    pluginName = "tmuxcolors";
+    src = fetchFromGitHub {
+      owner = "seebi";
+      repo = "tmux-colors-solarized";
+      rev = "e5e7b4f1af37f8f3fc81ca17eadee5ae5d82cd09";
+      sha256 = "1l3i82abzi4b395cgdsjg7lcfaq15kyyhijwvrgchzxi95z3hl4x";
+    };
+  };
+
   urlview = mkDerivation {
     pluginName = "urlview";
     src = fetchgit {