about summary refs log tree commit diff
path: root/pkgs/misc
diff options
context:
space:
mode:
authorGuillaume Bouchard <guillaum.bouchard@gmail.com>2020-12-30 01:35:04 +0100
committerGitHub <noreply@github.com>2020-12-30 00:35:04 +0000
commit0c7b63e3025d3073b6ea118de9e4e1c6dd5e033f (patch)
tree0db0fccbf1b14a591c8dbb5c08b8ccf6369897a6 /pkgs/misc
parent97d0953f9d791211a13f552ff94833771d2f4c07 (diff)
downloadnixlib-0c7b63e3025d3073b6ea118de9e4e1c6dd5e033f.tar
nixlib-0c7b63e3025d3073b6ea118de9e4e1c6dd5e033f.tar.gz
nixlib-0c7b63e3025d3073b6ea118de9e4e1c6dd5e033f.tar.bz2
nixlib-0c7b63e3025d3073b6ea118de9e4e1c6dd5e033f.tar.lz
nixlib-0c7b63e3025d3073b6ea118de9e4e1c6dd5e033f.tar.xz
nixlib-0c7b63e3025d3073b6ea118de9e4e1c6dd5e033f.tar.zst
nixlib-0c7b63e3025d3073b6ea118de9e4e1c6dd5e033f.zip
duckstation: init at unstable-2020-12-29 (#107878)
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/emulators/duckstation/default.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/pkgs/misc/emulators/duckstation/default.nix b/pkgs/misc/emulators/duckstation/default.nix
new file mode 100644
index 000000000000..29b867f0e9e3
--- /dev/null
+++ b/pkgs/misc/emulators/duckstation/default.nix
@@ -0,0 +1,34 @@
+{ lib, mkDerivation, fetchFromGitHub, cmake, pkg-config, SDL2, qtbase
+, wrapQtAppsHook, qttools, ninja, gtk3 }:
+mkDerivation rec {
+  pname = "duckstation";
+  version = "unstable-2020-12-29";
+
+  src = fetchFromGitHub {
+    owner = "stenzek";
+    repo = pname;
+    rev = "f8dcfabc44ff8391b2d41eab2e883dc8f21a88b7";
+    sha256 = "0v6w4di4yj1hbxpqqrcw8rbfjg18g9kla8mnb3b5zgv7i4dyzykw";
+  };
+
+  nativeBuildInputs = [ cmake wrapQtAppsHook qttools ];
+
+  buildInputs = [ SDL2 qtbase gtk3 pkg-config ];
+
+  installPhase = ''
+    mkdir -p $out/
+    mv bin $out/
+  '';
+
+  # TODO:
+  # - vulkan graphics backend (OpenGL works).
+  # - default sound backend (cubeb) does not work, but SDL does.
+  meta = with lib; {
+    description =
+      "PlayStation 1 emulator focusing on playability, speed and long-term maintainability";
+    homepage = "https://github.com/stenzek/duckstation";
+    license = licenses.gpl3;
+    platforms = platforms.linux;
+    maintainers = [ maintainers.guibou ];
+  };
+}