about summary refs log tree commit diff
path: root/pkgs/misc
diff options
context:
space:
mode:
authorJean Potier <jpotier@users.noreply.github.com>2017-04-06 16:00:02 +0200
committerzimbatm <zimbatm@zimbatm.com>2017-04-06 15:00:02 +0100
commit09b1414acd7af2775414cbddd183db7b25697841 (patch)
tree654940162f6f6933a7d73b5a28a88b0716163b42 /pkgs/misc
parentbd948391e6196fbd4e1e666ddd96393f57cdb214 (diff)
downloadnixlib-09b1414acd7af2775414cbddd183db7b25697841.tar
nixlib-09b1414acd7af2775414cbddd183db7b25697841.tar.gz
nixlib-09b1414acd7af2775414cbddd183db7b25697841.tar.bz2
nixlib-09b1414acd7af2775414cbddd183db7b25697841.tar.lz
nixlib-09b1414acd7af2775414cbddd183db7b25697841.tar.xz
nixlib-09b1414acd7af2775414cbddd183db7b25697841.tar.zst
nixlib-09b1414acd7af2775414cbddd183db7b25697841.zip
cups-toshiba-estudio: init at 7.51 (#24676)
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/cups/drivers/estudio/default.nix54
1 files changed, 54 insertions, 0 deletions
diff --git a/pkgs/misc/cups/drivers/estudio/default.nix b/pkgs/misc/cups/drivers/estudio/default.nix
new file mode 100644
index 000000000000..6f9e4579a147
--- /dev/null
+++ b/pkgs/misc/cups/drivers/estudio/default.nix
@@ -0,0 +1,54 @@
+{ stdenv, fetchurl, perl }:
+
+stdenv.mkDerivation {
+  name = "cups-toshiba-estudio";
+  version = "7.51";
+
+  src = fetchurl {
+    url = http://business.toshiba.com/downloads/KB/f1Ulds/14079/TOSHIBA_ColorMFP_CUPS.tar;
+    sha256 = "3741bb79723495da5cb5a3971ae8c6042b6c71a6264af8f25aecf721f1f0752f";
+  };
+
+  buildInputs = [ perl ];
+
+  phases = [ "unpackPhase"
+             "patchPhase"
+             "installPhase" ];
+
+  patchPhase = ''
+    patchShebangs lib/
+    gunzip                share/cups/model/Toshiba/TOSHIBA_ColorMFP_CUPS.gz
+    sed -i "s+/usr+$out+" share/cups/model/Toshiba/TOSHIBA_ColorMFP_CUPS
+    gzip                  share/cups/model/Toshiba/TOSHIBA_ColorMFP_CUPS
+  '';
+
+  installPhase = ''
+    mkdir -p $out/lib/cups/filter
+    mkdir -p $out/share/cups/model/Toshiba
+    cp {.,$out}/lib/cups/filter/est6550_Authentication
+    chmod 755 $out/lib/cups/filter/est6550_Authentication
+    cp {.,$out}/share/cups/model/Toshiba/TOSHIBA_ColorMFP_CUPS.gz
+    chmod 755 $out/share/cups/model/Toshiba/TOSHIBA_ColorMFP_CUPS.gz
+  '';
+
+  meta = with stdenv.lib; {
+    description = "Printer only driver for the Toshiba e-STUDIO class of printers";
+    longDescription = ''
+      This driver supports the following printers: TOSHIBA e-STUDIO2000AC,
+      TOSHIBA e-STUDIO2005AC, TOSHIBA e-STUDIO2040C, TOSHIBA e-STUDIO2050C,
+      TOSHIBA e-STUDIO2055C, TOSHIBA e-STUDIO2500AC, TOSHIBA e-STUDIO2505AC,
+      TOSHIBA e-STUDIO2540C, TOSHIBA e-STUDIO2550C, TOSHIBA e-STUDIO2555C,
+      TOSHIBA e-STUDIO287CS, TOSHIBA e-STUDIO3005AC, TOSHIBA e-STUDIO3040C,
+      TOSHIBA e-STUDIO3055C, TOSHIBA e-STUDIO347CS, TOSHIBA e-STUDIO3505AC,
+      TOSHIBA e-STUDIO3540C, TOSHIBA e-STUDIO3555C, TOSHIBA e-STUDIO407CS,
+      TOSHIBA e-STUDIO4505AC, TOSHIBA e-STUDIO4540C, TOSHIBA e-STUDIO4555C,
+      TOSHIBA e-STUDIO5005AC, TOSHIBA e-STUDIO5055C, TOSHIBA e-STUDIO5506AC,
+      TOSHIBA e-STUDIO5540C, TOSHIBA e-STUDIO5560C, TOSHIBA e-STUDIO6506AC,
+      TOSHIBA e-STUDIO6540C, TOSHIBA e-STUDIO6550C, TOSHIBA e-STUDIO6560C,
+      TOSHIBA e-STUDIO6570C and TOSHIBA e-STUDIO7506AC.
+    '';
+    homepage = https://www.toshiba-business.com.au/support/drivers;
+    license = licenses.unfree;
+    maintainers = [ maintainers.jpotier ];
+  };
+}