about summary refs log tree commit diff
path: root/pkgs/misc
diff options
context:
space:
mode:
authorMarc Weber <marco-oweber@gmx.de>2008-04-11 10:22:52 +0000
committerMarc Weber <marco-oweber@gmx.de>2008-04-11 10:22:52 +0000
commit05ebf87bbf57e58a667e0fc07c04928af2d1bf3c (patch)
tree52b4dcc776d55e3486d0be9d1146877a6c2ebc56 /pkgs/misc
parent79bd6ee48ac29cef0bebf9416b0143ba2dbc44a4 (diff)
downloadnixlib-05ebf87bbf57e58a667e0fc07c04928af2d1bf3c.tar
nixlib-05ebf87bbf57e58a667e0fc07c04928af2d1bf3c.tar.gz
nixlib-05ebf87bbf57e58a667e0fc07c04928af2d1bf3c.tar.bz2
nixlib-05ebf87bbf57e58a667e0fc07c04928af2d1bf3c.tar.lz
nixlib-05ebf87bbf57e58a667e0fc07c04928af2d1bf3c.tar.xz
nixlib-05ebf87bbf57e58a667e0fc07c04928af2d1bf3c.tar.zst
nixlib-05ebf87bbf57e58a667e0fc07c04928af2d1bf3c.zip
missing files previous patch
svn path=/nixpkgs/trunk/; revision=11565
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/ghc68executables/default.nix56
-rw-r--r--pkgs/misc/ghc68extraLibs/hsql-mysql-patch73
2 files changed, 129 insertions, 0 deletions
diff --git a/pkgs/misc/ghc68executables/default.nix b/pkgs/misc/ghc68executables/default.nix
new file mode 100644
index 000000000000..bf7f145360bb
--- /dev/null
+++ b/pkgs/misc/ghc68executables/default.nix
@@ -0,0 +1,56 @@
+args: with args;
+     let inherit (bleedingEdgeRepos)  sourceByName;
+     in
+# map ghcCabalExecutableFun and add cabal dependency to all 
+lib.mapAttrs ( name_dummy : a : ghcCabalExecutableFun (a // { libsFun = x : (a.libsFun x) ++ [x.cabal_darcs]; } ) )
+{
+  happy = {
+    name = "happy-1.17";
+    libsFun = x : [x.base x.directory x.haskell98 x.mtl];
+    src = fetchurl {
+      url =  "http://hackage.haskell.org/packages/archive/happy/1.17/happy-1.17.tar.gz";
+      sha256 = "0aqaqy27fkkilj3wk03krx2gdgrw5hynn8wnahrkimg52xyy996w";
+    };
+    meta = {
+      executables = ["happy"];
+      description = "A lexical analyser generator for Haskell";
+      homepage = http://www.haskell.org/happy/;
+      license = "BSD3";
+    };
+    pass = {
+      patchPhase = '' sed -e "s/buildVerbose flags/fromFlag (buildVerbose flags)/g" -e "s/BuildFlags(..)/BuildFlags(..), fromFlag/g" -i Setup.lhs '';
+    };
+  };
+  alex = {
+    name = "alex-2.2";
+    libsFun = x : [x.base x.haskell98];
+    src = fetchurl {
+      url =  "http://hackage.haskell.org/packages/archive/alex/2.2/alex-2.2.tar.gz";
+      sha256 = "1zhzlhwljbd52hwd8dm7fcbinfzjhal5x91rvi8x7cgxdkyd8n79";
+    };
+    meta = {
+      executables = ["alex"];
+      description = "tool generating lexical analysers";
+      homepage = http://www.haskell.org/alex/;
+      license = "BSD3";
+    };
+    pass = {
+      patchPhase = '' sed -e "s/buildVerbose flags/fromFlag (buildVerbose flags)/g" -e "s/BuildFlags(..)/BuildFlags(..), fromFlag/g" -i Setup.lhs '';
+    };
+  };
+  xmonad = {
+    name = "xmonad-darcs";
+    libsFun = x : [x.base x.mtl x.unix x.x11 x.x11extras xmessage  ];
+    src = sourceByName "xmonad";
+  };
+  darcs_unstable = {
+    name = "darcs_unstable";
+    libsFun = x : [x.base x.haskell98 x.http_darcs x.regex_compat x.quickcheck x.bytestring x.parsec x.html x.containers];
+    src = sourceByName "pg_darcsone";
+    pass = {
+      buildInputs = [  autoconf zlib ];
+      postUnpack = "cd nix_*; pwd; autoconf; cd ..";
+        NIX_LDFLAGS = "-lz";
+    };
+  };
+}
diff --git a/pkgs/misc/ghc68extraLibs/hsql-mysql-patch b/pkgs/misc/ghc68extraLibs/hsql-mysql-patch
new file mode 100644
index 000000000000..d15004b0a183
--- /dev/null
+++ b/pkgs/misc/ghc68extraLibs/hsql-mysql-patch
@@ -0,0 +1,73 @@
+--- b/Setup.lhs	2008-04-04 19:21:06.000000000 +0200
++++ a/Setup.lhs	2008-04-04 19:43:42.000000000 +0200
+@@ -1,12 +1,14 @@
++-- packages: process, Cabal, directory, filepath
+ #!/usr/bin/runghc
+ 
+ \begin{code}
+ import Data.Maybe(fromMaybe)
+ import Distribution.PackageDescription
++import Distribution.Verbosity
++import Distribution.PackageDescription.Parse
+ import Distribution.Setup
+ import Distribution.Simple
+ import Distribution.Simple.LocalBuildInfo
+-import Distribution.Simple.Utils(rawSystemVerbose)
+ import System.Info
+ import System.Exit
+ import System.Directory
+@@ -15,19 +17,19 @@
+ import Control.Monad(when)
+ import Control.Exception(try)
+ 
++
+ main = defaultMainWithHooks defaultUserHooks{preConf=preConf, postConf=postConf}
+   where
+     preConf ::  [String] -> ConfigFlags -> IO HookedBuildInfo
+     preConf args flags = do
+       try (removeFile "MySQL.buildinfo")
+       return emptyHookedBuildInfo
+-    postConf :: [String] -> ConfigFlags -> PackageDescription -> LocalBuildInfo -> IO ExitCode
++    postConf :: [String] -> ConfigFlags -> PackageDescription -> LocalBuildInfo -> IO ()
+     postConf args flags _ localbuildinfo = do
+-      mb_bi <- mysqlConfigBuildInfo (configVerbose flags)
++      mb_bi <- mysqlConfigBuildInfo (fromFlag (configVerbose flags))
+       let default_binfo | os == "mingw32" = emptyBuildInfo{extraLibs=["libmySQL"], ccOptions=["-Dmingw32_HOST_OS"]}
+                         | otherwise       = emptyBuildInfo{extraLibs=["mysqlclient"]}
+       writeHookedBuildInfo "MySQL.buildinfo" (Just (fromMaybe default_binfo mb_bi),[])
+-      return ExitSuccess
+ \end{code}
+ 
+ The following code is derived from Distribution.Simple.Configure
+@@ -46,9 +48,9 @@
+   message ("Using " ++ name ++ ": " ++ path)
+   return (Just path)
+ 
+-rawSystemGrabOutput :: Int -> FilePath -> [String] -> IO String
++rawSystemGrabOutput :: Verbosity -> FilePath -> [String] -> IO String
+ rawSystemGrabOutput verbose path args = do
+-  when (verbose > 0) $
++  when (verbose > silent ) $
+         putStrLn (path ++ concatMap (' ':) args)
+   (inp,out,err,pid) <- runInteractiveProcess path args Nothing Nothing
+   exitCode <- waitForProcess pid
+@@ -67,7 +69,7 @@
+ 
+ Populate BuildInfo using pkg-config tool.
+ \begin{code}
+-mysqlConfigBuildInfo :: Int -> IO (Maybe BuildInfo)
++mysqlConfigBuildInfo :: Verbosity -> IO (Maybe BuildInfo)
+ mysqlConfigBuildInfo verbose = do
+   mb_mysql_config_path <- findProgram "mysql_config" Nothing
+   case mb_mysql_config_path of
+--- a/hsql-mysql.cabal	2008-04-07 17:36:32.000000000 +0200
++++ b/hsql-mysql.cabal	2008-04-07 17:34:17.000000000 +0200
+@@ -5,7 +5,7 @@
+ category:	 Database
+ description: 	 MySQL driver for HSQL.
+ exposed-modules: Database.HSQL.MySQL
+-build-depends: 	 base, hsql
++build-depends: 	 base, hsql, old-time
+ extensions:      ForeignFunctionInterface, CPP
+ cc-options: -IDatabase/HSQL
+ extra-source-files: Database/HSQL/HsMySQL.h